搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Credit card saving does not work

  • 16 个回答
  • 1 人有此问题
  • 11 次查看
  • 最后回复者为 jonzn4SUSE

more options

When entering credit card info in a web form, Firefox will pop up a dialog asking if I'd like to save the card info. If I click yes, the dialog closes but the info is not saved. If I go into settings where one can view the saved cards and enter the info to save a new one, I can enter one but again it does not actually save. There is no error, it just doesn't save. Tailing journalctl shows no errors, and launching Firefox from a console and watching the output doesn't show any error either.

It's been this way over several updates over the course of a few months (as long as I've been using Firefox on this computer).

所有回复 (16)

more options

What OS? What Desktop?

Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

由jonzn4SUSE于修改

有帮助吗?

more options

jonzn4SUSE said

What OS? What Desktop? Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Thanks for the reply, Jon.

OpenSuse, Plasma Desktop. (I thought that was in the Firefox-generated info thing I had it fill in...I don't see it shown though)

I tried as you suggested. I'm unable even to find the Saved Credit Cards section in the settings of this Firefox. It's just not there anymore.

有帮助吗?

more options

Note that in about:config extensions.formautofill.creditCards.enabled is true extensions.formautofill.creditCards.available is true extensions.formautofill.creditCards.hideui is false

有帮助吗?

more options

It's there in all my versions of Firefox. see screenshot

有帮助吗?

more options

Here is what I have in Nightly.

extensions.formautofill.creditCards.available true extensions.formautofill.creditCards.enabled false extensions.formautofill.creditCards.hideui false extensions.formautofill.creditCards.used 0

有帮助吗?

more options

Hmm, it's there now. Maybe I needed to restart. It was definitely not there before since search on "credit" in the settings never turned up anything.

But anyway, I tried adding a card and I'm getting the same result as with the other version from the OpenSuse repos (and also with a copy of Waterfox).

有帮助吗?

more options

Does anyone know where it would be trying to save CC info? The one I downloaded was not KDE specific so I assume it wouldn't be trying to use Akonadi (which incidentally, I don't have installed).

有帮助吗?

more options

I never used the option, but just tried it and I had to create a password for Keyring(pgp), but it worked. see screenshot

有帮助吗?

more options

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

有帮助吗?

more options

cor-el said

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.

Yeah, I tried that. See the first suggestion and my response to it. Same behavior.

有帮助吗?

more options

jonzn4SUSE said

I never used the option, but just tried it and I had to create a password for Keyring(pgp), but it worked. see screenshot

Interesting! Thanks for testing this out, Jon. When you say "had to create a password for Keyring" do you mean that when you first tried saving a CC something prompted you to create the password or at least tell you that you needed to do this first? Or did it just not work (like what I described) prior to you creating the password?

And when you say "Keyring" what are you referring to? I noticed you capitalized it... Is it part of your DE, and if so, which?

有帮助吗?

more options

Here is a shot of the keyring that popup when I entered my credit card info. see screenshot

由jonzn4SUSE于修改

有帮助吗?

more options

I also ran a test on Amazon with the credit card(AMEX) autofill and it worked. I'm using Nightly on openSUSE.

有帮助吗?

more options

jonzn4SUSE said

Here is a shot of the keyring that popup when I entered my credit card info. see screenshot

So these just pop up automatically when you save a CC? Is this something you know how to navigate to via something else (setting, yast, etc.) I suspect that this is gnome-keyring, and part of your DE, and not part of mine (Plasma).

有帮助吗?

more options

Eric S said

I suspect that this is gnome-keyring, and part of your DE, and not part of mine (Plasma).

This seems to be the case, as this bugzilla issue seems to confirm: Can't add credit card in Linux without Gnome Keyring

有帮助吗?

more options

I'm in Plasma.

Operating System: openSUSE Tumbleweed 20211125 KDE Plasma Version: 5.23.3 KDE Frameworks Version: 5.88.0 Qt Version: 5.15.2 Kernel Version: 5.15.3-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

由jonzn4SUSE于修改

有帮助吗?

我要提问

你必须登录到你的账号才能回复。如果你还没账号,请提出一个新问题