搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Firefox Bookmarks, Tools, History Window Not Coming On Top

  • 4 个回答
  • 1 人有此问题
  • 48 次查看
  • 最后回复者为 ahmmad.ismail

more options

I am using:

  • Mozilla Firefox 94.0
  • Linux Mint 20.2
  • Linux Kernel 5.4.0-90-generic

In Firefox, the issue is with

  • Bookmarks > Manage Bookmarks
  • Tools > Downloads
  • History > Show All History

If I have opened Bookmarks then for some reason minimized the window , or clicked somewhere so the Bookmarks window is in the background , and I again click `Bookmarks > Manage Bookmarks` , nothing happens . My expectation in the Bookmark Window will come on top.

This is true for Download and History window as well.

If I have opened Bookmarks / Download / History then for some reason minimized the window , or clicked somewhere so the Bookmarks / Download / History window is in the background , and I again click `Bookmarks > Manage Bookmarks` or `Tools > Downloads` or `History > Show All History` nothing happens . My expectation in the Menu option I clicked, its Window will come on Top.

Just to be clear I have even tried by clicking `Always on Top` on the Bookmarks / Download / History window.

Why this is not happening?

I am using: * Mozilla Firefox 94.0 * Linux Mint 20.2 * Linux Kernel 5.4.0-90-generic In Firefox, the issue is with * Bookmarks > Manage Bookmarks * Tools > Downloads * History > Show All History If I have opened Bookmarks then for some reason minimized the window , or clicked somewhere so the Bookmarks window is in the background , and I again click `Bookmarks > Manage Bookmarks` , nothing happens . My expectation in the Bookmark Window will come on top. This is true for Download and History window as well. If I have opened Bookmarks / Download / History then for some reason minimized the window , or clicked somewhere so the Bookmarks / Download / History window is in the background , and I again click `Bookmarks > Manage Bookmarks` or `Tools > Downloads` or `History > Show All History` nothing happens . My expectation in the Menu option I clicked, its Window will come on Top. Just to be clear I have even tried by clicking `Always on Top` on the Bookmarks / Download / History window. Why this is not happening?

被采纳的解决方案

I'm not able to reproduce the issue. Do you have the same issue with Firefox in Safe Mode? What Desktop?

Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Operating System: openSUSE Tumbleweed 20211116 KDE Plasma Version: 5.23.2 KDE Frameworks Version: 5.88.0 Qt Version: 5.15.2 Kernel Version: 5.14.14-3-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

在上下文中阅读这个答案 👍 1

所有回复 (4)

more options

选择的解决方案

I'm not able to reproduce the issue. Do you have the same issue with Firefox in Safe Mode? What Desktop?

Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Operating System: openSUSE Tumbleweed 20211116 KDE Plasma Version: 5.23.2 KDE Frameworks Version: 5.88.0 Qt Version: 5.15.2 Kernel Version: 5.14.14-3-default (64-bit) Graphics Platform: X11 Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

由jonzn4SUSE于修改

more options

You are right. installed another version. solved my problem.

Thank you very much.

more options

The guys here told me to use Mozilla version many months ago and I've not gone back to my distro version. Nightly is my daily driver, but I have the distro version and a separate version for troubleshooting and as a backup for my synced items.

more options

Yes, I installed using tar.gz ``` $ sudo apt remove firefox

$ tar xjf firefox-*.tar.bz2 $ sudo mv firefox /opt/firefox $ sudo ln -s /opt/firefox/firefox /usr/bin/firefox

$ sudo tee -a /usr/share/applications/Firefox.desktop << END [Desktop Entry] Version=1.0 Name=Firefox Web Browser Comment=Browse the World Wide Web GenericName=Web Browser Keywords=Internet;WWW;Browser;Web;Explorer Exec=/opt/firefox/firefox %u Terminal=false X-MultipleArgs=false Type=Application Icon=firefox Categories=GNOME;GTK;Network;WebBrowser; MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall; StartupNotify=true Actions=new-window;new-private-window;

[Desktop Action new-window] Name=Open a New Window Exec=firefox -new-window

[Desktop Action new-private-window] Name=Open a New Private Window Exec=firefox -private-window END ``` Not sure if it will update properly or not. But my firefox is working smoothly.

由ahmmad.ismail于修改