搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Latest version of Firefox keeps disabling my themes.

  • 8 个回答
  • 2 人有此问题
  • 8 次查看
  • 最后回复者为 rlnoonan

more options

I have been using custom themes in Firefox for quite some time with no problems, it is one of the things that I really like about Firefox. I use different themes for each device I run Firefox on (animated themes on my faster computer, non-animated on my slower machine).

As of the last update to Firefox (or possibly the one before that) my themes constantly get disabled automatically. I am currently using Firefox Quantum 66.0.2 (64-bit). On one machine I am running Windows 10 and another I'm running Windows 7.

I've been trying to determine the circumstances that cause the theme to be disabled, but I'm not certain yet. I can close Firefox and re-open it and it still works sometimes (sometimes not). I have seen the theme disable while I was using Firefox, as it it just switched off. One possible cause that I am still testing out is whether it is tied to the different themes on different devices. Both devices end up getting their theme disabled, but possibly the trigger for the disable comes when I enable a different theme on a different device. I'll report back when I have tested more. I specifically have turned off sync'ing settings so that I can have different themes (and home pages), and that has worked fine for quite some time. Maybe the themes are now sync'ing regardless of this setting?

I did see a response to this issue elsewhere, and it was mentioned that this can happen if there is a problem with the extensions.json file or the prefs.js file in the profile folder. I don't that this is happening here because I looked at those files and don't see any problem with them (what should we look for to determine a problem with those files?). Plus the fact that this is occurring on multiple machines makes it unlikely that they both have file corruption.

Thanks for any help.

所有回复 (8)

more options

Where are you getting your theme from?

more options

I get all of my themes from addons.mozilla.org (where the Add-ons Manager searches).

A quick update on my issue: I tried setting the theme on both machines to the same thing and it has stayed enabled all weekend long. I'm going to try setting the two machines to different themes now to see if it disables again. I'll report the results back here.

more options

Try to toggle the two sync prefs on the about:config page to prevent Sync from interfering with the theme selection.

  • services.sync.prefs.sync.lightweightThemes.selectedThemeID = false
  • services.sync.prefs.sync.lightweightThemes.usedThemes = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

OK, that was quick! I set the theme on one machine to a different theme from the other machine and when I checked the original machine, it's theme had been disabled (no need to close Firefox either, is just disabled it while it was sitting there). So I think that explains why the themes were getting disabled, what I don't understand is why this is all of sudden happening. I have had different themes on separate machines for months. When I checked my account sync settings, I do have "Add-ons" checked. I have always had that checked so that I can keep the add-ons (especially extensions) that I have installed in sync. I have "Options" unchecked, and in the past, this is what allowed me to have separate themes. I'll try unchecking "Add-ons" to see if that allows me to go back to separate themes.

more options

cor-el said

Try to toggle the two sync prefs on the about:config page to prevent Sync from interfering with the theme selection.
  • services.sync.prefs.sync.lightweightThemes.selectedThemeID = false
  • services.sync.prefs.sync.lightweightThemes.usedThemes = false

OK, thanks for the suggestion. I tried this and set machine one to the "Galaxy Green" theme. I then went to machine two and also set the above and then set the theme to "Animated Matrix". Within seconds the theme got changed to "Galaxy Green" on machine two. Machine one still has the "Galaxy Green" theme. So a little bit of progress (at least it doesn't go to default), but I still can't seem to keep separate themes. Do you think I need to uncheck "Add-ons" in my account sync settings?

more options

See also:

  • Bug 1539444 - Theme sync disabling preference (services.sync) broke somewhere around Firefox v65/v66
more options

cor-el said

See also:
  • Bug 1539444 - Theme sync disabling preference (services.sync) broke somewhere around Firefox v65/v66

Thanks, I'll check that out. Just a quick note, I tried again and the result was the same as the original problem. I set machine two to use "Animated Matrix" and a short while later machine one went back to "Default" (machine two stayed at "Animated Matrix").

While I'm checking out the bug report, I'm going to try unchecking "Add-ons" to see if it works.

more options

I checked out the bug report and it sounds like it is pretty much exactly the issue I'm having here. Thanks for the pointer.

An important update: I unchecked "Add-ons" in the account sync options and the problem seems to have gone away. I've had "Green Galaxy" working on machine one and "Animated Matrix" working on machine two for well over a day now. Not ideal, since it doesn't allow me to keep my extensions in sync, but I since I have most things set up how I like them, I can just re-check when I make changes to the extensions.

Thanks for all the help. Hopefully the bug gets fixed and I can go back to the old way, but this is an acceptable workaround for now.