搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Office 365 document theme

  • 7 个回答
  • 1 人有此问题
  • 12 次查看
  • 最后回复者为 Spinnekop

more options

When I access my office 365 documents in Firefox (61 on Arch Linux with KDE Plasma desktop) it seems to apply a theme to the document. For example, a new doc has a grey rather than white background. If I use a dark theme the doc is dark grey with white text. It is black text on white in Chrome. Any ideas?

When I access my office 365 documents in Firefox (61 on Arch Linux with KDE Plasma desktop) it seems to apply a theme to the document. For example, a new doc has a grey rather than white background. If I use a dark theme the doc is dark grey with white text. It is black text on white in Chrome. Any ideas?

所有回复 (7)

more options

Hmm, usually Firefox themes do not affect web content. I don't think Office365 could detect your theme, either.

Are you using any custom style rules in a userContent.css file?

more options

Not that I know of. Attached two screenshots - one from firefox and one from chromium of the same document. The formatting of the firefox version is wrong - background is grey and no bullets.

more options

Thanks for the screenshots.

Background Color

That is puzzling. Judging by the rules I see in the page, the background color of the document should be white. (First screen shot, from Fx61/Windows.)

Since all your other colors look normal, I can't think of a Firefox setting that would be responsible (those settings would affect numerous areas of the page).

Is this the only site affected by that shade of gray?

List Bullets

Word documents use a symbol character to generate the dot. In your screenshot, the font being used for the dot is missing that character. It seems the browser uses these fonts for the dot:

  • Symbol (if available)
  • Symbol_MSFontService (presumably a downloadable font)
  • Your default sans-serif font (may or may not have that character)

(See second screenshot)

The Symbol font might not be available on Linux; I have no idea. If it is missing, the downloadable font should be used unless font downloads are generally blocked, or unless Microsoft's font server is blocked (seems to be fs.microsoft.com), or unless there is an error in Microsoft's style sheet.

To see what font is being used, you can use the Page Inspector tool. To call that up, either:

  • "3-bar" menu button > Web Developer > Inspector
  • (menu bar) Tools > Web Developer > Inspector
  • (Linux) Ctrl+Shift+c

Firefox should open a panel in the lower part of the tab and activate "click to select." If you click on a bullet (or the bulleted item), Firefox should highlight the HTML of that area in the Inspector. You want to select the items that says class="ListMarker". Then on the right side, click the Fonts heading to show the actual font being used for the bullet.

more options

When you refer to a dark theme, do you mean a Linux theme? This setting may or may not be relevant to the themes you are using, but you could try it:

On the Preferences page:

  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type color and Firefox should filter the page down so you can easily find the "Colors" button. Go ahead and click that.

Try changing this setting:

"Override the colors specified by the page with your selections above"

Below that, it usually says

"Only with High Contrast themes"

Click that and change the setting to

"Never"

then click OK to finish the change.

Does that help at all?

Here's a screenshot of that part of the Colors dialog (I'm sure it's prettier on the Mac):

more options

Hi - thank you for your help. The fonts are calibri and times new roman which are both installed. If I open a document with libreoffice using times and make a bullet list it is fine. Also, the color suggestion made no difference. btw. I tried a different version of linux, ubuntu, and it is doing the same thing. I also restarted firefox in 'safe mode' in case an extension was the problem but didn't help.

It is fine in windows so must be a problem with the linux version of firefox. linux chrome fine windows firefox fine linux firefox not fine!

more options

Since I can't easily test Ubuntu myself (I don't think), could you take 5 minutes and:

New Profile Test

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Click the Create a New Profile button, then click Next. Assign a name like June2018, ignore the option to relocate the profile folder, and click the Finish button.

After creating the profile, scroll down to it and click the Set as default profile button below that profile, then scroll back up and click the Restart normally button. (There are some other buttons, but please ignore them.)

Firefox should exit and then start up using the new profile, which will just look brand new. If asked whether you want to Sync or enable extensions, just ignore those for now.

If you load the document in this profile, are there any differences related to the background color or bullets?

When you are done with the experiment, open the about:profiles page again, click the Set as default profile button for your normal profile, then click the Restart normally button to get back to it.

Thanks.

由jscher2000 - Support Volunteer于修改

more options

Hi - sorry, I have been away for two weeks holiday.

Did as you suggested with the profiles - made no difference.

Honestly, for the limited number of times I need to use office365 I will just use chromium browser... it's really not worth the struggle.

Thanks for all of your suggestions.

Best wishes

Paul