搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Settings > General > Tabs> When you open a link in a new tab, switch to it immediately.

  • 7 个回答
  • 2 人有此问题
  • 27 次查看
  • 最后回复者为 tenbbs

more options

Can you please fix the Settings under General > Tabs > When you open a link in a new tab, switch to it immediately? Even if it is unchecked, it always switches immediately to the new tab.

所有回复 (7)

more options

Is it happening after right-clicking the link and choosing "Open in new tab" or after middle-clicking the link?

more options

Firefox has different behaviors depending on how/why the new tab was opened. You could try changing more settings as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste inback and pause while the list is filtered

(3) Double-click the following preferences to switch the value from false to true as desired:

  • browser.tabs.loadInBackground - when you right-click > Open Link in New Tab, or Ctrl+click, or middle-click a link (default = true)
  • browser.tabs.loadDivertedInBackground - when a link was coded to launch in a new window and Firefox switched it to a new tab instead (default = false)
  • browser.tabs.loadBookmarksInBackground - when you direct a bookmark to a new tab (e.g., using right-click > Open in New Tab, or Ctrl+click, or middle-click a bookmark) (default = false)
more options

jscher2000 - Your solution fixed half of my problem, I'm wondering if you can help solve the other half.

W10 Up to date, FFQ 63.0.1 64bit.

I already had the somewhat misleading/non-functional Options>General>"When you open a link in a new tab, switch to it immediately" - Un-checked. Still, links in YM and outlook.live.com always stole the focus and opened a new tab and made it the foreground.

Per your suggestion I switched browser.tabs.loadDivertedInBackground to True, and that made links in Yahoo mail, and in the /preview/ pane of outlook.live.com open in a new tab, in the background. This is the desired behavior and I thank you for your tip.

However, something has changed either in the last update to FFQ or in the new outlook.live.com interface because:

When I double-click an outlook.live.com email, it opens in it's own bespoke window (the kind that does not have Fwd/Back/Reload buttons, or tabs in the top block of the window.

Previously if I selected a link from this window, it would open in a new tab, but not steal the focus (the message window stayed on top and the new tab loaded as a background item). This was the desired behavior.

Today, even after the above settings changes, when a link is selected from the new window, it opens the link in a new tab but it steals the focus to the new tab, and throws the message window into the background.

It did not do this just a couple days ago.

How do I fix this issue?

more options

Hi tenbbs, when a website specifies a custom window size or disables one or more bars, Firefox doesn't divert it to a tab. There is an override for that (it's under B, but I'm describing all three preferences for context):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste neww and pause while the list is filtered

(3) Adjust the preferences as follows:

(A) browser.link.open_newwindow - for links in Firefox tabs

  • 3 = divert new window to a new tab (default)
  • 2 = allow link to open a new window
  • 1 = force new window into same tab

(B) browser.link.open_newwindow.restriction - for links in Firefox tabs

  • 0 = apply the setting under (A) to ALL new windows (even script windows) => try this setting
  • 2 = apply the setting under (A) to normal windows, but NOT to script windows with features (default)
  • 1 = override the setting under (A) and always use new windows

(C) browser.link.open_newwindow.override.external - for links in other programs

  • -1 = apply the setting under (A) to external links (default)
  • 3 = open external links in a new tab in the last active window
  • 2 = open external links in a new window
  • 1 = open external links in the last active tab replacing the current page [not recommended!]
more options

jscher,

Thank you for the info, but I think there was a miscommunication there.

I'll try be more clear.

I login to my mail on outlook.live.com

I doubleclick an email in the inbox - this pops that email out into its own custom sized window with no Fwd/Back buttons. (This is the desired behavior)

I single-left-click a link in that custom window - The new link is opened as a tab, in the main browser window, BUT the main browser window and the new tab are brought into the foreground. This last piece, is a change from whatever existed a week ago.

A week ago, I could perform the same steps, single-left-click a link in the custom window, the new link would opened as a tab, in the main browser window, and the email in the custom window would stay in the foreground. This is the desired behavior that I want to get back to.

-tenbbs

more options

Hi tenbbs, I thought you wanted to get rid of the popup. To keep the popup but make it behave a bit more like a regular window so it can have multiple tabs, force the toolbar as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste window_open and pause while the list is filtered

(3) Double-click the dom.disable_window_open_feature.toolbar preference to switch the value from false to true -- this disables websites from creating popups that don't have the main toolbar

After this change, popups should always have the full main toolbar AND a tab bar, which will enable links in the popup to open in the popup. As a result, however, the bottom of some pages may be cut off, pushed out of view by the additional bars, if the site suppressed scroll bar. Hopefully in that case you'll be able to expand the window by hand.

more options

jscher,

No, we still missed the point there, although I think I have found a solution on my own. I will restate the issue in a different way.

1) I login to outlook.live.com - Good 2) I double-click a message in the inbox, this opens that message in a new custom pop-out window (custom window size) with no tabs or Fwd/Back buttons at the top - Good 3) I left-click a link in that pop-out window, which opens in a new tab in the main browser window, - Good 4) AND the main browser window then moves to the foreground - BAD.

As it turns out, this behavior is not expressly driven by Firefox, but rather it's driven by Microsoft having completely rewritten the interface in outlook.live.com

About 1 1/2 weeks ago, at the same time the latest Firefox update was issued, MS went live with their new outlook.live.com email interface.

Prior to the outlook.live.com interface change, step 4 of my above situation was: 4) and the pop-out window stays in the foreground, and the main browser and newly opened tabs stay in the background. - GOOD.

The use model for this was, open a newsletter with maybe 20 links to different stories, select 4 or 5 of the stories I'm interested in, and then delete the newsletter and go back and read each of the 4 or 5 stories which were waiting in the main browser window for me.

The outlook.live.com interface change means each time a new link is selected, I have to Alt-Tab back to the custom window, select the next story I want to read later, Alt-Tab back to the custom window, and repeat until I've selected all of the stories I'm interested in.

The fix which I have to this admittedly very narrow problem, was found after I had a couple email exchanges with the MS/outlook tech support folks. They shared a link to the old-interface of outlook.live.com which is still alive but now requires a special link to land on it. Once I got the old-interface loaded up, all steps, including step 4 above, worked as desired, as they always did. So my squawk, as it turns out, was not a Firefox issue, but was an outlook.live.com issue.

The link to the old interface, for anyone who uses Hotmail or any of the other outlook.live.com email services, is: https://outlook.live.com/owa/?path=/fb

jscher, thank you for your repeated attempts to get me on the right path - but as it turns out, FF was not the issue :)