搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Gifs have stopped moving in new firefox

more options

I updated to the brand new shiny firefox and... gifs won't play anymore. Like at all. I checked my add-ons because I originally had some that stop GIFs and give you a little play/pause button on the top corner, just to be sure it wasn't the add-on and the new firefox being incompatible. But even after an uninstall of ANY and ALL gif-related add-ons, GIFs won't play at all or load as anything but a still image. I have resorted to copying the image link and pasting it into another program to get it to play. I'm on Windows 10 and Firefox just updated to Quantum v. 57.0 for reference. The gif problem started immediately after that update to quantum 57.0.

I updated to the brand new shiny firefox and... gifs won't play anymore. Like at all. I checked my add-ons because I originally had some that stop GIFs and give you a little play/pause button on the top corner, just to be sure it wasn't the add-on and the new firefox being incompatible. But even after an uninstall of ANY and ALL gif-related add-ons, GIFs won't play at all or load as anything but a still image. I have resorted to copying the image link and pasting it into another program to get it to play. I'm on Windows 10 and Firefox just updated to Quantum v. 57.0 for reference. The gif problem started immediately after that update to quantum 57.0.

被采纳的解决方案

Are they are plain old animated GIFs like the following, or are they "GIFv" files (for example, on Imgur) that run as an MP4 video?

Firefox has a built-in preference for animated GIFs that can stop them on the first frame. I don't know why that would suddenly be enabled after an update but you can check whether that is the issue:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste anim and pause while the list is filtered

(3) If the image.animation_mode preference is bolded and "modified" or "user set" to none, right-click it and choose Reset to restore the default value of normal

(If you change that, reload a page to try the GIF again.)

If that is not the source of the issue, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

定位到答案原位置 👍 4

所有回复 (3)

more options

选择的解决方案

Are they are plain old animated GIFs like the following, or are they "GIFv" files (for example, on Imgur) that run as an MP4 video?

Firefox has a built-in preference for animated GIFs that can stop them on the first frame. I don't know why that would suddenly be enabled after an update but you can check whether that is the issue:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste anim and pause while the list is filtered

(3) If the image.animation_mode preference is bolded and "modified" or "user set" to none, right-click it and choose Reset to restore the default value of normal

(If you change that, reload a page to try the GIF again.)

If that is not the source of the issue, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

The about:config solution worked great, thank you. I don't know how it got toggled, I haven't gone into about:config in ages.

To answer your question (for future users) no, I am 100% sure they were GIFs, I copied the image location and pasted them into my Telegram window just to make sure I was looking at GIFs and not still images. But they moved when I put them into Telegram, and that's how I figured out it was firefox that was the problem.

more options

After re-reading your original post, I think your previous add-on may have switched the value of that preference in order to take control of animated GIFs so they would only play them on demand. If that was an important feature for you, hopefully a new one will come along that is compatible with Firefox 57.