搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Cannot play video on Firefox 57.0 (64-bit)

  • 4 个回答
  • 13 人有此问题
  • 27 次查看
  • 最后回复者为 fischlefutter

more options

Prior to Firefox version 57.0 (64-bit), I was able to play videos from YouTube or any sites that has a video embedded on the webpage.

After Firefox updated to version 57.0, I am no longer able to play videos. There is video and audio but the video is displaying green images (see attached file or https://i.imgur.com/axYi0jX.jpg). The videos from YouTube, CNN, Fox, etc are all playing fine on Microsoft Internet Explorer except for Firefox.

It looks like something in version 57.0 has changed. The previous version plays videos fine.

Prior to Firefox version 57.0 (64-bit), I was able to play videos from YouTube or any sites that has a video embedded on the webpage. After Firefox updated to version 57.0, I am no longer able to play videos. There is video and audio but the video is displaying green images (see attached file or https://i.imgur.com/axYi0jX.jpg). The videos from YouTube, CNN, Fox, etc are all playing fine on Microsoft Internet Explorer except for Firefox. It looks like something in version 57.0 has changed. The previous version plays videos fine.
已附加屏幕截图

所有回复 (4)

more options

hi, we are currently aware of this issue on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue.

otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

more options

FFox 57 x64 under Win 8 x64 on an Acer Aspire E1-522 with AMD Radeon HD 8240 and latest drivers (AMD 12.102.1.0) produced the same messy picture.

Refreshing Firefox made videos play properly, but only while that copy of Firefox was running. When stopped and re-started, the problem returned.

Philipp's config work around (above) solved the problem and restored sanity. Thank you.

more options

philipp said

hi, we are currently aware of this issue on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue. otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

I have a similar problem with firefox 57.0 on an older 64Bit Linux System. It is not possible for me to play e.g. https://www.youtube.com/watch?v=islcMmfHHqE even though "Der HTML5-Videoplayer wird derzeit bei jeder möglichen Gelegenheit verwendet. " is switched on shown here: https://www.youtube.com/html5 . I tried erasing the profile in .mozilla and therefore a complete new profile - does not help. I can play https://www.youtube.com/watch?v=gCcx85zbxz4 .

Pulse Audio 4.0.git.270.g9490a-20.1 is installed. Graphic card is an older nVidia GTX570. I am able to play test films like big_buck_bunny_1080p_h264.mov from here : https://download.blender.org/peach/bigbuckbunny_movies/ with mplayer. If this is the wrong thread please point me to the corresponding one.

由fischlefutter于修改

more options

fischlefutter said

philipp said
hi, we are currently aware of this issue on some windows 8 configurations with amd graphics cards and older drivers. please see if there's a more recent graphics driver available for your system at https://support.amd.com/en-us/download and if installing that already solves the playback issue. otherwise you can do the following to work around the problem: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named media.windows-media-foundation.use-nv12-format. double-click it and change its value to false.

I have a similar problem with firefox 57.0 on an older 64Bit Linux System. It is not possible for me to play e.g. https://www.youtube.com/watch?v=islcMmfHHqE even though "Der HTML5-Videoplayer wird derzeit bei jeder möglichen Gelegenheit verwendet. " is switched on shown here: https://www.youtube.com/html5 . I tried erasing the profile in .mozilla and therefore a complete new profile - does not help. I can play https://www.youtube.com/watch?v=gCcx85zbxz4 .

Pulse Audio 4.0.git.270.g9490a-20.1 is installed. Graphic card is an older nVidia GTX570. I am able to play test films like big_buck_bunny_1080p_h264.mov from here : https://download.blender.org/peach/bigbuckbunny_movies/ with mplayer. If this is the wrong thread please point me to the corresponding one.

Bump. No information about this topic?