搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

firefox seems to be removing the colon in url during redirects

  • 12 个回答
  • 1 人有此问题
  • 10 次查看
  • 最后回复者为 Kap2017jan8

more options

When clicking a link to a webpage, firefox gives the error about redirecting and page won't load. http and https doesn't matter. When looking at the url remaining in the address field, it is missing the colon. When the colon is re-inserted the page loads correctly. What is causing this? Not all links are working this way. thanks

所有回复 (12)

more options

Can you post some examples?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Does it help if you allow redirecting?

See:

  • "3-bar" menu button -> Options/Preferences -> Advanced -> General
    Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Options/Preferences -> Advanced -> General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

more options

FredMcD said

Can you post some examples? Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Started in safe mode, problem persists. Colon still missing in action after clicking links. This happening in forum sites for embedded links in messages.

more options

cor-el said

Does it help if you allow redirecting? See:
  • "3-bar" menu button -> Options/Preferences -> Advanced -> General
    Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"
The setting in "Options/Preferences -> Advanced -> General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting. See also:
more options

cor-el said

Does it help if you allow redirecting? See:
  • "3-bar" menu button -> Options/Preferences -> Advanced -> General
    Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"
The setting in "Options/Preferences -> Advanced -> General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting. See also:

Thank you, but did not solve problem of colon going missing after clicking a link. Links are in forum sites and are embedded links in message read fields.

more options

What colon is missing?

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB
more options

FredMcD said

Can you post some examples?
more options

cor-el said

What colon is missing? Can you attach a screenshot?
  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB

In the address field the colon is missing between the http/https and the // slashes. ex: http//support.mozilla.

Putting it back works every time to go to destination of original link.

more options

Kap2017jan8 said

cor-el said
What colon is missing? Can you attach a screenshot?
  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB

In the address field the colon is missing between the http/https and the // slashes. ex: http//support.mozilla.

Putting it back works every time to go to destination of original link.

I believe its definitely firefox as I've used Opera and IE successfully with this forum site page. The link itself is an embedded url in a message field that typically opens automatically as an image when one reads the message. I have those suppressed in the forum personal settings as 'display embedded images' to off. When I turn the forum setting to on, the image displays correctly automatically. I do not want this setting on at all and much prefer the faster loading times of forum pages without it.

more options

Correction. This suppressed image setting link FAILED in opera and IE as well. Sorry about the misinformation. It's starting to point to the forum site as a bug maybe.

more options

You can use the Inspector to check the src attribute of the images. It is probably possible to come up with a bookmarklet or Greasemonkey script to fix the links if they are broken.

more options

cor-el said

You can use the Inspector to check the src attribute of the images. It is probably possible to come up with a bookmarklet or Greasemonkey script to fix the links if they are broken.
Next time I will do a more thorough testing procedure before coming to the mozilla site directly. It's looking more and more a outside forum site specific problem with handling links as I did almost all firefox/mozilla checks and fixes with no resolve with that forum site.

All other browsers have failed in the same way now, so I think that probably gets firefox off the hook. I will update this question and close it when if I get confirmation from the other problem forum site. Thanks everyone for the input so far.