搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Why does FF continually fill the exceptions box in Security, Content & Privacy with sites that I don't want. How do I stop this happening? Thanks

more options

Every day now I find that the Exceptions options in Security, Privacy and Content are filled with a list of blocked sites along with the exception of Security which adds the two approved FF / Mozilla sites for allowing addons. No offence but I don't want FF to decide what I should block and what I should allow so my question is how do I clear the sites and stop it filling up again. Thanks in advance - endee

Every day now I find that the Exceptions options in Security, Privacy and Content are filled with a list of blocked sites along with the exception of Security which adds the two approved FF / Mozilla sites for allowing addons. No offence but I don't want FF to decide what I should block and what I should allow so my question is how do I clear the sites and stop it filling up again. Thanks in advance - endee

被采纳的解决方案

Thanks for your interest but I've found the answer - they're populated by FF from "permissions.sqlite".

As for why v42? - because FF has now become a bloated pig.

Thank you - now marked solved.

在上下文中阅读这个答案 👍 0

所有回复 (12)

more options

For the different lists you mentioned:

  • On the Content panel of the Options page, there is no built-in feature to add sites to the popup or notification permission lists (other than through your interactive choice). An add-on or external security program may be modifying this list.
  • On the Privacy panel of the Options page, there is no built-in feature to add sites to the cookie permissions list (other than through your interactive choice). An add-on or external security program may be modifying this list.
  • On the Security panel of the Options page, it is normal for the Mozilla Add-ons site to be listed as site that has permission to install extensions, and not to list any other sites. When a page pushes an extension, you will be prompted to approve the installation using a drop-down panel from the address bar in that case. Adding a site to the list here only skips the first step of clicking an "Allow" button and not the main installation panel. It sounds as though you cannot permanently remove this site from the list.

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. Do any seem related to blocking or permissions? All extensions are optional. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement in regaining control of your settings?

more options

thanks but either I haven't explained myself or you mis-understand the question. Every day I get this (see attached jpgs). As you can see they are filled with sites I didn't put there so I assume FF is doing it. My question is how I do I stop them being added? If I remove them, close down FF then open up again they re-appear. I have no extensions or addons istalled in FF. No problem with PaleMoon, when i delete these lists in PM it stays deleted!

more options

another image - same thing only there are two "allow" as well as the scores of "block"-ed sites

more options

Firefox doesn't add sites to those lists unless you click an interactive button making a decision about the site.

For example, when a popup is blocked, an infobar often appears between the toolbar area and the top of the page with an option to Allow the popup. Or when you visit a site that wants to install an extension, a panel drops down from the address bar asking whether you want to allow it.

Since the default settings are to block popups and to block extensions from untrusted sites, Firefox nearly never would add a Block permission to those lists. In fact, there's no way to manually add a blocked site for software installation (as you can see, no Block button), so this is definitely unusual.

Do you have any security software that might be adding those???

Or, I hate to suggest it, could your computer be infected with a "fake AV" program that is trying to block you from replacing it with one of its competitors? This kind of program often aggressively advertises in popups that your computer is infected and demands a significant amount of money to clean it up. The sites on the blocked popups list certainly look very suspicious and when I try to visit them, OpenDNS has the first and fourth classified as malware distribution sites.


By the way, your Firefox reported that it is version 42. Is that correct?

Version 42 is not secure; Mozilla discloses security flaws after each new release. Is something holding you back from upgrading to Firefox 46? Please let us know so we can suggest solutions or workarounds. Or you can update now using the steps in this article: Update Firefox to the latest release.

If Help > About Firefox shows Firefox 46.0.1, you may need to clear the preference that is misreporting your version number. See: How to reset the default user agent on Firefox.

more options

You posted this question with a Firefox 42 version and that version probably creates the (two) allow exceptions automatically if the related xpinstall.whitelist.add.* prefs get reset. If you update the the current 46 release then this probably won't happen anymore.

more options

Thanks for your interest but I've found the answer - they're populated by FF from "permissions.sqlite".

As for why v42? - because FF has now become a bloated pig.

Thank you - now marked solved.

more options

选择的解决方案

Thanks for your interest but I've found the answer - they're populated by FF from "permissions.sqlite".

As for why v42? - because FF has now become a bloated pig.

Thank you - now marked solved.

more options

Did you delete permissions.sqlite and the problem went away permanently, or does the problem return?

Normally when you clear permissions through the user interface, they are removed from permissions.sqlite. Sometimes sqlite files become corrupted or locked. Exiting Firefox, deleting the file and having Firefox create a new one at the next startup might help with that.

But the original source of the unwanted permissions is not from Firefox itself. As you can see in the attached, a new Firefox profile has a blank permissions.sqlite file.

more options

I edited the hostperm.1 & permissions.sqlite files to reflect my choices.

I find it hard to believe that FF is not responsible tho.

Hostperm.1 & permissions.sqlite contains all the sites I mention which are then added into the exclusions boxes in "content", "privacy" and "security".

If I'm wrong then can you tell me what is populating these if not FF?

Thanks

more options

Hi endee, the hostperm.1 file would be from an ancient version of Firefox. Anything in there probably is several years old now. Probably best to completely delete that file.

permissions.sqlite is a current Firefox settings file, so Firefox will use that file. However, it starts off blank and there's no mechanism for Firefox to add sites to the file without you taking interactive action. There are some cookie-related extensions ("TACO" extensions) that add site permissions related to cookies. I've never heard of any extensions adding site permissions related to pop-ups or add-on installation.

So that means the question of how those sites got into the file(s) is unanswered. Do they reappear each time you delete both files?

more options

Hi, they used to. If I deleted permissions it would re-appear - populated from the hostperm I would imagine. So I did a wee test - hung up from the 'net, deleted all the files in the three boxes, shut down FF then opened it again - all boxes re-populated. So some mechanism when FF starts instigates the population of the exceptions boxes. If I delete them they re-appear - usually within 24hr of the delete. Finally I edited both files - deleting all 57,000+ sites that were set to block leaving only the two FF "allowed" sites and set the check for update cycle to 1 year. Seems to be behaving itself now.

more options

Usually Firefox would only look for hostperm.1 if there was no permissions.sqlite file, for a "one time" conversion. That file may well have been hanging around with the garbage data for quite a while. Hopefully whatever generated that list is no longer on your system.