搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

SSL connection to google.com giving sec_error_unknown_issuer

  • 2 个回答
  • 54 人有此问题
  • 115 次查看
  • 最后回复者为 robbiem44

more options

When I try to hit google.com, I get the "Your connection is not secure," then under Advanced, get this:

www.google.com uses an invalid security certificate. The certificate is not trusted because the issuer certificate is unknown. The server might not be sending the appropriate intermediate certificates. An additional root certificate may need to be imported. (Error code: sec_error_unknown_issuer)

The certificate itself is issued by Websense Inc.

I have tried removing the cert8.db file, I've tried adding an exception. Nothing working.

Thanks

被采纳的解决方案

Got it. Basically, I had to export the signing certificate from Chrome (where it was working) and import from within Firefox, and I'm back in business.

Thanks.

在上下文中阅读这个答案 👍 7

所有回复 (2)

more options

If you have the option to set Websense not to intercept/filter secure connections, you could try that. It may depend on whether it's a personal Websense product or a company/enterprise product.

To make Firefox compatible with Websense filtering -- if tests with other secure sites confirm the same issuer and you trust this software -- you probably need to import the software's or proxy's signing certificate into Firefox's Certificate Manager on the Authorities tab. This thread has an example of how you could do that:

https://support.mozilla.org/questions/1089816

more options

选择的解决方案

Got it. Basically, I had to export the signing certificate from Chrome (where it was working) and import from within Firefox, and I'm back in business.

Thanks.