搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

I cannot make Firefox is my default browser

  • 10 个回答
  • 2 人有此问题
  • 50 次查看
  • 最后回复者为 FredMcD

more options

since Firefox as upgrade I have not been able to have Firefox as my default browser . Every time I start Firefox a window comes up and says Firefox is not my default browser I click to make Firefox my browser but if close Firefox I have the same problem .

所有回复 (10)

more options

Check in your system if Firefox is seted as default. If in your system Firefox is set as default maybe this message comes up because Firefox is forgetting that it is seted as default

more options

I've already done that few times and I still have the same problem. Even in the options it says my browser is not the deep fault one.

more options

But in your OS system ? Firefox is seted as default?

more options

as I no to yes

more options

Try to redo the default browser setting and temporarily set another browser as the default browser.

more options

i am still getting the same problem as before. I have tried ever think that people have suggested with no look. it is every Time I start up Firefox

more options

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release.

You can use this button to go to the currently used Firefox profile folder:

more options

I decided to on click the box where it says always make sure Firefox is my browser , and now I don't have that problem any more

more options

I have been having the same problem. I found one solution that said to go to the Mozilla folder in the Program Files folder, right-click the firefox.exe file, click Run as Administrator, then answer yes to setting Firefox as default. It worked, but only as far as running the exe was concerned. I used the right-click method with the desktop icon and the quick launch icon. Now, if i just click the QL icon or double-click the Desktop icon, I still have the problem, but if i right-click either icon and select run as administrator, Firefox launches showing set as default.

I call this a bug. Whether it's Vista's bug or Mozilla's bug I cannot say (though i lean to Vista's bug). I would like to resolve this issue, especially since all web page file icons show Firefox's icon instead of IE's icon, and double-clicking them launches Firefox. It is merely an annoyance having to deal with this every time I run Firefox.

more options

Close Firefox. If your computer has another web browser (example: Win IE) Open it. go to the settings and make that browser the default. If you want, turn off the check if default option. Once you are done, close the browser.

Now open Firefox. Type about:preferences#general<enter> in the address bar. Turn on Always Check Firefox Default Browser. Then press the button to make Firefox the default. Close Firefox. After a short time, restart FF.