搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Firefox crashes

  • 5 个回答
  • 6 人有此问题
  • 2 次查看
  • 最后回复者为 asbls

more options

Browser freezes up periodically and gives a (not responding) error. If I force close the program I get a "Firefox has stopped working" popup, and then a second popup that says "Plugin Container for firefox has stopped working". It happens constantly, whether I have 1 tab open or 10. It seems to especially happen if I load up a Youtube or Imgur page. Is there something to be done about this?

被采纳的解决方案

What time? It took me 20 minutes to respond :P I would be gettin' paid serious cash for the amount of time I spend here. But alas, working at Mozilla is but a dream for now :)


Most of your crash reports are expired or no longer in the system. One of the signatures is EMPTY which doesn't tell us anything and the last one is related to the Adobe Flash plug-in.

Two things you can try here: Try disabling Hardware Acceleration.

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.


Second, Try to disable Protected Mode in Flash 11.3 and above by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in one of these locations: [46]

   (Windows 32bit) C:\Windows\System32\Macromed\Flash 
   (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash 

For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. [47] [48] [49]

Note: To re-enable Flash Protected Mode, either restore a backup of the original mms.cfg file, if you saved one, or else re-edit the mms.cfg file to remove the ProtectedMode=0 l line you added. Updating Flash Player or installing a newer version does not automatically re-enable Protected Mode


In case you weren't aware, it looks like user.js is active. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can get to the profile folder below:

  • Help > Troubleshooting Information > Profile Directory > Show Folder

or

  • Go to about:support and click Show Folder next to Profile Directory.

If you added this file manually, just ignore this step. Usually users don't know they installed it.

在上下文中阅读这个答案 👍 2

所有回复 (5)

more options

Can you give me your crash reports?

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and paste them into your response here.
more options

Here you go. I appreciate your time!

Most recent first- bp-b1bb869d-b166-4b7f-acb5-b90502140724 bp-c2a80b22-fe7c-4bb6-93a1-9df7e2140724 bp-18996133-5008-468d-81a2-475c72121227 bp-37adaa7f-4176-4c59-83c1-875aa2121121 bp-3e91077a-208b-4042-a48e-bfbd32120925

more options

选择的解决方案

What time? It took me 20 minutes to respond :P I would be gettin' paid serious cash for the amount of time I spend here. But alas, working at Mozilla is but a dream for now :)


Most of your crash reports are expired or no longer in the system. One of the signatures is EMPTY which doesn't tell us anything and the last one is related to the Adobe Flash plug-in.

Two things you can try here: Try disabling Hardware Acceleration.

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.


Second, Try to disable Protected Mode in Flash 11.3 and above by adding the line ProtectedMode=0 to the Flash "mms.cfg" file located in one of these locations: [46]

   (Windows 32bit) C:\Windows\System32\Macromed\Flash 
   (Windows 64bit) C:\Windows\SysWOW64\Macromed\Flash 

For example, on a Windows 7 64-bit system, open the C:\Windows\SysWOW64\Macromed\Flash folder, copy the file "mms.cfg" to the desktop, open it in Notepad, add a new line ProtectedMode=0 and then close Notepad, saving your changes. Next, go back to the C:\Windows\SysWOW64\Macromed\Flash folder, rename the original file to "mms.cfgBAK" (to save it as a backup) and then drag and drop in the modified "mms.cfg" file from the desktop. [47] [48] [49]

Note: To re-enable Flash Protected Mode, either restore a backup of the original mms.cfg file, if you saved one, or else re-edit the mms.cfg file to remove the ProtectedMode=0 l line you added. Updating Flash Player or installing a newer version does not automatically re-enable Protected Mode


In case you weren't aware, it looks like user.js is active. The user.js file is only present if you or other software has created this file and normally it wouldn't be there.

You can delete a possible user.js file and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in the current Firefox release. You can get to the profile folder below:

  • Help > Troubleshooting Information > Profile Directory > Show Folder

or

  • Go to about:support and click Show Folder next to Profile Directory.

If you added this file manually, just ignore this step. Usually users don't know they installed it.

more options

Awesome, I've applied your fixes. So far so good- I'll report back tomorrow if it looks like the problem is solved. Thanks again!

more options

Looks like it's fixed- thanks a lot!