Firefox升级后附加组件被禁用

附加组件有问题?从 Firefox 57(发布于2017年11月14日)开始,只有使用 WebExtensions API,新的Firefox扩展技术 构建的附加组件才能工作。不清楚你的附加组件是否受到影响?请参看 Firefox 的附加组件技术正在现代化常见问题 来了解更多信息。

Firefox 更新时会自动检查并将附加组件更新到相应的兼容版本。如果附加组件无法更新或没有兼容版本,Firefox 会禁用它。本文将介绍如何让这些附加组件恢复正常工作。

Incompatible - Win
注意:如果附加组件被禁用并显示信息 (附加组件名称)无法被验证以在 Firefox 中使用,请参看 Firefox 中的附加组件签名

检查您的附加组件的新版本

Firefox 每天一次自动检查附加组件的新版本并更新它们,不过您也随时可以手动检查更新。

  1. 点击菜单按钮 new fx menu 打开菜单面板。
  2. 点击 附加组件 打开 附加组件管理器 页面。
  3. 点击该页面的 Add-on Tools Icon 并选择 检查更新。如果 Firefox 发现有更新就会自动下载。
    Extension Update Win 1
  4. 如果可以,点击 "立即重启以完成安装" 连接。
    Extension Update Win 2

在附加组件的网站上寻找更新

一些附加组件的开发者可能开发出适合于不同 Firefox 版本的附加组件版本,所以附加组件管理器可能无法更新它们。此时,附加组件的网站可能会有更新。

  1. 打开附加组件管理器标签页,点击不兼容组件上的更多,然后点击 主页 旁边的链接,这时候 Firefox 会带您到附加组件的网页。
  2. 在附加组件的主页上下载最新的版本。
注意:如果还是没有附加组件的版本可以正常工作,请联系附加组件的开发者以获得帮助。

寻找替代的附加组件

可能有兼容 Firefox 的附加组件与您这个不兼容的功能相似也说不定,您可以到 附加组件官网 找找看。

这篇文章对您有帮助吗? 请稍候...

这些人帮助撰写了这篇文章:YFdyh000, Kemcy Best, MichelleChen, Lazyking, longxi, wxie。你也可以提供帮助,来看看该怎么做