Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Èròjà atẹ̀lélànà yii ni a ti fi pamọ́ fọ́jọ́ pípẹ́. Jọ̀wọ́ béèrè ìbéèrè titun bí o bá nílò ìrànwọ́.

somehow yahoo made itself my deffault search engine when I type something other than an adress in the adress bar. how do i make google.com the default search engine again?

  • 5 àwọn èsì
  • 18 ní àwọn ìṣòro yìí
  • 38 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ clillis2240

more options

google is still my default search engine for the search bar. I would just like to know how to change the settings so that it is also the default search engine when searching from the address bar.

google is still my default search engine for the search bar. I would just like to know how to change the settings so that it is also the default search engine when searching from the address bar.

Ọ̀nà àbáyọ tí a yàn

All Replies (5)

more options

Hi clillis2240,

You should take a look at the Knowledge Base article Search with the Firefox address bar. It will show you how to change your default search provider.

Sites like MSN, Yahoo, etc have been know to ask to become your homepage and default search engine. Was your homepage changed too? If it was, take a look at How to set the home page.

There are steps in that article to reset your homepage preferences to default. I would try that first to clear out any strangeness. If that works, you can try setting your homepage again to your personal preference.

Hopefully this helps!

more options

thanks for the assistance, but i understand how to change the settings in the search bar at the upper right side of the window. The issue I am having is with the address bar. when I type anything other than a web address, Firefox automatically searches on Yahoo. I would prefer it to not go to Yahoo unless I direct it to Yahoo.

Ti ṣàtúnṣe nípa clillis2240

more options

Ọ̀nà àbáyọ Tí a Yàn

Hey clillis2240,

Thanks for clarifying. I should have caught that before ;) Still an easy fix!

https://support.mozilla.com/en-US/kb/Location%20bar%20search?s=address+bar+search&r=0&as=s#w_changing-the-internet-keyword-service

more options

Start Firefox in Diagnose Firefox issues using Troubleshoot Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

YOU SIR, are my hero!

thx!