Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

.ics no longer defaulting to Windows/Outlook

  • 9 àwọn èsì
  • 3 ní àwọn ìṣòro yìí
  • 311 views
  • Èsì tí ó kẹ́hìn lọ́wọ́ jfarrellengineering

more options

Hi everyone,

Up until the latest FF release, opening an .ics (calendar file) link defaulted to the OS's preferred application; in my case Outlook. Now, every time I click on an .ics link FF asks where I want to save the file. I schedule ZOOM meetings all day and heavily rely on this feature.

I tried looking in FF's Files and Applications section in settings and .ics is not even listed as a file extension. I don't know how to add it.

Any assistance is greatly appreciated.

Jose

Hi everyone, Up until the latest FF release, opening an .ics (calendar file) link defaulted to the OS's preferred application; in my case Outlook. Now, every time I click on an .ics link FF asks where I want to save the file. I schedule ZOOM meetings all day and heavily rely on this feature. I tried looking in FF's Files and Applications section in settings and .ics is not even listed as a file extension. I don't know how to add it. Any assistance is greatly appreciated. Jose

Ọ̀nà àbáyọ tí a yàn

You should be able to add that file type by using the procedure outlined in the link below. It worked in the thread linked below.

https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file#w_changing-download-actions https://support.mozilla.org/en-US/questions/1371626

Ka ìdáhùn ni ìṣètò kíkà 👍 3

All Replies (9)

more options

Use Edge for software related to Microsoft applications.

Helpful?

more options

WOW! what an answer on a FF forum. I'm speechless...

Helpful?

more options

Ọ̀nà àbáyọ Tí a Yàn

You should be able to add that file type by using the procedure outlined in the link below. It worked in the thread linked below.

https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file#w_changing-download-actions https://support.mozilla.org/en-US/questions/1371626

Helpful?

more options

Thank you @terry21. That solved it!

Helpful?

more options

Terry- said

You should be able to add that file type by using the procedure outlined in the link below. It worked in the thread linked below. https://support.mozilla.org/en-US/kb/change-firefox-behavior-when-open-file#w_changing-download-actions https://support.mozilla.org/en-US/questions/1371626

When I go to that section, .ics and calendar are not among the listed options, and there is no button to add a new file type. How do I do that?

Helpful?

more options

How do you add the .ics file type to the Content Type list? .ics is not there for me to select what to open it with.

Ti ṣàtúnṣe nípa chrissy3

Helpful?

more options

I used the procedure in the image below and that worked. You can't add a file type to the list. This seems like it should be more intuitive.

Helpful?

more options

The solution works.. BUT FF downloads the .ics file, then Outlook opens it. AFAIK, the link to the .ics file used to just open in Outlook. Now my downloads folder is cluttered with .ics files.

Anyone else notice this?

Helpful?

more options

Easiest solution: Select "Show all downloads" (in the downloads pulldown of the Firefox toolbar). Then right click the file you want to auto open and select "Always open similar files". Works instantly. You can also now see that file type in the Settings menu under General/Applications to change the action to other options.

Helpful?

Béèrè ìbéèrè

O gbọ́dọ̀ wọlé sí àkọ́ọ́lẹ̀ re láti fèsì àwọn ìfọ̀rọ̀ránṣẹ́. Jọ̀wọ́ bẹ̀rè ìbéèrè titun, bí o kò báìtí ní àkọ́ọ́lẹ̀ náà.