Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Èròjà atẹ̀lélànà yii ni a ti fi pamọ́ fọ́jọ́ pípẹ́. Jọ̀wọ́ béèrè ìbéèrè titun bí o bá nílò ìrànwọ́.

Microphone permissions

  • Kòsí àwọn èsì
  • 1 ní ìṣòro yìí
more options

Linux Mint several versions, Windows 10.

Microphone permissions do not get "remembered" properly. Microphone permissions exceedingly difficult to navigate through, to enable the microphone.

Have endured this one for several years, off and on, multiple versions of Firefox.

For some reason, Firefox prevents GLOBAL permissions for the microphone, and instead, causes us to have to chase down a specific site to give specific-site permission to, in order to use the microphone.

Even then, it doesn't work right, often enough to be problem. It is intermittent in occasionally "forgetting" that approval was given to a site. It also does not allow manual override in the form of typing in a site, and giving that site permission, without first being connected to that site, and using the bizarrely-arcane system of clicking on a small icon on the address bar to include the site, and again, this does not always work well, anyway.

Multiple interlocking difficulties/issues, one result, no mic at the time it's needed to communincate with someone, real-time.

Is there any way, PLEASE, to simply provide a GLOBAL switch for the microphone, to simply turn it on, for everybody, and everything? Something in about:config I could go to, and tell it to OVERRIDE all other considerations, and just let the microphone alone, and let me use it?

I compartmentalize my browsing to a significant degree, and the sites I visit with Firefox are quite limited (most of which is associated with a Google Voice account, but not every last bit of it), and even then, it is so fragmented and buggy, that I find myself again and again, talking to someone who cannot hear me, even though I'd jumped through every single hoop previously, and had everything working previously, until reverted inexplicably back to its bad old ways, silently, without warning, without advising me that something had changed. Private browsing is disabled, but I'm running several privacy extensions.

But again, it sure would be nice if I could just find, and invoke, a GLOBAL ALLOW switch for the microphone, set it one time, and forget about it thenceforth and forevermore.

Please do not refer me to the existing hoops to jump through. Please do not refer me to the little security icon in the address bar. Please do not refer me to any single web page which I must allow without allowing permission for ALL web pages. My familiarity with this end of the issue is beyond extensive. Been there. Done that. Over and over and over. And it works, and then it breaks once again.

To sum up: Please provide a GLOBAL OVERRIDE for the microphone to turn it on and then forget about it.

My very kindest thanks, in advance.