On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Awesome bar and search engines no longer work

  • 4 replies
  • 5 have this problem
  • 2 views
  • Last reply by Jack Yan

more options

Hi everyone: a few days ago, the Awesome Bar stopped working (if I feed in a new URL, and press enter, or the arrow, nothing happens), as well as the search engines (every search engine has disappeared, and restoring to default does nothing). I have deleted search.sqlite from Firefox’s profile folder, and it has made no difference. I cannot get to new search engines to add them for the simple reason that Firefox no longer lets me feed in addresses! I’d be interested to get your advice.

Hi everyone: a few days ago, the Awesome Bar stopped working (if I feed in a new URL, and press enter, or the arrow, nothing happens), as well as the search engines (every search engine has disappeared, and restoring to default does nothing). I have deleted search.sqlite from Firefox’s profile folder, and it has made no difference. I cannot get to new search engines to add them for the simple reason that Firefox no longer lets me feed in addresses! I’d be interested to get your advice.

Chosen solution

Are the default search engines still in the searchplugins folder in the Firefox program folder (C:\Program Files\Mozilla Firefox\)?

Did you try to delete search.json as well?


Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


Read this answer in context 👍 1

All Replies (4)

more options

Chosen Solution

Are the default search engines still in the searchplugins folder in the Firefox program folder (C:\Program Files\Mozilla Firefox\)?

Did you try to delete search.json as well?


Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


more options

Hi cor-el:

I was going to write in the original post, ‘If anyone will know, it’ll be cor-el,’ but refrained in case someone else came across it first.

I didn’t know to delete search.json, but that worked—thank you. Problem solved!

more options

You're welcome.

I don't think that search.sqlite is still used in current Firefox versions.
I have it in some profiles, but with an older time stamp dating a few months back.
Only the Firefox ESR version still seems to use it.

more options

You are right: search.sqlite on my one was dated July 22.