On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot connect to legitamate website

  • 8 replies
  • 1 has this problem
  • 32 views
  • Last reply by cor-el

more options

I have just switched from Google Chrome to Firefox version 101.01. There is a legitimate website that I use a lot, it is an on-line library where I get eBooks on a regular basis.

Since I switch to Firefox I am not able to successfully get on the website. The website is HTTPS://broward.overdrive.com or HTTPS://www.overdrive.com, a division of the Broward County Library in Florida.

I continue to get the Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT. When I click “Accept the Risk and Continue button, Firefox then just returns to the original error screen. I noticed it also adds the site to the Firefox Certificate Manger. I had like 20 of the site listed in the certificate manager. I removed all but one, but each time I click the “Accept the Risk and Continue button it adds another exception to the manager but I am still not able to successful reach the site.

I have been using overdrive.com for at least 6 months and it was working with no issues until I switch to Firefox, so the website is not the problem.

I am using Windows 10 as an operating system on my desktop.

Please help me get back my access to this library website.

Thanks, Jim McGuire

I have just switched from Google Chrome to Firefox version 101.01. There is a legitimate website that I use a lot, it is an on-line library where I get eBooks on a regular basis. Since I switch to Firefox I am not able to successfully get on the website. The website is HTTPS://broward.overdrive.com or HTTPS://www.overdrive.com, a division of the Broward County Library in Florida. I continue to get the Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT. When I click “Accept the Risk and Continue button, Firefox then just returns to the original error screen. I noticed it also adds the site to the Firefox Certificate Manger. I had like 20 of the site listed in the certificate manager. I removed all but one, but each time I click the “Accept the Risk and Continue button it adds another exception to the manager but I am still not able to successful reach the site. I have been using overdrive.com for at least 6 months and it was working with no issues until I switch to Firefox, so the website is not the problem. I am using Windows 10 as an operating system on my desktop. Please help me get back my access to this library website. Thanks, Jim McGuire

All Replies (8)

more options

Try to rename the cert9.db file (cert9OLD.db) and remove a possible previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Modified by cor-el

Helpful?

more options

I followed the instruction above, but I am afraid it did not resolve the issue.

Please continue with the trouble shooting process. I am not able to get library books?

Thanks, Jim McGuire [email]@truevine.net

Modified by Andrew

Helpful?

more options

Hi Jim, is that the only site where you get a connection error?

That site uses a real certificate, not a self-signed certificate, so it's possible your connection is being intercepted. Are you using a public WiFi service? You might need to sign in to the WiFi first before you can use the Library website.

If public WiFi is not the explanation, perhaps something else is intercepting your browsing. However, we don't really have enough information at this point to suggest a specific culprit. If there is a pattern of problems with multiple sites, that would be helpful to know.

Helpful?

more options

Can you inspect the certificate ?

You can do a malware scan just to be sure.

Helpful?

more options

jscher2000,

Most everything else works fine, and when I go to the main library, https://www.broward.org/library/, it works fine, but https://www.broward.overdrive.com is where I get the error and block. If fact I went to the main library and found a book just fine until I went to download it. It would not download for the main library was trying to download from the overdrive.com site, so I pretty much am not able to get any eBooks.

My setup is on WiFi, but it is my own home secure net work. I am constantly logged in with no issues any where else.

I use Windows 10 and have the Windows Defender enabled and do not use any other malware software. Windows just completed a schedule scan today with no issues.

Thanks for your help, but so far still having the problem. Should I not be able to override this in Firefox?

Jim McGuire

Helpful?

more options

Hi Jim, I'm not sure what you mean about overriding. The site has a perfectly valid certificate if Firefox contacts the correct server, but something seems to be inhibiting your connection for some reason.

Could you disable Firefox from using any system-level proxy server setting. On the Settings page -- either

  • "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Type or paste about:preferences into the address bar and press Enter/Return to load it

-- look for a tiny search box near the top of the page. Type proxy and Firefox should filter to the "Settings" button in the Network section. Go ahead and click that button.

Change the first setting to "No proxy" and click OK near the bottom of the dialog to save the change.

Then try https://broward.overdrive.com/ again in a new tab. Any difference?

Helpful?

more options

jscher2000

Thanks for your support, but that did not solve the problem. I think I know the problem which is not Firefox related but other software I have on my computer. So, thanks for your time and support and sorry for any inconvenience.

I will begin to work with the company of that software. If somehow that too ends in a dead end then I will re-initiate a new support request.

Thanks again for your assistance.

Jim McGuire

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.