Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Authorisation to Winows 10 to start Firefox

  • 11 replies
  • 1 has this problem
  • 28 views
  • Last reply by Shadow110

more options

I have Windows 10 Pro 64 bit. Since your recent upgrade to v 58.0.2, when I start Firefox (FF), I always receive a request to allow FF ("this app") to make changes on this PC (screenshot attached). I click Yes and FF starts, but it is not set as my default browser and I cannot set FF to become the default browser, as I am unable to save the change to do this. I have logged-in to Windows as an Administrator. Also your major upgrade lost all my bookmarks; as the upgrade did not ask me to save them first, I do not know if they can be retrieved. Please advise.

I have Windows 10 Pro 64 bit. Since your recent upgrade to v 58.0.2, when I start Firefox (FF), I always receive a request to allow FF ("this app") to make changes on this PC (screenshot attached). I click Yes and FF starts, but it is not set as my default browser and I cannot set FF to become the default browser, as I am unable to save the change to do this. I have logged-in to Windows as an Administrator. Also your major upgrade lost all my bookmarks; as the upgrade did not ask me to save them first, I do not know if they can be retrieved. Please advise.
Attached screenshots

Chosen solution

Just to be sure:

You need to make sure all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder.

When you run Firefox as administrator then the application can possibly make changes ot files in the Firefox program folder and Windows warns you about this. You should never run a browser as administrator.

Read this answer in context 👍 1

All Replies (11)

more options

How did you do the upgrade? Was it online or offline upgrade?

more options

It could be that Firefox is asking for administrator access.

Shut down Firefox. Using your file browser, open the Programs Folder on your computer.

Windows: C:\Program Files C:\Program Files (x86)

Right click on Firefox.exe and select Properties. Now select Compatibility. Turn Off Run This Program In Compatibility Mode, and Run This Program As An Administrator.

Do the same for any Firefox shortcuts you have. Now restart Firefox.

more options

This is a reply to WestEnd: H WestEnd. The Firefox upgrade was done by me responding to the online invitation to download the latest version of Firefox, which I did.

more options

FredMcD said

It could be that Firefox is asking for administrator access. Shut down Firefox. Using your file browser, open the Programs Folder on your computer. Windows: C:\Program Files C:\Program Files (x86) Right click on Firefox.exe and select Properties. Now select Compatibility. Turn Off Run This Program In Compatibility Mode, and Run This Program As An Administrator. Do the same for any Firefox shortcuts you have. Now restart Firefox.
more options

Hi FredMcD Firefox is already set to run as Administrator, and I have checked that this is the setting in firefox.exe properties.

more options

FredMcD said

Turn Off Run This Program In Compatibility Mode, and Run This Program As An Administrator.
more options

Chosen Solution

Just to be sure:

You need to make sure all items are deselected in the "Compatibility" tab of the Properties window.

  • Privilege Level: "Run this program as Administrator" should not be selected
  • "Run this program in compatibility mode for:" should not be selected

Also check the Properties of the firefox.exe program in the Firefox program folder.

When you run Firefox as administrator then the application can possibly make changes ot files in the Firefox program folder and Windows warns you about this. You should never run a browser as administrator.

more options

Hi cor-el I did have Firefox set to run as administrator following the suggestion to do this. I have deselected run as admin and compatible mode, so now I am no longer asked by Windows to allow FF to run. Thanks for your help on this problem, however I am still not able to set FF to be my default browser; I get the option in FF settings and then I select FF but this does not save and MS Edge remains the default.

more options

Hi, please open Win 10 Settings --> Apps --> Default Apps --> Click on what ever Browser Icon is in Browser and change it to Firefox.

Please let us know if this solved your issue or if need further assistance.

more options

Hi Pkshadow, Thanks for your suggestion. I have tried this many times; although I set the default browser to Firefox, it doesn't save and reverts back to Edge; I guess this is because MS wants everyone to use Edge.

more options

David_Dundas said

Hi Pkshadow, Thanks for your suggestion. I have tried this many times; although I set the default browser to Firefox, it doesn't save and reverts back to Edge; I guess this is because MS wants everyone to use Edge.

Hi, yes and it is probably UAC that is causing the issue. Where the screen goes dark and get a popup for everything that you want to run. I run with it turned off myself as not going to put up that all the time. I trust in myself more then MS. https://www.howtogeek.com/howto/windows-vista/disable-user-account-control-uac-the-easy-way-on-windows-vista/ Or at least set it lower than what it is set at.

So ya, disable it, set Firefox up in Settings as default then re-enable at a lower threshold if you believe in it and test.

I am still running bookmarks I saved from Netscape in 95 as HTML so suggest you do the same for the future. Email to self as I have done/do often at various online email sites. Can always put everything else back together again but not bookmarks.

Please let us know if this solved your issue or if need further assistance.