Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't access the Kroger website. It says I need Technobabble: TLS 1.2, and that my browser is out of date. My browser is up-to-date, so how do I fix this?

  • 6 replies
  • 2 have this problem
  • 923 views
  • Last reply by jadamirada

more options

I cannot access the Kroger website. When I try, I get a message saying my browser is out of date. It isn't.This is what I get:

Upgrade Your Web Browser

It appears that your web browser is out of date. To protect you while using our site, we require a web browser that supports modern security features.

Technobabble: TLS 1.2 is required to access our sites. Click an icon below to upgrade your browser:

All Replies (6)

more options

Hi jadamirada, could you check whether some of your Firefox settings have been customized:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste TLS and pause while the list is filtered

Do any of the preferences starting with security.tls have a non-default value (bolded and indicates "modified")? To restore a setting back to its default, right-click the setting and choose Reset.

(3) In the search box above the list, type or paste SSL3 and pause while the list is filtered

Firefox should display about 15 lines starting with security.ssl3

If any of the preferences is bolded and "modified" to false, double-click it to restore the default value of true EXCEPT

You can block these two to improve your security (double-click to switch them from true to false):

  • security.ssl3.dhe_rsa_aes_128_sha
  • security.ssl3.dhe_rsa_aes_256_sha

(Assuming the Preference column is alphabetical, these usually would be at the top. They are related to the Logjam vulnerability.)

Does that change anything?

more options

Thank you, jscher, but none of the settings have been modified.

more options

On Kroger, what page do you end up on when you see that message? Can you copy the address from the address bar and paste it here?

Do you know whether your browsing connections are made through an intermediary such as a security software filter, a proxy server, a private VPN service, a peer-to-peer network such as Hola, or Tor? It's possible the intermediary is not using the best security settings.

Sometimes you can recognize an intermediary by a changed certificate. If you visit my test page here --

https://www.jeffersonscher.com/res/jstest.php

-- will Firefox connect? You can call up the certificate viewer using any of these methods:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Certificate"
  • (menu bar) Tools > Page Info > Security > "View Certificate"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Certificate" button

I have posted a screenshot for comparison. What do you have in the "Issued by" area?

more options

Here is the url for the Kroger page where I first got the message

https://www.kroger.com/weeklyAd

I get the same message, though, no matter where I try to connect with the Kroger website.

Okay, I followed your instructions and made it to the 'view certificate' page, and it says it was issued by ESET SSL Filter CA

Thank you so much for your help. I am practically computer illiterate. I think "ESET" has something to do with my security.

more options

Chosen Solution

more options

Yes!!! Thank you so much!! This fixed it!!