Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how can I force firefox use mplayer when I click on an audio/mpeg (mp3) attachment?

  • 3 replies
  • 2 have this problem
  • 45 views
  • Last reply by rhbliss

more options

If i go into preferences/applications and set .avi files to use mplayer it works just like it used to but if I do that for mp3 audio/mpeg fires it adds mplayer to the download list but when I click on the mp3 file it opens a new page with something that sort of looks like a player but does not work! the download button claims that "Movie player is the default but I wand mplayer to be the default! Note: this is firefox-32.0.2. This all worked in 23.0.1-1

If i go into preferences/applications and set .avi files to use mplayer it works just like it used to but if I do that for mp3 audio/mpeg fires it adds mplayer to the download list but when I click on the mp3 file it opens a new page with something that sort of looks like a player but does not work! the download button claims that "Movie player is the default but I wand mplayer to be the default! Note: this is firefox-32.0.2. This all worked in 23.0.1-1

Chosen solution

OK my cockpit error! that fix does allow clicking on the mp3 to at least play sound if I have the preferences set properly to mplayer. But it still does not put up the mplayer window so I have no control to pause the audio. This may be because mplayer is loaded as a plugin. It is interesting that if I use totem instead of mplayer, totem does run in a new window, allowing audio control.

Read this answer in context 👍 0

All Replies (3)

more options

You can disable GStreamer support by setting the media.gstreamer.enabled pref to false on the about:config page.

more options

What that did was cause clicking on the mp3 attachment to bring up a save file pop up. What I want it to do is run the attachment with the program i specify like mplayer or totem.

more options

Chosen Solution

OK my cockpit error! that fix does allow clicking on the mp3 to at least play sound if I have the preferences set properly to mplayer. But it still does not put up the mplayer window so I have no control to pause the audio. This may be because mplayer is loaded as a plugin. It is interesting that if I use totem instead of mplayer, totem does run in a new window, allowing audio control.

Modified by rhbliss