Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When spell check underlines a word as misspelled, it doesn't offer any spelling options, it just underlines the word. How do I fix this?

  • 2 iimpendulo
  • 1 inayo le ngxaki
  • 19 views
  • Impendulo yokugqibela ngu cor-el

more options

I have Windows 7 and Firefox 10.0

Firefox spell check. Sometimes it checks, sometimes it doesn't work at all. However, even when I get the squiggly red line under a misspelled word, I am never offered spelling options, I just get the red line. I have 'check spelling as I type' selected in tools, options, advanced, general. So, how can I ensure that spell check always checks for errors, and that it starts offering me suggestions for correcting the spelling?

I have Windows 7 and Firefox 10.0 Firefox spell check. Sometimes it checks, sometimes it doesn't work at all. However, even when I get the squiggly red line under a misspelled word, I am never offered spelling options, I just get the red line. I have 'check spelling as I type' selected in tools, options, advanced, general. So, how can I ensure that spell check always checks for errors, and that it starts offering me suggestions for correcting the spelling?

All Replies (2)

more options

The option to check spelling toggles spell check on and off.

Try right clicking the underlined word and using the options available then. As standard I do not think Firefox offers an automatic spell check option that presents options over the entire document/field for each misspelled word in turn, it does however allow you to use a personal dictionary and add words to that.

more options

Do you have a dictionary installed and selected?

  • You can see which dictionary is selected if you right-click in a text area and open the Languages submenu.
  • Open the "Add Dictionaries" link to install a dictionary if you do not have one.
  • Make sure that [X] "Check Spelling" in the right-click context menu is check-marked.

You can enable or disable spell checking globally:

  • Tools > Options > Advanced : General: Browsing: "Check my spelling as I type"

You can look here for dictionaries:

See also: