Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website pictures do not display on Firefox, but they do in Safari. Am I missing an extension or plug-in?

  • 3 iimpendulo
  • 5 inale ngxaki
  • 193 views
  • Impendulo yokugqibela ngu cor-el

more options

Website html content appears, but embedded photos do not. For instance, on rei.com merchandise page, all data appears except the product photos. In Picasa outlines of photos appear, but not the pictures. This problem arose day after cleaning hard drive with OnyX Automator. I have run Disk Utility Repair and restarted the computer, but the problem persists.

Website html content appears, but embedded photos do not. For instance, on rei.com merchandise page, all data appears except the product photos. In Picasa outlines of photos appear, but not the pictures. This problem arose day after cleaning hard drive with OnyX Automator. I have run Disk Utility Repair and restarted the computer, but the problem persists.

Isisombulu esikhethiweyo

If images are missing then check that you aren't blocking images from some domains. See:

  • Check the permissions for the domain in the current tab in Tools > Page Info > Permissions
  • Check that images are enabled: Firefox > Preferences > Content: [X] Load images automatically
  • Check the exceptions in Firefox > Preferences > Content: Load Images > Exceptions
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images)

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.



You can use these steps to check if images are blocked:

  • Click the "More Information" button to open the "Page Info" window with the Security tab selected (also accessible via "Tools > Page Info").
  • Go to the Media tab of the "Tools > Page Info" window.
  • Select the first image link and scroll down through the list with the Down arrow key.
  • If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.
Funda le mpendulo kwimeko leyo 👍 0

All Replies (3)

more options

Isisombululo esiKhethiweyo

If images are missing then check that you aren't blocking images from some domains. See:

  • Check the permissions for the domain in the current tab in Tools > Page Info > Permissions
  • Check that images are enabled: Firefox > Preferences > Content: [X] Load images automatically
  • Check the exceptions in Firefox > Preferences > Content: Load Images > Exceptions
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images)

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.



You can use these steps to check if images are blocked:

  • Click the "More Information" button to open the "Page Info" window with the Security tab selected (also accessible via "Tools > Page Info").
  • Go to the Media tab of the "Tools > Page Info" window.
  • Select the first image link and scroll down through the list with the Down arrow key.
  • If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.
more options

Problem solved following 3d tick mark above. Firefox>Preferences>Content:Load Images box was unchecked. Checking it solved the problem. Thanks

more options

You're welcome