Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Repeatedly crashes . but only on this machine.

  • 6 iimpendulo
  • 1 inayo le ngxaki
  • 28 views
  • Impendulo yokugqibela ngu jonzn4SUSE

more options

First of all , Hello  :) FF is a great wb and i use it everywhere i got a machine. Works fine everywhere .. but here on this computer. Why only on this machine ? Same distros ( linux mint 20.3 ) radeon video cards , amd family cpu's This machine is AMD FX(tm)-6300 Six-Core Processor × 6 the video card atm is AMD PITCAIRN (DRM 2.50.0, 5.4.0-94-generic, LLVM 12.0.0) though i had the same crash issue with a nVidia graphics card. Memory is Corsair and the memtest86 reports no errors. This is where i get a bit lost. Memory issues or hardware defects might explain this but where's one to begin ? Trouble is , no other application ever crashes and it's rock solid. So is FF to point a finger at or something else ? That's the objective of me submitting this report. Try to find out what's really at fault here and fix it.

The crashes happen at all times. It can also be right at starting FF and never even reaching the main window. I tried with and without the --safe-mode and it's the same that also happens.

So i submitted one of the crash reports ID: 656264f4-7867-4c55-8b36-0637e0220114

The report can be found here : https://crash-stats.mozilla.org/report/index/656264f4-7867-4c55-8b36-0637e0220114

Since there's so many i hesitate to put them all up , there's dozens since the system reinstall yesterday , i reinstalled the whole OS again yesterday to try to get rid of the bug. Any help to solve this once and for all will be highly appreciated . :) thanks for reading

FuzzyTheBear

Isisombulu esikhethiweyo

Ok .. now that was something else .. in one word : bad ram. Last run of memtest86+ ( 4 5 months ago ) showed perfect ram , 0 errors , so ofc , i took that to the bank. Since i wrote the last time , crashes started on other programs as well , random system freezes. So .. new run of memtest86+ and there it was .. 1022 errors splashed in red .. so i swapped RAM for a new 8 gig module and everything's honky dorey doo.

Solved. Bad RAM .

Thank you for the help .

Funda le mpendulo kwimeko leyo 👍 1

All Replies (6)

more options

Try downloading another copy of Firefox and run it from the folder. Do not sign into your Firefox account and see if you have the same issue.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Are you using Wayland or X11?

Operating System: openSUSE Tumbleweed 20220113 KDE Plasma Version: 5.23.5 KDE Frameworks Version: 5.90.0 Qt Version: 5.15.2 Kernel Version: 5.16.0-1-default (64-bit) Graphics Platform: X11 Processors: 4 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Helpful?

more options

Hi .. being in lockdown still .. hard to go as fast as i wanted to :)

Lo and behold , the stock version works without a problem. To answer it's x11 that runs. in a terminal echo $XDG_SESSION_TYPE x11

So a stock version works without problems. I have not synced or anything , no extensions. Next steps ? .. guess i could move the old profile and check a fresh version issued by Mint without syncing or extensions see if that works out ?

Thanks for the answer. It's nice to narrow it down some.

Fuzzy aka Richard  :D

Helpful?

more options

You should sync your data to the separate version of Firefox and see if you have the same issues. I run several versions of Firefox and Waterfox. Sync will see the versions as different devices and you can sync your data between them like a backup. In case one of them goes boom, you can just sync data to it. I was losing tabs in my distro version of Firefox over a year which is why I've been running Nightly as my daily driver.

Helpful?

more options

Interresting .. it starts to crash immediately while the sync ain't even complete .. I deleted all local config again and , i started to install addons. Adblocker ultimate first. Opened Yahoo Mail .. bang crash. Ah that was getting interresting indeed .. so i turned it off for Yahoo Mail after a few tries and crashes. No more crashes .. But .. why ? .. Ain't this odd ? .. so i kept on with adding a you tube ad blocker .. worked ok youtube downloader ( feller 1.1.7.2 ) all ok .. works fine no crashes up until now.

So instead of syncing at large , the decision is to keep syncing off and rebuild. Up to now .. there's 0 problems. Ill keep on using this tarball for a while.

Here's the clincher : As soon as a sync the data on the official mint release with all the old config set aside , i get the same crashing again as soon as i sync.

I know it's convenient to get all the bookmarks and all synced but obviously , though the synced data works on my home machines there's something this one dosen't like at all.

Does this solve the issue ? big fat no. Is this a workaround ? yes but it's not really elegant. By no means does it solve the enigma of what crashes on this machine. Nor provides an easy way to keep ff updated. I am definitely going to keep looking ans searching for a true answer.

For now , though it works enough for this machine downtown , it's use being mainly a jukebox/dj station/mixxx/video playback workstation , i can't say solved works for me. The initial problem remaining whole.

Ill keep searching and provide any information that might be usefull as you guys need.

If you have a way to help me solve this , debugger of some kind , or knowledge on how to solve , i am totally willing to put in the hours and help. Ill be trying a few things and report back later this week.

Thanks for helping me. If i can do something in return , let me know.

Always glad to help people that over the years gave me so much.

Ric

Helpful?

more options

Isisombululo esiKhethiweyo

Ok .. now that was something else .. in one word : bad ram. Last run of memtest86+ ( 4 5 months ago ) showed perfect ram , 0 errors , so ofc , i took that to the bank. Since i wrote the last time , crashes started on other programs as well , random system freezes. So .. new run of memtest86+ and there it was .. 1022 errors splashed in red .. so i swapped RAM for a new 8 gig module and everything's honky dorey doo.

Solved. Bad RAM .

Thank you for the help .

Ilungisiwe ngu FuzzyTheBear

Helpful?

more options

Good Job!!!  ;-))

Helpful?

Buza umbuzo

Kufuneka ungene eakhawuntini yakho ukuphendula okuthunyelweyo. Nceda uqale imibuzo emitsha, ukuba awukabinayo iakhawunti.