Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Twitter links are not showing up on my webpages on Firefox but they do on Explorer?

  • 5 iimpendulo
  • 1 inayo le ngxaki
  • 30 views
  • Impendulo yokugqibela ngu FredMcD

more options

Over the last few days, any link to Twitter has been blocked on all web pages that I am trying to view. Thinking it might be a computer setting, I opened IE and the pages show up fine with all images. I love using Firefox, how can I resolve this issue? Thank you.

Over the last few days, any link to Twitter has been blocked on all web pages that I am trying to view. Thinking it might be a computer setting, I opened IE and the pages show up fine with all images. I love using Firefox, how can I resolve this issue? Thank you.

All Replies (5)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 30.0.0.154

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

Could be a problem with "DuckDuckGo Privacy Essentials".

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

more options

Thank you for the suggestions. Starting Firefox in safe mode did solve the problem. Do I leave it running in safe mode or does that signify a specific problem? Also, I am running Win10. I was a bit confused regarding Adobe. Do I install it or no? Lastly, the tracking protection is not a problem.

more options

fmastro6 said

I was a bit confused regarding Adobe. Do I install it or no?

Many websites still use Abode to show the clips. If you don't watch any clips, you can remove it.

fmastro6 said

Starting Firefox in safe mode did solve the problem. Do I leave it running in safe mode or does that signify a specific problem?

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions.

First, disable DuckDuckGo as cor-el suggested. Then Restart Firefox.

If the problem is still there, then disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.