Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox has put a Block on my graphics driver and I want it taken Off, please

  • 8 iimpendulo
  • 1 inayo le ngxaki
  • 1 view
  • Impendulo yokugqibela ngu cor-el

more options

Firefox has put a Block on my graphics driver and I want it taken Off, please. Nvidia couldn't find an update without installing JAVA and JAVA is way too unsafe to install. The Weather Chanel.com won't load and I want the Block taken off my Firefox system please.

All Replies (8)

more options

Could you copy/paste the information about the blocked graphics. Here's how:

Open the support information page using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Graphics header and select from there through the end of the table that follows, then copy (e.g., Ctrl+c) and paste into a reply. (It's normal to lose the formatting, don't worry about that.)


Regarding weather.com, there is a problem loading the page if you completely disabled location services. You can check on that here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste geo and pause while the list is filtered

(3) If the geo.enabled preference is bolded and "user set" to false, double-click it to restore the default value of true

(4) Switch over to weather.com and test, and prepare for getting annoying permission requests...

You can make permanent site-specific location permission changes using the Permissions panel of the Page Info dialog. You can call that up using any of these:

  • right-click a blank area of the page and choose View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address, then the ">" icon, then More Information > Permissions

Near the top, you'll find "Access Your Location" and you can uncheck the "Use default" box and select the permission you prefer.

Note: If you have Firefox set to clear history when you close Firefox, make sure not to clear "Site Preferences" or your permissions will be deleted.

more options

Hi jscher; Thank you so much for such a fast & helpful reply. Troubleshooting is telling me I need to update my graphic driver but when I went to Nvidia they couldn't find an update AND they wanted me to install JAVA which I uninstalled long ago due to high security risks, so I can't get the update that way and I don't think there is a different way to do so. I tinkered around with a couple about:config settings but that didn't help either so I went back to put them as they had been initially and not all of them would revert back to the way they were but I don't seem to be having any other issues....yet.

I must tell you that I went back to an older version of Firefox but it didn't correct this graphics issue so I let Firefox update itself automatically and it's showing 45.0.1 "Firefox is up to date". I don't think it is all the way up-to-date but it will get there eventually. Here's the info you requested.

OH! that geo-enable thingy? it Was set at False so I did as you said to and lo & behold, there's weather.com in all it's glory.. ha ha Who Knew!? thanks so much for that. I haven't got a clue as to how it got set to False. You figure it's something I did personally? How did I do it?

Adapter Description NVIDIA GeForce 6150SE nForce 430 Adapter Drivers nv4_disp Adapter RAM Unknown Asynchronous Pan/Zoom none Device ID 0x03d0 Direct2D Enabled Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer. DirectWrite Enabled false (0.0.0.0) Driver Date 9-4-2007 Driver Version 6.14.11.6258 GPU #2 Active false GPU Accelerated Windows 0/1 Basic (OMTC) Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer. Subsys ID 2a72103c Supports Hardware H264 Decoding No; Failed to create H264 decoder Vendor ID 0x10de WebGL Renderer Blocked for your graphics driver version. Try updating your graphics driver to version 182.65 or newer. windowLayerManagerRemote true AzureCanvasBackend skia AzureContentBackend cairo AzureFallbackCanvasBackend cairo AzureSkiaAccelerated 0

Ilungisiwe ngu James

more options

It is not the Firefox browser but Mozilla.

https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers

more options

Thanks for sending me that. But according to the dates on those, they are from 2010 & 2011 and my being blocked has just happened in the past few days. What? Are they just now getting around to my graphics driver after all this time? What a load of doggie doo-doo. I clicked my Nvidia for a graphics update and it told me they couldn't find a better one than I already have so now where do I go? Thanks James.

more options

Nvidia's website is a little difficult to use...

Did you try the first download on this page: http://www.geforce.com/drivers

This advanced search page allows selecting:

Product Type: GeForce Product Series: GeForce 6 Series Product: GeForce 6150SE nForce 430 Operating System: Windows XP Recommended/Beta: Recommended/Certified

http://www.nvidia.com/download/find.aspx

Sample screen shot attached.

Note: I suggest choosing a release from 2010 first to see whether that is stable before trying anything newer, and even then only advance one year at a time just in case a newer release is "too much" for your system.

Ilungisiwe ngu jscher2000

more options

Yes, I tried the dowload, well actually, I didn't. I clicked the 'search my computer' button and what comes up is that I have to install JAVA which really ticks me off. JAVA has been such a security risk that I uninstalled it long ago and I really hate to take the chance on installing it and discover that it's jinxed my system. I'll have to think long & hard on that. Thanks so much for the info. I so appreciate it.

more options

Well, you can use the advanced search page without Java as far as I can tell.

more options

Java and JavaScript are different languages. To avoid confusion, see: