Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Prevent open history entires from moving to the top

  • 2 iimpendulo
  • 2 inale ngxaki
  • 19 views
  • Impendulo yokugqibela ngu cor-el

more options

When I open a history entry, it's automatically moves to the top of the list and scroll me there. Not only this scrolls away from the place in the (very long) history list I was looking at, It screws up the browsing history.

Can I force FF to copy the entries rather than move them and not autoscroll to the top?

When I open a history entry, it's automatically moves to the top of the list and scroll me there. Not only this scrolls away from the place in the (very long) history list I was looking at, It screws up the browsing history. Can I force FF to copy the entries rather than move them and not autoscroll to the top?

All Replies (2)

more options

Hi

This is not something that Firefox does by default, but might be something that you can do through an add-on.

I cannot vouch for either of them, but you may want to have a look at Norwell History Tools and Session History Tree that might be able to help.

I hope you do not mind me mentioning, but I noticed that you are using an old version of Firefox. To make sure you have the latest security and performance fixes, I recommend you update to a more recent version. You can read how to do this here.

I hope this helps, but if not please come back here and we can look into a different solution for you.

more options

Firefox only shows the most recent visit of a specific URL if you search the history. If you click an history item to visit the URL then you create a new history entry and the previous visit is no longer shown. That new visit will appear as the first and causes Firefox to jump to the top of the list. You can select multiple items and open them all in tabs via the right-click context menu or copy them to the clipboard and paste them in a text file. In the sidebar you need to click to the far left of an item to prevent opening the link.