Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox bug and Microsoft Outlook web site: Firefox will not allow Windows computer to sleep

  • 4 tontu
  • 1 am na jafe-jafe bii
  • 5 views
  • i mujjee tontu mooy Brian

more options

After a new email notification sound plays from Microsoft Outlook, https://outlook.office.com/mail/, Firefox has a constant audio stream in use, preventing Windows computers from sleeping.

How to reproduce: 1) In an Admin Command Prompt, execute "powercfg /requests" and verify nothing has a power request, especially "SYSTEM: None." 2) In Firefox, open a tab and login into a Microsoft Outlook account at https://outlook.office.com/mail/. 3) Wait for a new email which triggers an audible chime. 4) In the Admin Command Prompt, verify "powercfg /requests" reports "SYSTEM: [DRIVER] <audio-driver-specific-string> An audio stream is currently in use." Note the computer will never go to sleep due to this request. 5) Close the Firefox tab with Microsoft Outlook. 6) In the Admin Command Prompt, verify "powercfg /requests" has no power requests, especially "SYSTEM: None". Note the computer will sleep after the idle period as expected.

After a new email notification sound plays from Microsoft Outlook, https://outlook.office.com/mail/, Firefox has a constant audio stream in use, preventing Windows computers from sleeping. How to reproduce: 1) In an Admin Command Prompt, execute "powercfg /requests" and verify nothing has a power request, especially "SYSTEM: None." 2) In Firefox, open a tab and login into a Microsoft Outlook account at https://outlook.office.com/mail/. 3) Wait for a new email which triggers an audible chime. 4) In the Admin Command Prompt, verify "powercfg /requests" reports "SYSTEM: [DRIVER] <audio-driver-specific-string> An audio stream is currently in use." Note the computer will never go to sleep due to this request. 5) Close the Firefox tab with Microsoft Outlook. 6) In the Admin Command Prompt, verify "powercfg /requests" has no power requests, especially "SYSTEM: None". Note the computer will sleep after the idle period as expected.

All Replies (4)

more options

Seems like there is something set in outlook email that is preventing the system from doing to sleep. As you mentioned close outlook and it goes to sleep after idle time. That would seem to indicate something in the outlook setting is keeping the browser active and preventing the system from idle to sleep mode.

Helpful?

more options

donthavecow said

Seems like there is something set in outlook email that is preventing the system from doing to sleep. As you mentioned close outlook and it goes to sleep after idle time. That would seem to indicate something in the outlook setting is keeping the browser active and preventing the system from idle to sleep mode.

Sorry for any confusion; I am not running the Outlook app; I am visiting the Outlook web site in a Firefox tab. Firefox appears to never close the audio stream after the sound stops playing until the entire tab to the Outlook web site is closed.

Helpful?

more options

That's what I just said the tab left opened to outlook is running a background process that is keeping it active and that you need to check your outlook settings to see what it's loading that is keeping the connection active and disable it.

Helpful?

more options

Dropa said

That's what I just said the tab left opened to outlook is running a background process that is keeping it active and that you need to check your outlook settings to see what it's loading that is keeping the connection active and disable it.

Firefox's Page Info/Media for the Outlook tab only shows icons, images, and backgrounds, no audio. But Firefox is causing "An audio stream is currently in use." How are you determining Outlook is the bad actor rather than Firefox?

Helpful?

Laajal dara

Danga war a dugg ci sam sàq ngir tontu ci siiwal. Kon tàmbalil laaj bu bees, sudee amagoo am sàq.