Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to make firefox to reload pinned tabs on startup

more options

I recently deleted the file with firefox settings (can't remember the name) cause i was unable to what netflix/hbo. now however, whenever i open firefox my pinned tabs (16 tabs) does not reload the pages as in does not refresh the content of the page. it use to refresh the page inside these pinned tabs when i open firefox but now the pages are still the old version. i have to refresh these pinned tabs manually.

so is there any settings to make these pinned tabs to actually refresh the page when i open firefox? i'm confuse why firefox it still shows that its loading the page cause it actually show the same page content that was a day before.

I recently deleted the file with firefox settings (can't remember the name) cause i was unable to what netflix/hbo. now however, whenever i open firefox my pinned tabs (16 tabs) does not reload the pages as in does not refresh the content of the page. it use to refresh the page inside these pinned tabs when i open firefox but now the pages are still the old version. i have to refresh these pinned tabs manually. so is there any settings to make these pinned tabs to actually refresh the page when i open firefox? i'm confuse why firefox it still shows that its loading the page cause it actually show the same page content that was a day before.

All Replies (3)

more options

When Firefox restores your session, it tries to use files from its disk cache ("Cached Web Content") and session history file to bring the page back to the way it looked when you left it. Obviously if your goal is to get the latest page at that URL, and not the one you were looking at when your last session ended, this doesn't match your preference.

I don't think this behavior changed recently. Is it possible that you used to block or clear Firefox's disk cache and that's why the pages always had to reload? If you want Firefox to dump its cache at shutdown, you can set that up on the Settings/Preferences page (I'm not sure what it is called in Linux these days). Either:

  • "3-bar" menu button > Settings or Preferences
  • (menu bar) Tools > Settings or Preferences
  • type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click over to the Privacy & Security panel, then scroll down to the History section.

Change the selector to "Firefox will: Use custom settings for history"

Tick the last checkbox, labeled "Clear history when Firefox closes" -- Firefox should now enable the Settings button to the right of that line

Click the Settings button and UNCHECK all categories except Cache -- you want to only clear things you are sure you want to dump. Then click OK.

Now when you Quit Firefox, the cache should get cleared. If you let Linux signal Firefox to close itself during a system shutdown, I'm not sure whether cache will get cleared in that case due to limited time.

More info on clearing different aspects of "history": Delete browsing, search and download history on Firefox.

Helpful?

more options

i don't know how i've made this profile to load pinned tabs. its quite an old profile (probably from ff 60 or something). anyway now i have a question:

is it normal to have so many prefs.js in the profile folder. right now i have reach prefs-137.js. don't know why there are so many. use to be just default one.

user.for.forms moo ko soppali ci

Helpful?

more options

Firefox creates a prefs-number.js file if the prefs.js file is locked by another program (or perhaps "read only) when Firefox goes to save updates to it. That can happen from time to time for unknown reasons, but shouldn't happen that often.

Helpful?

Laajal dara

Danga war a dugg ci sam sàq ngir tontu ci siiwal. Kon tàmbalil laaj bu bees, sudee amagoo am sàq.