Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New version sucks!

more options

So today, November 5, 2021, I did the Firefox update and it has changed all my options in the Setting to everything Firefox. Horrible!! I want my homescreen to be www.bing.com, yet when I go into Settings there is NO WAY to get the damn check mark off the "Always check to see if Firefox is your default browser." At the top of the damn Settings - General page there is also a system warning stating "Your browser is being managed by your organization" What organization?!!!!!! I am using my personal laptop, so there is no "organization" set up NOR HAVE I EVER GIVEN ANYONE ASSOCIATED AT FIREFOX TO ACT AS MY PERSONAL REPRESENTATIVE.

Who is the IDIOT that is FORCING everyone else to only use Firefox as a default search engine! Who is just screaming "I am a dictator and I need to be slapped!" Fix this issue and SOMEONE AT FIREFOX better may damn sure that someone is not hijacking my computer or anyone else's personal computer!

I will notify every damn new media organization if that damn "...being managed by your organization" is NOT removed immediately! Firefox needs to vet people better so no one is acting like some damn self-appointed "MASTER OF ALL" organization!

All Replies (1)

more options

tracylynne48313 said

I want my homescreen to be www.bing.com, yet when I go into Settings there is NO WAY to get the damn check mark off the "Always check to see if Firefox is your default browser." At the top of the damn Settings - General page there is also a system warning stating "Your browser is being managed by your organization" What organization?

Home Page

On the first point, set your home page on the "Home" panel of the Settings page. Select Custom URLs and then enter https://www.bing.com/. Or you can go to Bing and set the home page from there. More info in this article: How to set the home page.

Default Search Engine

You can make Bing your default search engine on the "Search" panel of the Settings page. More info in this article: Change your default search settings in Firefox.

Organization Managing Your Browser

This can indicate that a Group Policy has been applied to your browser, which is common in a work setting but not in a home setting. To see whether that is the page, open the About Policies page by typing or pasting about:policies in the address bar and pressing Enter to display it.

This page normally shows the "Active" panel and displays The Enterprise Policies service is inactive.

Does your Active panel list anything else?

Do not check whether Firefox is your default browser

Do you prefer to use Edge or Chrome as your default browser?