Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Top sites icons not displayed when set to not remember history

  • 3 tontu
  • 1 am na jafe-jafe bii
  • 33 views
  • i mujjee tontu mooy cfjohnsn

more options

I was able to set up my Top Sites to display the sites and got all icons to display using the "Use a custom image" option and inputting a direct link to the icon/image I wanted to have displayed. All of them showed up exactly as I wanted while the browser was set to "Remember history".

After making the change to "Never remember history" and the browser restarting, the top sites that I configured are all still there, but the icons are not being displayed.

Why would it remove them when they are not based on history, but on a custom/direct URL to the image and, is there a workaround/fix for this so that the icons are displayed using the URL?

If it is solely based on history, then even having the option to use a custom URL is fairly useless, if you value your privacy.

I was able to set up my Top Sites to display the sites and got all icons to display using the "Use a custom image" option and inputting a direct link to the icon/image I wanted to have displayed. All of them showed up exactly as I wanted while the browser was set to "Remember history". After making the change to "Never remember history" and the browser restarting, the top sites that I configured are all still there, but the icons are not being displayed. Why would it remove them when they are not based on history, but on a custom/direct URL to the image and, is there a workaround/fix for this so that the icons are displayed using the URL? If it is solely based on history, then even having the option to use a custom URL is fairly useless, if you value your privacy.

Saafara biñ tànn

When you are in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) then all session data is kept in memory and there is no access possible to files in the profile folder. This includes the disk cache and the thumbnail cache in the secondary profile location, so you won't see website thumbnails on the Firefox Home page.

Jàng tontu lii ci fi mu bokk 👍 1

All Replies (3)

more options

Saafara yiñ Tànn

When you are in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) then all session data is kept in memory and there is no access possible to files in the profile folder. This includes the disk cache and the thumbnail cache in the secondary profile location, so you won't see website thumbnails on the Firefox Home page.

more options

Thanks, that makes sense, explained that way.

more options

Sorry to bring this back up, but, while the explanation made sense to me initially, it doesn't explain why a couple show up and others don't.

See the screenshot for reference.

My first thought was that I visited those couple before switching over to privacy mode, but the others are still listed in that same day's remaining history (hadn't cleaned it after looking up icon images and switching to privacy mode).

Is there any explanation for that and, if so, could moving the images (either the links or downloaded copies of the images) to that folder/config file get them working?