Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Despite following suggestions of Top 10 Contributors on this page, Firefox consistently monopolises 99% of memory, making my machine run VERY slowly.

  • 6 tontu
  • 1 am na jafe-jafe bii
  • 3 views
  • i mujjee tontu mooy Shadow110

more options

Firefox regularly monopolises 99% of memory.

I have tried all of the solutions suggested on the Support site as well as the suggestions offered by Top 10 Contributors on this site (I have disabled all add-ons, run in Safe mode, uninstalled – then re-installed the latest version [ 52.9.0] of Firefox, ensured that both browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 are set to "false") but all to no avail. When left unattended for an hour or so, Firefox crashes.

Despite this, Firefox consistently monopolises 99% of memory, making the machine run VERY slowly (except, inexplicably, whenever I am on a Mozilla Support page).

This has been going on for more than a year.

I use Windows XP (which otherwise works fine), have an up-to-date Norton anti-virus protection and do not use Pocket.

I refuse to use Google Chrome and do not want to have to revert to IE, but the current situation is intolerable.

With very sincere thanks,

Firefox regularly monopolises 99% of memory. I have tried all of the solutions suggested on the Support site as well as the suggestions offered by Top 10 Contributors on this site (I have disabled all add-ons, run in Safe mode, uninstalled – then re-installed the latest version [ 52.9.0] of Firefox, ensured that both browser.tabs.remote.autostart and browser.tabs.remote.autostart.2 are set to "false") but all to no avail. When left unattended for an hour or so, Firefox crashes. Despite this, Firefox consistently monopolises 99% of memory, making the machine run VERY slowly (except, inexplicably, whenever I am on a Mozilla Support page). This has been going on for more than a year. I use Windows XP (which otherwise works fine), have an up-to-date Norton anti-virus protection and do not use Pocket. I refuse to use Google Chrome and do not want to have to revert to IE, but the current situation is intolerable. With very sincere thanks,
Nataali seetu yiñ ci takkaale

All Replies (6)

more options

I had just the same problem and Pj (Top 25 contributor) offered the following solution which has worked for me in Windows 7.

There's another thing you could try that's helped me extend my browser sessions before becoming Memory-Choked or an occasional crash.

Setting the Disk Cache in About:Config to 0.

It's been working great for me for a while now limiting the RAM usage to under 1GB.

Type in About:Config in the browser and scroll down to:

   browser.cache.disk.smart_size.enabled (Set it to false instead of true) 
   browser.cache.disk.capacity (Set it to 0 instead of 358400)
more options

This seems to have had an effect, thank you. I will wait a day or so before confirming (one way or the other).

more options

Hi rutherford2017, legacy Firefox can use a lot of memory for some sites; I certainly noticed it with Facebook. The endless loading newsfeed could run me up near the maximum for a 32-bit program and freeze Firefox. Unfortunately, with your system, you don't have the option of more memory and 64-bit Firefox; maybe someday.

Meanwhile, do you notice any pattern with particular sites using more memory? Could you check the "Memory troubleshooting tools" of the support article for this problem: Firefox uses too much memory or CPU resources - How to fix. That might help identify problem pages or add-ons.

more options

Thank you jscher2000.

I did indeed read and follow the recommendations in the support article, but doing so had no appreciable effect. The only sites that had any impact on memory usage were Mozilla pages; whenever I was on any of these, memory usage dropped to normal levels -- but as soon as I navigated anywhere else (and I mean ANYWHERE else), memory usage shot back up to 97-99%.

The advice from Jems1 (above) -- to set the Disk Cache in About:Config to 0 -- seems (at least for the time being) to have significantly reduced the problem. If it continues, I will mark the problem as 'Solved'.

more options

Jems1

Well, that worked for about 24 hours, but Firefox is now once again monopolising 97%-99% of RAM.

(And browser.cache.disk.smart_size.enabled is still set to false and browser.cache.disk.capacity is still set to 0)

(And you'd think that if Firefox was using all available RAM, it would at least have the courtesy to work fast, but no.)

Oddly, as soon as I manage to switch to this Mozilla Support tab (although this takes a few minutes of patient waiting...), the percentage of memory used by Firefox (centre column) usually plummets to almost nothing -- although the amount of memory being used (right column) stays more-or-less unchanged. Please see attached double screenshot. (At left, when I am on my email tab -- at right, when I am on this Mozilla Support page)

I would be grateful for any other suggestions.

rutherford2017 moo ko soppali ci

more options

Hi, please try a Refresh but Note that this does more than uninstalling and re-installing does. Normal uninstalling does not remove some preferences which may have become corrupt. Please Refresh but do this 1st: Delete your Cookies and Cache and TEST.

then

TEST....... If no issues then Extensions which need to be added back in 1 at a time and tested ..... Or it is your Profile : Make a new one and test ...:

If is your Profile :

Note: Any customization will revert back to default, you will also need to reinstall Extensions.

NOTE : Support for XP ends month end and the final browser for XP/VISTA is version 52.9.0esr Please move to this as it has the latest security and stability patches. https://www.mozilla.org/en-US/firefox/organizations/all/#legacy If do backup up just in case.

Please let us know if this solved your issue or if need further assistance.