Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After Upgrading to v58 userChrome.css Multiple Tabs Setup Stopped Working

  • 7 tontu
  • 2 am na jafe-jafe bii
  • 39 views
  • i mujjee tontu mooy opoplawski

more options

On Nov 20, 2017 after v57 I lost access to my extension that gave me multiple plugin rows.

Then I found the solution was to create a Chrome\userChrome.css file in my profile and configure multiple tab rows like I wanted.

After upgrading to v58 I have lost all my tab rows and they are now all showing on one row all squished and with the scroll bars which I hate and it totally slows down working.

How do we re-gain access to a Multiple-Row Tab Setup???

The following userChrome.css prevously worked great in v57:


/*START userChrome.css*/ /*Multiple Tab Rows*/ .tabbrowser-tab {

   flex-grow:1;
   min-width:150px;

} .tabbrowser-tab,.tab-background {

   height:29px;

} .tab-stack {

   width: 100%;

} .tabbrowser-tabs .scrollbox-innerbox {

   display: flex;
   flex-wrap: wrap;

} .tabbrowser-tabs .arrowscrollbox-scrollbox {

   overflow: visible;
   display: block;

} .tabbrowser-tabs .scrollbutton-up,.tabbrowser-tabs .scrollbutton-down,#alltabs-button{

   display: none;

}


/*Make Pinned Tabs smaller*/ .tabbrowser-tab[pinned] {

 min-width: 24px !important;   
 width: 28px;

}

/*END userChrome.css*/

marcelg7 moo ko soppali ci

Saafara biñ tànn

This works for me on Firefox Quantum 58.0.1

#main-window:not(#f) .tabbrowser-tab {
   -moz-box-sizing: border-box !important;
   height: 33px !important;
   vertical-align: top !important;
}
#main-window:not(#f) .tabbrowser-tab:not([pinned]) {
   width: auto !important;
}
#main-window:not(#f) .tabbrowser-tab[pinned] {
   width: 94px !important;
}
#main-window:not(#f) .tab-close-button {
   display: -moz-box !important;
}
#main-window:not(#f) .titlebar-button {
   height: 33px !important;
}
#main-window:not(#f) #titlebar-buttonbox,
 .tabbrowser-arrowscrollbox scrollbox > box {
   display: block !important;
}
#main-window:not(#f) #titlebar-buttonbox {
   vertical-align: top !important;
}
.tabbrowser-arrowscrollbox scrollbox {
   overflow: visible !important;
}
.tab-label-container[textoverflow]:not([pinned]) {
   mask-image: unset !important;
}
.scrollbutton-up,
.scrollbutton-down {
   display: none !important;
}
Jàng tontu lii ci fi mu bokk 👍 1

All Replies (7)

more options

Any help is appreciated as this is a nightmare for working my job. Thanks!

marcelg7 moo ko soppali ci

more options

Saafara yiñ Tànn

This works for me on Firefox Quantum 58.0.1

#main-window:not(#f) .tabbrowser-tab {
   -moz-box-sizing: border-box !important;
   height: 33px !important;
   vertical-align: top !important;
}
#main-window:not(#f) .tabbrowser-tab:not([pinned]) {
   width: auto !important;
}
#main-window:not(#f) .tabbrowser-tab[pinned] {
   width: 94px !important;
}
#main-window:not(#f) .tab-close-button {
   display: -moz-box !important;
}
#main-window:not(#f) .titlebar-button {
   height: 33px !important;
}
#main-window:not(#f) #titlebar-buttonbox,
 .tabbrowser-arrowscrollbox scrollbox > box {
   display: block !important;
}
#main-window:not(#f) #titlebar-buttonbox {
   vertical-align: top !important;
}
.tabbrowser-arrowscrollbox scrollbox {
   overflow: visible !important;
}
.tab-label-container[textoverflow]:not([pinned]) {
   mask-image: unset !important;
}
.scrollbutton-up,
.scrollbutton-down {
   display: none !important;
}

Sonny moo ko soppali ci

more options

Thank you so much srazzano!

That straightened things out for me and now I'm back up and running after making my customizations with your starting CSS.

Cheers!!!

more options

Can someone post the corrected version of userChrome.css AFTER replacement of "1." and all the rest? Can I directly replace userChrome.css with the above? Best Max

more options
more options

Copy this code and paste into userChrome.css file in your user profiles chrome folder.

#main-window:not(#f) .tabbrowser-tab {
   -moz-box-sizing: border-box !important;
   height: 33px !important;
   vertical-align: top !important;
}
#main-window:not(#f) .tabbrowser-tab:not([pinned]) {
   width: auto !important;
}
#main-window:not(#f) .tabbrowser-tab[pinned] {
   width: 94px !important;
}
#main-window:not(#f) .tab-close-button {
   display: -moz-box !important;
}
#main-window:not(#f) .titlebar-button {
   height: 33px !important;
}
#main-window:not(#f) #titlebar-buttonbox,
 .tabbrowser-arrowscrollbox scrollbox > box {
   display: block !important;
}
#main-window:not(#f) #titlebar-buttonbox {
   vertical-align: top !important;
}
.tabbrowser-arrowscrollbox scrollbox {
   overflow: visible !important;
}
.tab-label-container[textoverflow]:not([pinned]) {
   mask-image: unset !important;
}
.scrollbutton-up,
.scrollbutton-down {
   display: none !important;
}

Sonny moo ko soppali ci

more options

All of the multiple tab row solutions that I've found have made closing tabs very slow. Does anyone else see this or know of a fix?