FAQ - la nouvelle technologie des modules pour Firefox

This page does not exist in Wolof. You have been redirected to the Français version instead. If you would like to localize it into Wolof, click here. You can also see the English version of this page.

Qu’est-ce qu’une extension obsolète ?

Les extensions créées en utilisant des composants qui ne sont pas compatibles avec Firefox version 57 et les versions ultérieures (comme le SDK ou le XUL) sont considérées comme « obsolètes ».

Comment puis-je savoir si j’ai des extensions obsolètes installées ?

Pour voir si vous avez des extensions incompatibles installées, ouvrez le gestionnaire de modules complémentaires. Cliquez sur le bouton de menu Fx57Menu et choisissez Modules complémentaires ou bien saisissez about:addons dans un nouvel onglet. Si vous avez une extension obsolète, elle figure dans la liste sous Désactivé et ne dispose pas d’option Activer dans le menu des points de suspension (3 points).

Fx68Addons-OldLegacyNowDisabled

Comment puis-je savoir si j’ai des extensions obsolètes installées ?

Pour voir si vous avez des extensions incompatibles installées, rendez-vous dans le gestionnaire de modules complémentaires. Cliquez sur le bouton de menu Fx57Menu et choisissez Modules complémentaires ou bien saisissez about:addons dans un nouvel onglet. Si vous avez une extension obsolète, vous verrez une note en haut de votre écran comme celle-ci :

Legacy extension warning

Cliquez sur le lien « Afficher les extensions obsolètes » pour voir la liste des extensions obsolètes installées sur votre navigateur. Cliquez sur « Trouver un module équivalent » près de chaque extension obsolète pour voir une extension équivalente recommandée. Vous pouvez en savoir davantage sur cette fonctionnalité sur cette traduction du billet de blog de Mozilla.

Si je vois indiqué « Obsolète », est-ce que cela signifie que mon extension est cassée ?

Oui, les extensions étiquetées « Obsolète » ne fonctionnent plus avec Firefox 57 et supérieur. Dans certains cas, les développeurs et développeuses doivent continuer à travailler après la date de sortie du 14 novembre 2017 pour rendre compatibles leurs extensions avec la version courante de Firefox. Dans ces cas-là, l’extension est automatiquement mise à jour dès que sa version compatible est disponible.

Recommandez-vous des extensions pour remplacer celles qui sont obsolètes ?

Oui ! Rendez-vous dans le gestionnaire de modules complémentaires (cliquez sur le bouton de menu Fx57Menu et choisissez Modules complémentaires ou bien saisissez about:addons dans un nouvel onglet) et sélectionnez Extensions obsolètes. Cliquez sur Rechercher un module équivalent à côté de chaque exension obsolète pour une alternative recommandée. Vous pouvez en lire davantage sur cette fonctionnalité dans notre billet de blog.

Nous vous recommandons de chercher des extensions compatibles sur le portail des modules addons.mozilla.org (AMO) ou de parcourir cette collection d’extensions mises en avant.

Vous pouvez également utiliser cet outil de recherche d’extensions pour tenter de trouver une extension équivalente que nous recommandons.

Il n’existe pas d’extensions équivalentes recommandées pour l’une de mes extensions obsolètes. Que faire ?

Si vous ne trouvez pas d’équivalent qui vous convienne, parcourez notre forum de discussion (en anglais) pour demander des conseils aux membres de la communauté.

Quand Firefox ESR a-t-il arrêté la prise en charge des extensions obsolètes ?

Firefox Extended Support Release (ESR) version 52 est la dernière version qui prenait en charge les extensions obsolètes. La prise en charge d’ESR 52 a pris fin le 5 septembre 2018.

En octobre 2018, tous les modules complémentaires obsolètes ont ét désactivés sur addons.mozilla.org (AMO). Les utilisateurs et utilisatrices ne peuvent plus trouver de modules complémentaires obsolètes sur AMO.

Si vous décidez de vous servir de versions de Firefox qui ne sont plus prises en charge pour continuer d’utiliser des modules obsolètes, vous vous rendez vulnérable aux failles de sécurité. Nous vous recommandons énergiquement de ne pas utiliser ces versions.

Qu’est devenu mon thème complet ?

Les thèmes complets ne fonctionnent pas avec Firefox 57+ et sont désactivés. Si vous utilisez un thème complet sombre, l’option Sombre dans le gestionnaire de modules peut être une bonne solution de remplacement pour vous. Allez dans l’onglet Thèmes dans la fenêtre about:addons et essayez-le. Nous allons apporter des améliorations aux thèmes dans les mois qui viennent, vous pouvez donc vous attendre à des thèmes avec davantage de fonctionnalités qu’une simple image de fond dans les versions à venir.

Qu’est devenu mon module pour Flash ?

Depuis la version 55 de Firefox, Adobe Flash ne s’exécute pas par défaut car demander pour activer Flash est intégré au navigateur. Vous pouvez choisir le comportement de Flash pour des sites précis ou pour tous les sites.

Certaines des extensions pour Flash les plus populaires ajoutaient cette possibilité avant qu’elle ne soit intégrée au navigateur. Comme ces extensions sont dorénavant obsolètes, elles ne seront probablement plus maintenues par les développeurs et ne fonctionneront plus.

Dans certains cas, nous avons des API pour les WebExtensions pour des capacités supplémentaires à Flash (telles que la suppression des objets locaux partagés Flash, aussi appelés cookies Flash) et nous comptons que des modules complémentaires tireront avantage de plus de possibilités de Flash peu à peu, à mesure que nous travaillons ensemble à découvrir ce qui est nécessaire pour parvenir à des fonctionnalités équivalentes.

// These fine people helped write this article:Goofy, Mozinet, Cécile, YD. You can help too - find out how.

Ndax jukki bi amal nala njariñ? Xaaral tuuti...

Bokk ci ñiy jàppale Ndimbalu Mozilla