Hiển thị các câu hỏi được đánh dấu: Xem tất cả các câu hỏi
  • Đã lưu trữ

Hide tab bar with one tab Firefox 76

My hide tab bar with one tab code has broken with 76. The tabs themselves remain collapsed, but the bar remains. Here's my userChrome file: /* Modify to change window … (xem thêm)

My hide tab bar with one tab code has broken with 76. The tabs themselves remain collapsed, but the bar remains. Here's my userChrome file:

/* Modify to change window drag space width */
:root[tabsintitlebar="true"] #nav-bar{ --window-drag-space-width: 24px }

.titlebar-buttonbox-container{
  position: fixed;
  display:block !important;
  top:0;
  right:0;
  height: 40px;
}
#toolbar-menubar[inactive] > .titlebar-buttonbox-container{ opacity: 0 }

:root[sidemode="maximized"] > #navigator-toolbox{ padding-top: 8px !important; }
:root[sizemode="maximized"] .titlebar-buttonbox-container{ top: 8px }

:root[uidensity="compact"] .titlebar-buttonbox-container{ height: 32px }
.titlebar-buttonbox-container > .titlebar-buttonbox{ height: 100%; }
#titlebar{
 -moz-box-ordinal-group: 2;
  -moz-appearance: none !important;
}
:root[tabsintitlebar="true"] #nav-bar{
  padding-right: calc(138px + var(--window-drag-space-width,0px));
  padding-left: var(--window-drag-space-width,0px)
}
.titlebar-placeholder,
#TabsToolbar .titlebar-spacer{ display: none; }
/* Also hide the toolbox bottom border which isn't at bottom with this setup */
#navigator-toolbox::after{ display: none !important; }

/* Menubar on top patch - use with Fx65_tabs_on_bottom.css */
/* Only really useful if menubar is ALWAYS visible */

#navigator-toolbox{ margin-top: 22px }
#toolbar-menubar{
  position: fixed;
  display:block !important;
  top: 0px;
  height: 22px;
  margin-top:1px;
  width: 100%;
  overflow: hidden;
}

#toolbar-menubar .titlebar-buttonbox-container{ height: 22px; }
#toolbar-menubar .titlebar-button{ padding: 2px 17px !important;  }

/* This will allow you to MAYBE put some items to the menubar */
#toolbar-menubar > *{ float: left }
#toolbar-menubar .toolbarbutton-1 { --toolbarbutton-inner-padding: 3px }

/* Makes tabs toolbar items zero-height initially and sets enlarge them to fill up space equal to tab-min-height set on tabs */
/* Firefox 65+ only */
/* !!USER!! -  REMOVE ALL BUTTONS you can from the tabs toolbar */

/* Configurable window drag space  */
:root[sizemode="normal"] #nav-bar{ --window-drag-space-width: 20px }

#titlebar{ -moz-appearance: none !important; }
#tabbrowser-tabs, #tabbrowser-tabs > .tabbrowser-arrowscrollbox{ min-height: 0 !important; }
:root:not([customizing]) #tabbrowser-tabs .tabs-newtab-button,
:root:not([customizing]) #TabsToolbar .titlebar-button{
  -moz-appearance: none !important;
  height: 0px;
  padding-top: 0px !important;
  padding-bottom: 0px !important;
  -moz-box-align: stretch;
  margin: 0 !important;
}
#tabbrowser-tabs .tabbrowser-tab{ height: var(--tab-min-height) }
#tabbrowser-tabs .tabbrowser-tab[first-visible-tab="true"][last-visible-tab="true"]{
  visibility: collapse !important;
}

/* Button re-styling */
#tabbrowser-tabs .tabs-newtab-button:hover{ background-color: var(--toolbarbutton-hover-background) }
#tabbrowser-tabs .tabs-newtab-button > .toolbarbutton-icon{
  padding: 0 !important;
  transform: scale(0.6);
  background-color: transparent !important;
}
/* Extra top padding  in maximized window */
:root[sizemode="maximized"] > #navigator-toolbox{ padding-top:7px !important; }
/* Fix window controls not being clickable */
#toolbar-menubar:hover{
  min-height: calc(var(--tab-min-height) + var(--space-above-tabbar) - 1px) !important;
  height: calc(var(--tab-min-height) + var(--space-above-tabbar) - 1px) !important;
  -moz-appearance: initial !important;
}
#nav-bar{ padding: 0 var(--window-drag-space-width,0px) }

/* Hide blue stripe on active tab */
.tab-line[selected="true"] {
  opacity: 0 !important;
}

 #toolbar-menubar, #menubar-items, #main-menubar {
 background-color: #F8F8FB !important;
 background-image: none !important;
}
 #TabsToolbar, #menubar-items, #main-menubar {
 background-color: #F8F8FB !important;
 background-image: none !important;
}

/* Change Color of Active tab */

/* Change Color of Normal Tabs */
tab:not([selected=”true”]) 
{
	background-color: rgb(240,240,245) !important;
	color: black !important;
}

/* Hide solo tab */
#tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] {
  visibility: collapse;
}
/* Hide New Tab Button immediately next to solo tab */
#tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] + toolbarbutton {
  visibility: collapse;
}

Any help is appreciated.

Đã được hỏi bởi Leafsdude 1 năm trước

Trả lời lần cuối bởi jscher2000 1 năm trước

  • Đã lưu trữ

customizing colors

In Google search the default colors for links are blue for a link that I haven't looked at and a slightly different shade of blue. I have trouble seeing the difference be… (xem thêm)

In Google search the default colors for links are blue for a link that I haven't looked at and a slightly different shade of blue. I have trouble seeing the difference between the 2. I have changed the link color of the link that I clicked on to orange. But when I change the "override colors specified by the page with your selections above" from "never" to "always". It changes the colors on the web page. How do I keep the orange color on visited links without effecting the colors on the web pages?

Steve

Đã được hỏi bởi reble 1 năm trước

Trả lời lần cuối bởi cor-el 1 năm trước

  • Đã lưu trữ

Added single pane extension - Firefox now unusable.

At Firefox' recommendation, I added an extension/addon called 'single pane extension' where I think the idea was that Firefox could be save better. But since the install… (xem thêm)

At Firefox' recommendation, I added an extension/addon called 'single pane extension' where I think the idea was that Firefox could be save better. But since the install Firefox has become unusable. I can only use it in safe mode. Here is a screenshot. Sorry, but I can't figure out how to fix this.

Đã được hỏi bởi webnick 1 năm trước

Trả lời lần cuối bởi jscher2000 1 năm trước

  • Đã lưu trữ

Disable Library window sidebar icons via user.Chrome

I'm looking to have the Library window sidebar and #placesToolbar icons not show. I have tried a number of id and class tags but no luck as yet. Have managed to customise… (xem thêm)

I'm looking to have the Library window sidebar and #placesToolbar icons not show. I have tried a number of id and class tags but no luck as yet. Have managed to customise most of this window but just can't remove the icons. I would also like to hide some of the treeChildren themselves (Tags for example).

Đã được hỏi bởi deanone 1 năm trước

Trả lời lần cuối bởi cor-el 1 năm trước

  • Đã lưu trữ

Two address bar problems

I'm using Windows 10 on one computer and Windows 7 on another need a solution which will work for both. When I upgraded to Firefox 72, I think it was, I had a problem wi… (xem thêm)

I'm using Windows 10 on one computer and Windows 7 on another need a solution which will work for both.

When I upgraded to Firefox 72, I think it was, I had a problem with the tabs which I wanted to show below the address bar. Someone from this forum helped by guiding me to a userChrome change and a userContent.css file. That worked fine and the tabs were below the address bar.

The next time I upgraded Firefox to 75 I think it was, the address bar wasn't working the way it used to. I wanted to be able to have the whole address bar selected when I clicked on it so I could type over what was there and enter a new address. Again, someone on this forum very kindly helped me by showing me how to change the settings on browser.urlbar.OpenViewOnFocus and 3 others and the problem was solved.

Now I come to Firefox 77 and the tabs are showing above the address bar again AND the address bar is no longer working as I wanted it to.

The OpenViewOnFocus settings are the way they I was advised to change them, but the tabs are still above the address bar. Someone acknowledged that changing the OpenViewOnFocus will no longer correct the tab locations and suggested a userChrome.css change. But I've already got one program in the userChrome.css file that I used the fix the address bar program.

Can I have two different programs in the userChrome.css field?

If so, can anyone help with the userChrome.css program that would take care of both problems? and do I still need the userContent.css file?

Why does Firefox keep doing this?

Đã được hỏi bởi mikejanus 1 năm trước

Trả lời lần cuối bởi Mike Janus 1 năm trước

  • Đã lưu trữ

I thought I'd try 74. Tabs back on top, anyone got a fix (the chrome file that worked on 72 doesn't work on 74)

The tabs on the bottom solution I had working on 72 does not work on 74. Anyone have an update?

Đã được hỏi bởi jcurran516 1 năm trước

Trả lời lần cuối bởi cor-el 1 năm trước

  • Đã lưu trữ

Change the Findbar's search matches background / foreground color for the FOCUSED search match

Apparently, the preference names for the currently selected / focused, highlighted search match have changed. I can't find any CSS code on the web to modify this behavio… (xem thêm)

Apparently, the preference names for the currently selected / focused, highlighted search match have changed. I can't find any CSS code on the web to modify this behavior. Though I made a note years ago about switching from using prefs for it in about:config, to using a CSS style.

The "unfocused" highlighted search matches do allow me to change both FG & (BG=bright pink) colors - to a point. I think I had to create these prefs, or some of them. The UNfocused search matches color prefs are: ui.textHighlightBackground #EF0FFF ui.textHighlightForeground #000000

They allow me to use black (vs. default white) for the text color on the fuchsia BG.

The pref names for focused search match apparently changed, based on an old profile. ui.textSelectBackgroundAttention #00FF00 ui.textSelectForegroundAttention #FFFFFF (I can change the white FG to anything, but it always defaults to white. The green BG w/ white FG / text, is really hard for me to read.

Fx won't allow me to change the FG color on the currently focused / selected search match. No matter if I select a BG color that black - or many non-white Foreground colors have a much higher contrast values than the default green BG w/ white FG.

Even if the colors I try have a much higher contrast value than the green / white. http://snook.ca/technical/colour_contrast/colour.html#fg=B6C9D0,bg=0004FF

EXCEPT, for the focused / selected match, if I enter white or very light BG, the super smart code still uses white text, making it invisible. But it won't let me use green / black, or yell BG with Red or Blk FG.

I think this problem is because of some algorithm Mozilla uses to calculate contrast values, that obviously doesn't work very well. Anyone know of a way around this issue, or CSS code that might override Mozilla's contrast algorithm?

Đã được hỏi bởi Joebt 1 năm trước

Trả lời lần cuối bởi cor-el 1 năm trước

  • Đã lưu trữ

Firefox 74 tabs on bottom - Overlapping panel issue

Please see https://stackoverflow.com/questions/60678417/firefox-74-tabs-on-bottom-overlapping-panel-issue or https://www.reddit.com/r/firefox/comments/fhoelc/firefox_74_t… (xem thêm)

Đã được hỏi bởi aleksandr.blekh 1 năm trước

Trả lời lần cuối bởi cor-el 1 năm trước