Hiển thị các câu hỏi được đánh dấu: Xem tất cả các câu hỏi
  • Đã giải quyết

New CSS styles not picked in Firefox.

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren'… (xem thêm)

I am building a website and, for the last couple of days, when I make changes to the CSS file they are no longer being picked up by the browser by which I mean they aren't displayed in the web page nor in the developer tools inspector.

They are visible in Chromium browser and dev tools.

I have cleared the cache and refreshed the page to no avail. It is only when I restart the browser that the new style rules take effect in the browser and show up in the dev tools.

Đã được hỏi bởi mt3ch 1 tuần trước

Đã được trả lời bởi cor-el 1 tuần trước

  • Đã giải quyết

Can Someone Guide Me About My Website Flora Terra Issue?

I have noticed that my Flora Terra Website (https://floraterraca.com) sometimes open perfectly but often not. Should I include some extra code to make it compatible? Rega… (xem thêm)

I have noticed that my Flora Terra Website (https://floraterraca.com) sometimes open perfectly but often not.

Should I include some extra code to make it compatible?

Regards Usman

Đã được hỏi bởi Arslan Goraya 1 tháng trước

Đã được trả lời bởi Arslan Goraya 1 tháng trước

  • Đã giải quyết

Firefox isn't showing forms on our website created with Formidable Forms

Hi there, I work for a small UK based charity and we use our website to take orders for our programmes, we deliver DARE programmes in the UK. Our website is https://lifes… (xem thêm)

Hi there,

I work for a small UK based charity and we use our website to take orders for our programmes, we deliver DARE programmes in the UK.

Our website is https://lifeskills-education.co.uk.

We use WordPress as our CMS and use Formidable Forms to create forms for people to place orders; these forms work fine in Chrome and Edge, but will not display in Firefox. I have tried everything, disabling third party scripts, all plugins, themes and more, but Firefox refuses to show them. It sees the HTML, but when inspected the HTML is greyed out. It is not greyed out on Chrome.

https://lifeskills-education.co.uk/resources/the-dare-primary-programme/ is the page where an order form should show on the left above the fold. It is titled Place an Order.

There is nothing I can find anywhere that can help me with this issue, Google has come up blank and I am not a web developer so don't have the tech chops to track this down.

Any help appreciated. Thanks.

Stuart

Đã được hỏi bởi thebastion 3 tháng trước

Đã được trả lời bởi cor-el 3 tháng trước

  • Đã giải quyết
  • Đã lưu trữ

How to prevent Firefox from removing my extension's data when I remove debug version?

I have an extension with id setup in manifest like this: ``` "browser_specific_settings": { "gecko": { "id": "{e3ec45ef-43ba-499d-8469-6d0e2f06921f}", "stric… (xem thêm)

I have an extension with id setup in manifest like this:

``` "browser_specific_settings": {

   "gecko": {
     "id": "{e3ec45ef-43ba-499d-8469-6d0e2f06921f}",
     "strict_min_version": "42.0"
   }
 },

```

which uses indexedDB(PouchDB). I installed that extension from addons.mozilla.org, disabled, installed temporarily version for developing and Firefox removes data of both extensions(cuz they have the same id) every time I remove only temporarily version.

This does not happen when I don't set id in manifest(temporarily version has random id in this case), but it's not a solution cuz some API's and Android version of Firefox requires id to be set manually

How to prevent Firefox from removing data of normal extension when I remove temporarily one?

Just in case someone wants to reproduce the issue:

1. Install this extension https://addons.mozilla.org/en-US/firefox/addon/tagit/?src=search
2. Go to extension's page (button with eyes on browser's panel)
3. Go to "Tags" page and create any tag(write something and press Enter)
4. Disable this extension on about:addons page
5. Clone its repository and checkout to commit where id is in manifest `git clone https://github.com/DevAlone/tagit.git; git checkout 8e0d04201865fd7b7543b167279a045c89408d5c`
6. Install dependencies and build `npm install; npm run build`
7. Install that temporarily extension(`build` dir) on about:debugging page
8. Remove that temporarily extension on about:debugging page
9. Enable normal extension on about:addons page
10. Go to the Tags page again to see that database is gone

Đã được hỏi bởi SergeyDevZ 10 tháng trước

Đã được trả lời bởi TyDraniu 10 tháng trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox is re-directing to another domain on the homepage.

I was using a staging site and then went live and redirected the staging domain to the live domain. However, I then needed to re-instate the staging site. Now, whenever I… (xem thêm)

I was using a staging site and then went live and redirected the staging domain to the live domain. However, I then needed to re-instate the staging site. Now, whenever I go to the home page of the staging site, it redirects me to the live site. Any other page or url doesn't redirect. If I put a query parameter in the url, it doesn't redirect either. I've tried the suggestions here without success: https://stackoverflow.com/questions/13063496/firefox-invalidate-dns-cache

Đã được hỏi bởi badgersnadgers 10 tháng trước

Đã được trả lời bởi jscher2000 10 tháng trước

  • Đã giải quyết
  • Đã lưu trữ

Strange dashed border is visible around column after clicking in website footer

Hi, We are developing a new website for a client. The client is seeing a strange issue when viewing the site in Firefox, where a thick dashed border appears around an ima… (xem thêm)

Hi,

We are developing a new website for a client. The client is seeing a strange issue when viewing the site in Firefox, where a thick dashed border appears around an image and column in the footer of the website. It happens when she clicks in the footer somehow. It seems inconsistent, and the client sent us 2 different screenshots where the border line looks different. (Screenshots attached.)

We haven't been able to re-create the issue on our end, even after testing on several machines and browsers. The client is using a Windows computer and is running the newest version of Firefox. She only sees the issue when using Firefox (it looks fine for her in Microsoft Edge). She has seen the issue on several different dates, and after disabling all her Firefox extensions.

Here is the link to the site: http://82a.de4.myftpupload.com/

Anyone seen something like this before, and have any idea what it is or how to fix it?

Thank you!!

Đã được hỏi bởi Hana 10 tháng trước

Đã được trả lời bởi cor-el 10 tháng trước

  • Đã giải quyết
  • Đã lưu trữ

Could you tell me the maximum supported version of Firefox in this OS environment?

Hello, I am a developer working on Red Hat Linux R5.10. Could you tell me the maximum supported version of Firefox in this OS environment? The current version of Red Hat … (xem thêm)

Hello, I am a developer working on Red Hat Linux R5.10.

Could you tell me the maximum supported version of Firefox in this OS environment? The current version of Red Hat Linux R5.10 is related to the following environment. gtk2, glib 2.0, pango 1.14

The latest version(66.0.3) of Firefox has requirements below

-GTK + 3.4 or higher
-GLib 2.22 or higher
-Pango 1.22 or higher

This OS does not meet all the requirements.

help please

Đã được hỏi bởi namhun 1 năm trước

Đã được trả lời bởi Meskó Balázs 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

User session is getting deleted when payment is done and redirecting to my site, it is happening only with Mozilla browser

On my e-commerce application, when customer is trying to pay amount, redirecting him to Payment gateway site and after payment done return back to My application, Session… (xem thêm)

On my e-commerce application, when customer is trying to pay amount, redirecting him to Payment gateway site and after payment done return back to My application, Session is getting nil and user is getting logged off.

this is happening only with Mozilla customer, may I know that what exactly the reason for getting session nil.

Đã được hỏi bởi Naresh534 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Our website doesn't display properly on Firefox

Our business website has recently been relaunched, it displays fine on other browsers but is beyond broken on Firefox. I've attached a screenshot of how it looks on Chrom… (xem thêm)

Our business website has recently been relaunched, it displays fine on other browsers but is beyond broken on Firefox. I've attached a screenshot of how it looks on Chrome, to see how it looks on Firefox here is our url: https://www.exegetic.biz/.

As you can see it's VASTLY different and VERY frustrating. I've done a fair amount of reading as to what the issue could be but all the suggestions I have found are end user based... For example emptying the cache, clearing cookies, checking the zoom etc. This doesn't really help since I've looked at the site on various devices with FireFox and they all appear the same...

Has anyone else experienced this? Any help would e greatly appreciated!

Đã được hỏi bởi EmmaExegetic 1 năm trước

Đã được trả lời bởi Wesley Branton 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

My website is not working in Firefox but its working fine in Chrome

I just made my website and it's not working in Firefox however in chrome its working fine. It's in Wordpress. Is something wrong with my wordpress plugins. It gives me e… (xem thêm)

I just made my website and it's not working in Firefox however in chrome its working fine. It's in Wordpress. Is something wrong with my wordpress plugins.

It gives me error that says "Secure Connection Failed"

Website Link : http://esportsrush.com/

https://i.imgur.com/QnrvzMg.jpg

Can't use the add images button below so posting imgur link here.

Đã được hỏi bởi gomu 1 năm trước

Đã được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Failed to read configuration file

We are currently having to role back to FireFox ESR 52.9 from the latest Quantum build of FireFox 60.3.0. Due to the fact that this version utilizes WebGl 2. Our older sy… (xem thêm)

We are currently having to role back to FireFox ESR 52.9 from the latest Quantum build of FireFox 60.3.0. Due to the fact that this version utilizes WebGl 2. Our older systems will not render one of the educational games we utilize in the our School District any longer due to the fact that Quantum uses WebGl 2 instead WebGl 1. We have tested and verified that ESR 52.9 renders the game properly.

I have been trying to disable the automatic update in utilizing the user.js file and the cfg file. The computers are apart of the domain. From what I have read only new user profiles will get the new user.js settings while all existing profiles will retain the old settings so we plan on reimaging these computers so all existing profiles will be wiped.

I have also seen users block the updates by changing the Host File which we will not do. Some sites state create a profile folder in the defaults folder other show place the user.js file in the pref folder. So I am lost at this point. I have followed this guide as well:

https://developer.mozilla.org/en-US/docs/Mozilla/Firefox/Enterprise_deployment_before_60#Changes_Over_Time

I have placed the 00_admin-prefs.js with the exact settings shown and have the mozilla.cfg file in the same folder as the js. both are in the defaults\pref

When trying to run FireFox I am am not getting:

Failed to read the configuration file. Please contact your Administrator. (I am the Admin). My domain creds give me admin privileges on all computers.

I know this folder also holds the channel-pref.js so I am not sure if I can add what I need to that file.

If someone would please help me determine what is going on. Why wont firefox copy the either a user.js file or utilize the cfg file I created to each new profile that gets created when logging into the computer.

Đã được hỏi bởi fharris77 1 năm trước

Đã được trả lời bởi fharris77 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Scrollbar (unpredictably) stops working on PC

I'm seeing a really weird issue - https://rs2018.raffworks.com/ - on Firefox PC only, after opening a couple of the items up, the scrollbar completely stops working. Some… (xem thêm)

I'm seeing a really weird issue - https://rs2018.raffworks.com/ - on Firefox PC only, after opening a couple of the items up, the scrollbar completely stops working. Sometimes one item, sometimes three or four. But then bang! the scrollbar just locks up completely and it's impossible to scroll the page.

Has anyone experienced anything like this? Firefox on macOS is fine.

Đã được hỏi bởi raffjones 1 năm trước

Đã được trả lời bởi raffjones 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Programming code is visible when viewing a page with Firefox, but not on other people's screens..

I've added some extra code to automatically show the correct language to visitors based on their location settings. This is working properly for the people who have chec… (xem thêm)

I've added some extra code to automatically show the correct language to visitors based on their location settings. This is working properly for the people who have checked it and they are only seeing the correct language, but the CODE is visible on the webpage when I check it on my own computer. I recognise it must be a Firefox setting on my computer, but can not determine which setting it is. Any help is appreciated.

Đã được hỏi bởi lgould 1 năm trước

Đã được trả lời bởi user633449 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Open a IE window from parent page launched using Firefox

We have an application that was integrated with several other legacy applications in the organization. We started upgrading our application to HTML 5 standards to make it… (xem thêm)

We have an application that was integrated with several other legacy applications in the organization. We started upgrading our application to HTML 5 standards to make it work with all modern browsers such as Firefox, Chrome and Edge. Now the problem is that, our application has redirect links to 3 to 5 legacy applications that were coded for IE 7 and no where in the migration path. When the users click on these links while working on our application, Firefox opens a blank page, making them as blockers for our application uplift. 1) is there a way to force a link to open in IE while the parent page is launched using Firefox ? I have seen this link : https://stackoverflow.com/questions/43615678/force-a-link-in-i-e-to-open-in-firefox , but this is for the opposite requirement...open Firefox from IE. 2) how do you run applications requiring .cab files on Firefox ? if there is an answer for this, we don't need to worry about #1.

Thanks.

Đã được hỏi bởi Ravix5 1 năm trước

Đã được trả lời bởi Roland Tanglao 1 năm trước

  • Đã khóa
  • Đã lưu trữ

Firefox Video control template

Hello team firefox! I'm building my own webpage, where some videos are played (with scenes, so there will be a back and next button). When i embeed a video with the contr… (xem thêm)

Hello team firefox!

I'm building my own webpage, where some videos are played (with scenes, so there will be a back and next button). When i embeed a video with the controlls, everything works. But: as soon as i turn on fullscreenmode (which the videos are played in normally), my two next and back buttons dissapeer (behind the video ofc).

So my questions to you: could you please send me your video control html, css and js? Would be reaaaly cool of you!

Đã được hỏi bởi paasi6666 1 năm trước

Trả lời lần cuối bởi Roland Tanglao 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox doesn't randomly load webpages

Hi, I use Firefox v590.0.2 (64 bits) with Windows 10. I use Firefox at my work, only for browsing our intranet. I'm a web developer so I load many pages on our intranet. … (xem thêm)

Hi,

I use Firefox v590.0.2 (64 bits) with Windows 10.

I use Firefox at my work, only for browsing our intranet. I'm a web developer so I load many pages on our intranet. Since a few weeks, I noticed that the pages are not always loaded correctly: the page starts to be loaded, and then it stops and it's loading forever (with the "Waiting for XXX" message at the bottom left). If I refresh the page it will eventually load as expected.

I tried to install a new Firefox on *another* computer, and I use it to browse the same website. And the same behavior appears: it works very fast and well for some pages, and then randomly stops working for some random pages.

On my main computer I tried to create new profiles, delete everything, without success.

I also tried to deactivate the hardware acceleration on both Firefox, without success.

When I check the Network tab from the web developer bar, I can see that some CSS files (it's not always the same, and it can be 1 or several CSS files) are not loaded (see the attachment) and appears with a grey dot, just like if the browser was trying to load them but it cannot, blocking the page. (I've also noticed it could impact other resources, like, at least images)

Before v59 I've never seen this behavior.

Note :

 - our intranet is on Sharepoint, with NTLM auth
 - at home I use Firefox on my personal computer and it works normally (but I don't browser the work intranet)
 - at work, because it's on the intranet, the network doesn't go thru a proxy
 - I'm now using Chrome because of this issue with Firefox, and the problem doesn't occur in Chrome

Thanks for any help.

Đã được hỏi bởi AymKdn 2 năm trước

Đã được trả lời bởi AymKdn 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Temporarily block Firefox updates by URL/IP

We have an Add-On that will no longer work with FireFox once it updates version 60.2. It will heavily impact our stores ability to use certain functions/integration with … (xem thêm)

We have an Add-On that will no longer work with FireFox once it updates version 60.2. It will heavily impact our stores ability to use certain functions/integration with our website until we get either a new add-on released or make a change to the site. We had planned on disabling updates for FireFox temporarily on each PC at each store but I am hoping for a workaround. I am curious if there is a list somewhere of the server IP’s/URLs that FireFox would use to update. This way I can just blacklist those IP’s for the time being until we get a new add-on released or an update to our website. This way they would not be able to download the latest update. It would prevent me from having to alter settings on each PC at each store (we have close to 70 locations and 4 computers at each). Is there such a list? And if so can someone point me there? Thanks!

Đã được hỏi bởi ar550n1c 1 năm trước

Đã được trả lời bởi ar550n1c 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Browser Console

Trying to debug very simple javascript in a small web page. I turned on the chrome javascript console when I run my file and then ctrl-shift-j I get an error report o… (xem thêm)

Trying to debug very simple javascript in a small web page. I turned on the chrome javascript console when I run my file and then ctrl-shift-j I get an error report on code that is not mine -- lots of references to recipebox -- and dont get any help with my own page.

Đã được hỏi bởi jean01 2 năm trước

Đã được trả lời bởi Shadow110 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

How can I view what the cookie content is?

I am a new developer and I'm trying to learn how cookies work, but I don't know how to view what the actual cookie value is, so that I can check if I did it correctly. … (xem thêm)

I am a new developer and I'm trying to learn how cookies work, but I don't know how to view what the actual cookie value is, so that I can check if I did it correctly. I see where you can set the defaults you want and enable or disable cookies, but where can you view the content in FireFox browser? I know in Google Chrome you can see all the cookies and their values in settings, content, cookies, view all. Thanx, Gil

Đã được hỏi bởi gilbert2097 2 năm trước

Đã được trả lời bởi cor-el 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

None of the "sha256" hashes in the integrity attribute match the content of the subresource

We created a web site that uses resources from cdnjs. This site has been live for a couple of months but we have sporadic issues with resources from this CDN and FireFox.… (xem thêm)

We created a web site that uses resources from cdnjs. This site has been live for a couple of months but we have sporadic issues with resources from this CDN and FireFox.

  • The error in the console for each script/style CDN resource is: None of the "sha256" hashes in the integrity attribute match the content of the subresource.
  • The error message in the network tab for each resource is: The connection used to fetch this resource was not secure

Resources that I have had issues with include these elements (as they appear in our web page):

Steps to reproduce

You can reproduce the problem with one of the above URLs and place it directly in the URL of the FireFox browser. The resource should load in the browser window but after pressing CTRL+F5 at least one time (could be up to 5 times) an error will appear. I can duplicate this from multiple PCs although we are located in the Netherlands so maybe a timing issue or something? This does not happen with any other resources from other CDNs that we are using like (we use integrity checks with these as well):

My environment:

  • Windows 10 Pro 64bit patched to latest
  • FireFox 60.0.1 (64-bit)

My question

Is this an issue that is specific to cdnjs and they must resolve this or is this an issue with FireFox or is this an issue with how we are requesting the resource? Is there anything else that we can do to get the ball rolling on fixing this (depending on the actual source of the problem)?

As a side note we also test our software on Google Chrome, MS Internet Explorer, MS Internet Explorer 11, MS Edge, and Opera and we have

Thank you in advance!

-Igor

Đã được hỏi bởi igorw 2 năm trước

Đã được trả lời bởi igorw 2 năm trước