Hiển thị các câu hỏi được đánh dấu: Xem tất cả các câu hỏi
  • Đã lưu trữ

Disabling Control +w keybind

Could you add a option of closing tab with <kbd>Ctrl</kbd>+<kbd>w</kbd> to the advanced preference? Also, I realized that: ```browser.tabs.warnO… (xem thêm)

Could you add a option of closing tab with <kbd>Ctrl</kbd>+<kbd>w</kbd> to the advanced preference?

Also, I realized that:

```browser.tabs.warnOnClose False``` Does this option activates warn when closing the tab? If your answer is yes, it is not working at all.

Được hỏi bởi maxemilian 1 năm trước

Lần cuối trả lời bởi wtfiwinomgs 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox automatically downloading files instead of asking

After a forced update, firefox stopped giving the popup that lets you choose what to do with the file. A temporary fix is to go into options and set "Always ask you wher… (xem thêm)

After a forced update, firefox stopped giving the popup that lets you choose what to do with the file.

A temporary fix is to go into options and set "Always ask you where to save files", however this is clunky, and much much slower, so is there any way to get this popup back?

If not, then i will have to migrate to a different browser for safety, since this new "Feature" can be easily abused by hackers and malicious websites.

Được hỏi bởi cvfnfyltcglvwjgzve 1 năm trước

Được trả lời bởi jscher2000 - Support Volunteer 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Set up custom default search URL

I'd like to use the Startpage search as my default search in Firefox, instead of Google. And I mean the keyword-less search. I know what a search keyword is and I use sev… (xem thêm)

I'd like to use the Startpage search as my default search in Firefox, instead of Google. And I mean the keyword-less search. I know what a search keyword is and I use several for special search engines (map, Wikipedia, dictionaries, parcel tracking, etc.). But the default search must work without any keywords.

And I want to use the custom settings they provide as URL parameters. I've tried with the cookie option but the cookie expires even after regular use. So the custom URL is the only working solution. Startpage support recommended me doing that.

I know that I can install the Startpage search to Firefox and it worked. But I can't combine it with the custom settings. So I uninstalled the extension, deleted the search engine and went to my custom startpage.com URL. Right-clicking the URL bar allowed me to add the search engine from there. But it also doesn't have my settings.

I couldn't find the search URL in about:config. Where is it stored? I need to change whatever Firefox thinks is Startpage's search URL to include my settings.

Changing the settings is critical because by default they open clicked results in a new tab which I cannot stand. I have enough open tabs, and there's still the back button.

Được hỏi bởi ygoe 2 năm trước

Được trả lời bởi jscher2000 - Support Volunteer 2 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Where did Page Setup / Margins & Header/Footer go?

I'm using Firefox 85.0.2 . . . I was doing this (below), to customize my header and footer, but in this version of FF, I no longer see this in Options - only in: about:c… (xem thêm)

I'm using Firefox 85.0.2 . . . I was doing this (below), to customize my header and footer, but in this version of FF, I no longer see this in Options - only in: about:config . . . keyword "footer" . . . there, I would have to change it for 5 different ways of printing (to printers or to PDF)

I need to get rid of printing the URL in the footer - many times, it's too long, and I don't need it.

Where did the Page Setup option go?

I see in the current Print Options, you have to go to - More Settings / Margin / Custom - to see those. Why would they put this so many levels down?

It used to be: File / Page Setup / Margins & Header/Footer . . . "Customize" Headers & Footers:

Option 1 (left) . . . there are two leading spaces:

 > > &T
 > > &U . . . &D . . . &PT

Option 2 (left) . . . get rid of the ">"s, and just have the two leading spaces:

 &T
 &U . . . &D . . . &PT

Được hỏi bởi sludge7051-x 3 năm trước

Được trả lời bởi jscher2000 - Support Volunteer 3 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox closes my open tabs when I exit

I have the Startup checked, to Open previous windows and tabs, but when I close Firefox, all tabs are closed. I have "Remember history" selected under History. Under "Coo… (xem thêm)

I have the Startup checked, to Open previous windows and tabs, but when I close Firefox, all tabs are closed. I have "Remember history" selected under History. Under "Cookies and Site Data" the box that says, "Delete cookies and site data when Firefox is closed" is unchecked. See uploaded images.

Được hỏi bởi netxconsulting 1 năm trước

Được trả lời bởi netxconsulting 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Is there a way to remove recent bookmarks from the "hamburger menu"

Is there a way to remove recent bookmarks from the "hamburger menu" (says "Open Application Menu" on hovering)? The bookmarks there seem to only show the most recent book… (xem thêm)

Is there a way to remove recent bookmarks from the "hamburger menu" (says "Open Application Menu" on hovering)? The bookmarks there seem to only show the most recent bookmarks added and there's no way to organize those or delete them without also deleting the bookmarks from the main bookmarks menu, which can be organized. There should be a way to not show bookmarks that are private bookmarks just because they've recently been added. I couldn't find an answer to this anywhere in support -- though I might not have been searching the right terms. Any and all help would be much appreciated. (Also, apologies if I put this in the wrong category. Wasn't sure what to use.) Thanks!

Được hỏi bởi scott.andera 1 năm trước

Được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

How to change the Tab color for inactive tabs?

How to change the Tab color for inactive tabs? I have a userChrome file and have been able to change the color of the active tab but cannot do so for the inactive tab. T… (xem thêm)

How to change the Tab color for inactive tabs?

I have a userChrome file and have been able to change the color of the active tab but cannot do so for the inactive tab. The inactive tab color blends into the toolbar color. If I move my mouse cursor over it changes to a slight darker gray color.

Active tab color. I made mine a off white color:

.tab-background[selected="true"] {

   background-color: #f9f7f1 !important;

}

Được hỏi bởi davidhelp 1 năm trước

Được trả lời bởi davidhelp 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox breaks my desktop environment's scrollbar style and (gradient) color and in version 98+ refuses css to approximate it

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has t… (xem thêm)

I work on kubuntu 20.04 with plasma 5.18.8 desktop environment. I have a QtCurve-based custom application style, which I almost match with css for GTK apps. Firefox has to be an exception by itself! Not only that, but it changes my ability to customize its interface, from time to time and even changes access to such ability, on some updates.

My scrollbar customizations in userChrome.css and userContent.css do not work any more (other CSS changes still work, for menu/addressbar/tabbar/bookmarksbar orderint and tab styling). I had to resort to settings in user.js file, to get a 20px width scrollbar, suitable for my big screen, but... it gets very wide when I increase the focus, on some webpages and becomes very ugly! Furthermore, I cannot make sense of the proper use of "ui.themedScrollbar*" settings and the scrollbar and its slider result in the same color. These are my settings in user.js:

user_pref("widget.content.gtk-theme-override", "backwater"); user_pref("widget.non-native-theme.enabled", false); // Use GTK-3.0 gtk.css: set to false user_pref("toolkit.legacyUserProfileCustomizations.stylesheets", true); // Use userChrome.css & userContent.css: set to true user_pref("widget.gtk.alt-theme.scrollbar_active", true); user_pref("widget.non-native-theme.scrollbar.size.override", 20); // If nothing else works, fix scrollbar width to 20px user_pref("widget.non-native-theme.gtk.scrollbar.round-thumb", false); user_pref("widget.non-native-theme.gtk.scrollbar.thumb-size", 1.0); // originally 0.75 user_pref("widget.non-native-theme.gtk.scrollbar.allow-buttons", true); // it was true, anyway... user_pref("layout.css.cached-scrollbar-styles.enabled", false); user_pref("layout.css.color-mix.enabled", true); user_pref("widget.non-native-theme.scrollbar.style", 4); // wide scrollbar theme: set to 4 user_pref("ui.themedScrollbar", "#bad1f5"); user_pref("ui.themedScrollbarInactive", "#668cc4"); user_pref("ui.themedScrollbarThumb", "#e4e4e4"); user_pref("ui.themedScrollbarThumbHover", "#e4e4e4"); user_pref("ui.themedScrollbarThumbActive", "#668cc4"); user_pref("ui.themedScrollbarThumbInactive", "#bad1f5"); user_pref("browser.dom.window.dump.enabled", false); user_pref("extensions.ui.sitepermission.hidden", false); user_pref("fission.experiment.max-origins.qualified", true);

Either with the "ui.themedScrollbar*" settings or without them (and cleared from the prefs.js file), the scrollbar and its slider result in the same color, unless I (tryingly) click on some place on the scrollbar outside its slider; then I can see the slider, _only_ for the duration of the mouse-down event (which causes up or down page-hight scrolling).

The default, very thin scrollbar, as well as my modified wide scrollbar with invisible slider are both useless to me! I have even tried fx-autoconfig (https://github.com/MrOtherGuy/fx-autoconfig) to make the scrollbar CSS work, but no result. At this point, I am considering switching to another browser, despite the trust I have to mozilla, for my data and privacy.

Được hỏi bởi kavadias 1 năm trước

Được trả lời bởi kavadias 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

How to get Content Types Back in Applications

Many file types are no longer listed under Settings > Applications>Content Type at about:preferences#general. I used to be able to click on a file in an email like … (xem thêm)

Many file types are no longer listed under Settings > Applications>Content Type at about:preferences#general. I used to be able to click on a file in an email like a Word or Excel document, and it would come up on my screen. Now Firefox asks me to Save them. I don't want to automatically save files without first looking at them. How can I get those file types in the Application list again?

I have attached a pic of the file types I have left to chose from. There used to be a lot more. How can I get back all the missing choices I have had there for years?

Được hỏi bởi mishasarkpetsitting 1 năm trước

Được trả lời bởi jscher2000 - Support Volunteer 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Spell Check not working.

Dear Sir or Madam, I'm running 101.0.1 and spell check no longer works on any mail app like Gmail, Outlook, Yahoo, BT Mail. If I use Chrome or Edge then spell check work… (xem thêm)

Dear Sir or Madam,

I'm running 101.0.1 and spell check no longer works on any mail app like Gmail, Outlook, Yahoo, BT Mail. If I use Chrome or Edge then spell check works correctly. This is despite my Firefox Settings being as below.....

Language Choose the languages used to display menus, messages, and notifications from Firefox. ENGLISH GB Set Alternatives… ENGLISH GB Choose your preferred language for displaying pages. Choose… ENGLISH (United Kingdom) (en-gb) Check your spelling as you type = Tick (Yes)

Could you please advise a fix?

Kind regards,

Neil.

P.S. If I use Chrome or Edge then spell check works correctly.

Được hỏi bởi Trinovantes 1 năm trước

Được trả lời bởi Trinovantes 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Compact mode: bookmark spacing/padding in Firefox 112.0 on Windows 10 - (since version 89?)

Firefox 112.0 running on Windows 10 64-bit laptop with a small (pixel geometry) display screen has unnecessarily large padding (white space) around each bookmark as I nav… (xem thêm)

Firefox 112.0 running on Windows 10 64-bit laptop with a small (pixel geometry) display screen has unnecessarily large padding (white space) around each bookmark as I navigate bookmarks on the bookmark bar.

I believe this was a change instituted around version 89 (in a nutshell, I could see more - twice as many? - bookmarks listed within a bookmark folder with version 88/before. The vertical whitespace between bookmarks within a folder is excessive and makes it much more necessary to scroll within a (long) list of bookmarks in a folder when looking for one.

There was a procedure posted in the discussion below on how to set and enable "compact density".

Bookmark Padding in New Firefox Versions 2 https://support.mozilla.org/en-US/questions/1369996

The procedure below was attempted - browser.compactmode.show enabled, browser restarted, however, I cannot fin "Customize Toolbar" and "compact".

"go to - about:config search - "browser.compactmode.show" - change to TRUE , then close that window go to - Customize Toolbar at the bottom of that page, there a box called Density. Click that, you'll see "compact (not supported)" Apparently, it IS supported because I chose that. (it looked like it ignored my choice) After I closed Customize Toolbar, the bookmarks were compact spaced again. Exactly how I need them."

Is this fixable/solvable?

Được hỏi bởi wb0gaz 9 tháng trước

Được trả lời bởi cor-el 9 tháng trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox: Move Find bar to the top

I recently upgraded my system and, after installing and using Firefox, I notice the Find (Ctrl + F) bar is now at the bottom of the window. Whereas, it was previously at… (xem thêm)

I recently upgraded my system and, after installing and using Firefox, I notice the Find (Ctrl + F) bar is now at the bottom of the window. Whereas, it was previously at the top (which is more like every other application I use).

After some head scratching and web searches, I remembered I had to fix this issue previously (after a Firefox upgrade some time back). The method to fix it then could be found here: [there a way to put the Find Bar at top] That link is of course to the same question asked 4 years back.

I have once again followed the procedure there explained per: • Access my Firefox profile folder. In my case:

  C:\Users\<Me>\AppData\Roaming\Mozilla\Firefox\Profiles\5ym42ewi.default

• Create folder therein called ‘chrome’ • In that folder create a file called ‘userChrome.css’ • In that file add text:

  .browserContainer > findbar {
    -moz-box-ordinal-group: 0;
  }

However, after doing that (and restarting Firefox), the Find bar stubbornly remains glued to the bottom of the window.

Can anyone tell me how to solve this issue?

As a separate note to the developers: This issue is long-standing, that a web search reveals is still relevant to many users. Any chance of considering making it a standard option?

Được hỏi bởi Spinner 1 năm trước

Được trả lời bởi cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

how do I move bookmarks to the right side

as per my title: how do I move bookmarks to the right side? ps - migrated today from chrome... and amazed you haven't yet realised how MASSIVELY important customising … (xem thêm)

as per my title: how do I move bookmarks to the right side?

ps - migrated today from chrome... and amazed you haven't yet realised how MASSIVELY important customising options are. This place is our virtual home!

stay safe !

Được hỏi bởi alexandre pruykemaker 1 năm trước

Được trả lời bởi alexandre pruykemaker 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

How do I disable the mute button on tabs? Setting "browser.tabs.showAudioPlayingIcon" to false does nothing

The mute icon only shows on hover and takes up 50% of the tab size so I'm constantly accidentally muting tabs without realizing it and silencing video calls and the like.… (xem thêm)

The mute icon only shows on hover and takes up 50% of the tab size so I'm constantly accidentally muting tabs without realizing it and silencing video calls and the like. The top Google result for this issue -- rightfully yelled in all caps because this is an absolutely horrid UX -- says to set browser.tabs.showAudioPlayingIcon to false, but that does absolutely nothing in FF 100.0

Được hỏi bởi exasperated_plum 1 năm trước

Được trả lời bởi user104147805413306348376805769878442569366 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Close Tab button on left

Obviously people have asked this before, but those threads all seem to be closed now. The idea that a browser would not want to have a consistent UI with every other part… (xem thêm)

Obviously people have asked this before, but those threads all seem to be closed now. The idea that a browser would not want to have a consistent UI with every other part of the operating system is absolutely nuts, so why is it not easier (or even automatic?!) to place the 'close tab' button on the left when running on a Mac operating system?

I have tried the solutions recommended here – https://support.mozilla.org/en-US/questions/1253751 – but without any success. Maybe someone could help me understand what I am doing wrong? Better yet, maybe Mozilla could remove the need for such workarounds and implement what ought to be a standard feature?

Được hỏi bởi Kit Marsden 2 năm trước

Được trả lời bởi cor-el 2 năm trước

  • Đã giải quyết

How do I disable the new built-in translator?

I need to disable this horrible translator that is now showing up on top of every page I visit, It keeps showing up even after choosing a translation or disabling transla… (xem thêm)

I need to disable this horrible translator that is now showing up on top of every page I visit, It keeps showing up even after choosing a translation or disabling translations for that language. That is probably a bug, but I don't want to wait for a fix, I need to be able to see the pages I visit completely, this thing prevents me from clicking buttons and and is really anoying.

This is the built-in translation feature since I do not use any translation plugins, and started showing up after an upgrade.

Được hỏi bởi jose90 5 tháng trước

Được trả lời bởi jose90 5 tháng trước