Hiển thị các câu hỏi được đánh dấu: Xem tất cả các câu hỏi
  • Đã lưu trữ

Auto select dictionary

I'm a native Dutch speaker, and also read and write a lot in English. Hence I have two dictionaries installed for spell checking: Dutch and English. I often find myself u… (xem thêm)

I'm a native Dutch speaker, and also read and write a lot in English. Hence I have two dictionaries installed for spell checking: Dutch and English.

I often find myself using one language on one page, and the other on the next, thus having to switch the spell checker dictionary between Dutch and English all the time.

What would be VERY convenient, is either

1. The possibility to use two (or any number) dictionaries at the same time.

Or better yet:

2. The possibility to 'auto detect' the current language, and use that dictionary.

This auto detect thing could simply consist of seeing what dictionary results in the least number of detected spelling errors, and use that.

Thanks for your consideration, this sounds like a rather simple feature to me, yet I've been missing it for many years, and I have in fact found quite some similar requests from other people throughout the internet as well! It would make a great addition to Firefox!

Đã được hỏi bởi Peter_Scheurman 6 năm trước

Trả lời lần cuối bởi James 6 năm trước

  • Đã lưu trữ

Can Firefox HTTP basic authentication dialog handle non-english user name and password?

Firefox's HTTP basic authentication dialog is encoding non-english user name and passwords incorrectly. Everything works when I enter English user name and password. Howe… (xem thêm)

Firefox's HTTP basic authentication dialog is encoding non-english user name and passwords incorrectly. Everything works when I enter English user name and password. However, if I input valid user name and/or password with non-english character(s) in them, I cannot login. The authentication fails.

I turned to Fiddler and found that FireFox is sending incorrectly encoded Authorization header. Traces below. If I send correctly encoded Authorization header everything works. The test below uses Chinese characters.

Working scenario using English user name and password:


GET http://myhost:8080/notification/syndication HTTP/1.1 Accept-Language: en-US User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E) Accept-Encoding: gzip, deflate Connection: Keep-Alive Authorization: Basic dXNlcjE6cGFzc3dvcmQ= Host: myhost:8080


Non-working scenario using non-English character user name and password:


GET http://myhost:8080/notification/syndication HTTP/1.1 Accept-Language: en-US User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E) Accept-Encoding: gzip, deflate Connection: Keep-Alive Authorization: Basic e1UNOnNwc3M= Host: myhost:8080

Note the incorrect Authorization header string product by Firefox code: Authorization: Basic e1UNOnNwc3M=

Correct base64 encoding would have yielded this authorization header instead: Authorization: Basic 55m75b2V5ZCNOnNwc3M=

Is this a bug in Firefox? Perhaps there is a configuration change that I need to make to input non-English user name and password in the basic authentication dialog? Chrome does not have this issue. Internet Explorer has the same problem.

Đã được hỏi bởi Mehboob 5 năm trước

Trả lời lần cuối bởi FredMcD 5 năm trước

  • Đã lưu trữ

spell check does not work with window 10

If you go to options/advance/ The check box for check spelling is clear and even when you engage the feature, close the browser and reopen it, it shows this feature is ac… (xem thêm)

If you go to options/advance/ The check box for check spelling is clear and even when you engage the feature, close the browser and reopen it, it shows this feature is active but if you intentionally misspell anything it does not highlite the mistake. This is a serious problem and I am in the final pre beta stage with Windows 10 and the new release is due [ RTM ] on the 27th or 29th so you guys need to correct this problem cause it does not happen on my windows 8 or 8.1

Đã được hỏi bởi jhaskins20018 5 năm trước

Trả lời lần cuối bởi cor-el 5 năm trước

  • Đã lưu trữ

At least the last three Firefox updates have corrupted the operation of the language bar on my full updated XP desktop.

After each of at least the last three Firefox updates (I was gone in the month of May and thus may be unaware of other updates), the language bar will not perform properl… (xem thêm)

After each of at least the last three Firefox updates (I was gone in the month of May and thus may be unaware of other updates), the language bar will not perform properly. Microsoft Word accepts Japanese entry correctly, but in Firefox it does not operate properly, specifically: once the language option is set to "Japanese," with input specified to be via hiragana, when I enter text it appears in unhighlighted Latin letters and neither offers kanji suggestions nor allows kana input.

My machine is a fully updated Windows XP machine. This problem always appears immediately after a Firefox update.

Đã được hỏi bởi LarryCannon 5 năm trước

Trả lời lần cuối bởi guigs 5 năm trước

  • Đã lưu trữ

Lock spell checker language setting to US English?

Every time I start Firefox, the language is set to UK English. I live in the US and the spell checker flags words that are spelled right for the US, but if I make a typo… (xem thêm)

Every time I start Firefox, the language is set to UK English. I live in the US and the spell checker flags words that are spelled right for the US, but if I make a typo and use the UK spelling, it passes that (and I sometimes miss the typo).

I change the setting to US English and it's fine until I reboot the computer, then I have to do it all again. I admit this is a very minor problem, but it is really frustrating at times - I count on my spell checker because I do make a lot of typos and it helps to catch them (strange neurological condition I won't go into - kind of like dyslexia in the fingers).

Is there some way to FORCE Firefox to start in US English every time? Some line I could add to the about:config for instance?

OS: Linux Ubuntu 14.04LTS Using Gnome (old style) desktop only, Firefox 39.03, I usually have Thunderbird 31.8 and OpenOffice 4.1 all open at the same time, on dual monitors.

Đã được hỏi bởi Archaeometrist 5 năm trước

Trả lời lần cuối bởi cor-el 5 năm trước

  • Đã lưu trữ

I live in Vietnam, how do I prevent websites in Vietnamese? I'm plagued by it, I just want English!!

I've tried playing about with location settings, as much as I dare, and whatever else my limited know-how allows, but I keep getting sites I use all the time in V'mese an… (xem thêm)

I've tried playing about with location settings, as much as I dare, and whatever else my limited know-how allows, but I keep getting sites I use all the time in V'mese and it's driving me mad. All I can think of now is to learn the damned lingo, problem is I just can't make some of the necessary noises, it's physiologically not possible for me, I'm Vietnamese Vernacular Deficient (V.V.D.S. as it's not better known as!) so any help with getting English plumbed in as the one, and only I hope, language option would be hugely appreciated. Hope to hear of a solution soon, thanks for reading,


SiCo.

Đã được hỏi bởi SiCo 5 năm trước

Trả lời lần cuối bởi ideato 5 năm trước

  • Đã lưu trữ

Firefox 41.0.1 does not show correct Hangul(Korean) when I try to input Hangul in input text.

On both Windows and OS X environment, Firefox 41.0.1 does not seem to treat input events correctly when I try to input Hangul. I understand this problem happened in earli… (xem thêm)

On both Windows and OS X environment, Firefox 41.0.1 does not seem to treat input events correctly when I try to input Hangul. I understand this problem happened in earlier old versions on old days.

Attached file shows wrongly treated Hangul characters when I tried to input same contents in upper rectangle.

Đã được hỏi bởi YHRhie 5 năm trước

Trả lời lần cuối bởi guigs 5 năm trước

  • Đã lưu trữ

when I browse anything from mozilla the writting of any webpage showed "CHINESE" Language.

when I search any web site through all page showed in chinese language.I changed the language setting but the result is same.This particular problem showed in "GOOGLE CHR… (xem thêm)

when I search any web site through all page showed in chinese language.I changed the language setting but the result is same.This particular problem showed in "GOOGLE CHROME" also.

Đã được hỏi bởi SUSMOY ROZARIO 5 năm trước

Trả lời lần cuối bởi cor-el 5 năm trước

  • Đã lưu trữ

Keyboard stops working when using Japanese Hiragana input

Whenever I use the Hiragana input method for Japanese (Mac) the keyboard freezes up every other time I try to type. After typing one sentence or phrase in Japanese, I nee… (xem thêm)

Whenever I use the Hiragana input method for Japanese (Mac) the keyboard freezes up every other time I try to type. After typing one sentence or phrase in Japanese, I need to manually switch to another language, then switch back to Japanese to unfreeze the keyboard for use in Firefox. I seems to get stuck when I am offered to choose between homophonous logographs i.e. 用紙 and 要旨, and although the arrow keys work to toggle between different choices, 'enter' nor 'space bar' will register, thus preventing me from naturally exiting the drop down scroll and moving on. This problem only occurs inside Firefox, and only with Japanese Hiragana (Chinese Pinyin works fine ironically). In Safari and other browsers the input method also works fine. Thank you for answering my question.

Đã được hỏi bởi houstonphbu 5 năm trước

Trả lời lần cuối bởi alex_mayorga 5 năm trước

  • Đã lưu trữ

change language firefox on MAC

Hi, I live in the Netherlands but I don't speak Dutch. I'm from Sweden and have both Swedish and English as preferred languages. Since I moved here, Firefox changed the … (xem thêm)

Hi,

I live in the Netherlands but I don't speak Dutch. I'm from Sweden and have both Swedish and English as preferred languages. Since I moved here, Firefox changed the language to Dutch. I understand that IP-related issues cannot be solved with firefox (searching for a brand on facebook in one of the languages I know but ending up on the Dutch page) but I really would like to be able to understand my browser. The solution is probably simple - but since everything is in Dutch I can't navigate my way to where I need to make the change. For the last two months I've been using Safari as a result, which I'm not particularly happy about either.

Please help me, and not by guiding me in English on where to go as it will be different in Dutch.

Thanks, Frida

Đã được hỏi bởi fridaevahelen 5 năm trước

Trả lời lần cuối bởi FredMcD 5 năm trước

  • Đã lưu trữ

Firefox changes default language

Hi, I have several times had the experience that Firefox changes the default language in a middle of a session. It just happend. Firefox stopped working for a few seconds… (xem thêm)

Hi,

I have several times had the experience that Firefox changes the default language in a middle of a session. It just happend. Firefox stopped working for a few seconds, and when it was back, the language had changed from Danish to English. It's actually not a problem if it didn't also delete all my settings, and it also changes the default language of my Zotero Account.

Is there a way I can change it back, without loosing my settings?

Lykke

Đã được hỏi bởi ggbibl 5 năm trước

Trả lời lần cuối bởi FredMcD 5 năm trước

  • Đã lưu trữ

Google on Firefox goes Chinese

Do google searches on Firefox and I get English hits with Chinese writing mixed in, all Chinese writing for the top of the page items, all chinese in the panel on the ri… (xem thêm)

Do google searches on Firefox and I get English hits with Chinese writing mixed in, all Chinese writing for the top of the page items, all chinese in the panel on the right.

Run Opera on the same machine at the same time and make the same search and get no problem at all.

Đã được hỏi bởi abrogard 5 năm trước

Trả lời lần cuối bởi cor-el 5 năm trước

  • Đã lưu trữ

Change languague without reinstalling Firefox

Dont have the administrator rights (at work) and I need to change the languague of my Firefox. I am desperate. Dont want to use Internet Explorer, I prefer to quit my job… (xem thêm)

Dont have the administrator rights (at work) and I need to change the languague of my Firefox. I am desperate. Dont want to use Internet Explorer, I prefer to quit my job.

Đã được hỏi bởi hrc893 4 năm trước

Trả lời lần cuối bởi cor-el 4 năm trước

  • Đã lưu trữ

page set up is in metric

My page set up just changed from inches to metric. Paper size is Letter. So what happened with the latest Firefox? Been using it for years and never saw this issue bef… (xem thêm)

My page set up just changed from inches to metric. Paper size is Letter. So what happened with the latest Firefox? Been using it for years and never saw this issue before.

Đã được hỏi bởi sleeperph 4 năm trước

Trả lời lần cuối bởi 1984WasNotaManual 4 năm trước