Hiển thị các câu hỏi được đánh dấu: Xem tất cả các câu hỏi
  • Đã khóa
  • Đã lưu trữ

how to open a firefox browser through selenium 3.6.0 with another profile using Javascript

I would like to open firefox through selenium and upon file download, the file to be stored on another path other than the default, the downloads folder, automatically, w… (xem thêm)

I would like to open firefox through selenium and upon file download, the file to be stored on another path other than the default, the downloads folder, automatically, without getting the prompt dialog.

This is can be done through configuring a new profile but I can't find any implementation example on the web.

Thank you in advance

Asked by tzifosPali 1 năm trước

Last reply by Roland Tanglao 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Cannot access passwords; cannot remake passwords

Problem: Cannot access passwords protected by master password. Normal mode symptoms: - No master password is ever asked -- Trying to set one is futile (see screen… (xem thêm)

Problem:
Cannot access passwords protected by master password.

Normal mode symptoms:
- No master password is ever asked
-- Trying to set one is futile (see screenshot)
- Certificate is at status "Ready" instead of "Logged In" or "not Logged In" (see screenshot)
- No fields are filled with usernames and passwords when needed.
-- No prompt for it is shown either

Background:
I transitioned from windows to linux
I made a full copy of all my profile when transitioning.
I controlled firefox's version to make sure I would transition using the same version number.
I have backups.
Nothing appears in the browser's console when I start or when I try to change master password.
If I try to view the passwords I have, however... ~120 messages appear telling it cannot decrypt (see screenshot)

Tried:
1-Safe-mode:
-- The master password system works as it is supposed to. I get a master password prompt at browser's first password use.
2- Deleting prefs.js
-- Still not working
3- Disabling all extensions manually
-- Still not working
4- Deleting storage directory
-- Still not working

-Trying 2 + 3, 3 + 4, 2 + 3 + 4 or 2 + 4....
-- Still not working.

What am I missing?
Thanks in advance

Asked by brunoais 1 năm trước

Answered by brunoais 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

the profile

hello, Hi, My profile: APPDATA \ Mozilla \ Firefox \ Profiles \ it often changes itself and I lose all passwords, registered add-ons. What are the causes Cordially. Berna… (xem thêm)

hello, Hi, My profile: APPDATA \ Mozilla \ Firefox \ Profiles \ it often changes itself and I lose all passwords, registered add-ons. What are the causes Cordially. Bernard

Asked by lacourtoisie 1 năm trước

Answered by FredMcD 1 năm trước

  • Đã khóa
  • Đã lưu trữ

Firefox Video control template

Hello team firefox! I'm building my own webpage, where some videos are played (with scenes, so there will be a back and next button). When i embeed a video with the contr… (xem thêm)

Hello team firefox!

I'm building my own webpage, where some videos are played (with scenes, so there will be a back and next button). When i embeed a video with the controlls, everything works. But: as soon as i turn on fullscreenmode (which the videos are played in normally), my two next and back buttons dissapeer (behind the video ofc).

So my questions to you: could you please send me your video control html, css and js? Would be reaaaly cool of you!

Asked by paasi6666 1 năm trước

Last reply by Roland Tanglao 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Open a IE window from parent page launched using Firefox

We have an application that was integrated with several other legacy applications in the organization. We started upgrading our application to HTML 5 standards to make it… (xem thêm)

We have an application that was integrated with several other legacy applications in the organization. We started upgrading our application to HTML 5 standards to make it work with all modern browsers such as Firefox, Chrome and Edge. Now the problem is that, our application has redirect links to 3 to 5 legacy applications that were coded for IE 7 and no where in the migration path. When the users click on these links while working on our application, Firefox opens a blank page, making them as blockers for our application uplift. 1) is there a way to force a link to open in IE while the parent page is launched using Firefox ? I have seen this link : https://stackoverflow.com/questions/43615678/force-a-link-in-i-e-to-open-in-firefox , but this is for the opposite requirement...open Firefox from IE. 2) how do you run applications requiring .cab files on Firefox ? if there is an answer for this, we don't need to worry about #1.

Thanks.

Asked by Ravix5 1 năm trước

Answered by Roland Tanglao 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

send a message for misfuction

Ripeto i miei dati: windows 10 aggiornato; kaspersky internet security; tutto funziona perfettamente. Oggi ho aggiornato a Firefox 63. Da ieri mi appare che i segnalibri … (xem thêm)

Ripeto i miei dati: windows 10 aggiornato; kaspersky internet security; tutto funziona perfettamente. Oggi ho aggiornato a Firefox 63. Da ieri mi appare che i segnalibri non possono funzionare correttamente. Ho seguito tutte le vostre possibili soluzioni ed aiuti. Da ultimo ho provato a ripristinare i segnalibri; mi dice che non posso salvare il backup. Cosa posso fare. Grazie. SOCREMBERGAMO

Asked by socrembergamo 1 năm trước

Answered by socrembergamo 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Did not receive gift card for firefox survey

I opened firefox a couple of days ago and was lead to a survey on firefox itself and thought why not do it? It asked a bunch of questions of whether I used it or other br… (xem thêm)

I opened firefox a couple of days ago and was lead to a survey on firefox itself and thought why not do it? It asked a bunch of questions of whether I used it or other browsers like chrome, safari, etc, how often and what I use it for, and etc. At the end of the survey that took about 20-35 minutes, it asked for my email so that they can send me a $5 Amazon Gift Card. I completed this on the 24th. The website in question where I filled the firefox survey at was, "forthrightsurveys.com" Returning to the website (specifically the last page right when I submitted my email, "forthrightsurveys.com/[whole bunch of strings]) gives the prompt "This questionnaire has already been completed using your ID. It may only be completed once be each respondent." Going to forthrightsurveys.com url in general links me specifically to "intellisurvey.com", so I can't check to see if I might have put my email wrong.

I have been checking my inbox and my junk mail just in case but I have still not received an email. Is there anyway to get my giftcard or to be able to redo the survey in order to be able to get my giftcard? I have tried to check the firefox website for support in general as to who to email in regards to this, but all it leads to is back to this forum to ask my question.

Asked by taigatop 1 năm trước

Answered by taigatop 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Is the website "firefoxsupport.org" legit? I may have been hacked by them

I was looking for support after experiencing big problems after the last firefoxupdate (windows 10 crashing). Found this website firefoxsupport.org and they seem legit. A… (xem thêm)

I was looking for support after experiencing big problems after the last firefoxupdate (windows 10 crashing). Found this website firefoxsupport.org and they seem legit. After chatting with them via their online chatbox (no red flags), i gave them permission to call me, And the guy seemed very knowledgeable and professional (still no red flags). So i gave him permission for remote access. He claimed i was infected with some kind of trojan, and was asking for money to fix it, and also there was timepressure. Those were red flags for me so i hung up and broke the connection. But now i my firewall is down and internetconnection gone.

Asked by BassD 1 năm trước

Answered by James 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

email with user name not received

Your system keeps telling me that you have sent an email but nothing turns up - and yes I have checked my junk file folder and there is nothing in there. [Personal inform… (xem thêm)

Your system keeps telling me that you have sent an email but nothing turns up - and yes I have checked my junk file folder and there is nothing in there.

[Personal information removed by moderator. Please read Forum rules and guidelines, thanks.]

Asked by Sandgroper48 1 năm trước

Answered by McCoy 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

The erasing key not working to go history back -1

Hello, i started using Linux (Debian stretch) and after a few days i realized that in Firefox (63.0.1 64bit) can no longer use the deleting key (not "Delete", but one tha… (xem thêm)

Hello, i started using Linux (Debian stretch) and after a few days i realized that in Firefox (63.0.1 64bit) can no longer use the deleting key (not "Delete", but one that is used to erase text from right to left) to go back in history on a tab. I found i can use the keyboard shortcut Ctrl+right arrow, but this one is much less handy than single key which i am missing.

Second problem is that when i click back button by mouse, then it do not scroll the page to the spot where i was, but the scrollbar is on the top of the page which is not convenient.

These two things seems like a small issue, but it making quick browsing uneasy. Please how to fix these issues?

--- Yes, in about:config, i had to set "browser.backspace_action " to be "0", unsure why on Linux they do it differently.

Asked by #367259 1 năm trước

Answered by cor-el 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox crashes

After I updated an add-on (Flash) that was suggested by Firefox, I have not been able to start Firefox. It crashes on startup every time. I have gone through each of th… (xem thêm)

After I updated an add-on (Flash) that was suggested by Firefox, I have not been able to start Firefox. It crashes on startup every time. I have gone through each of the suggestions on how to fix it but none have worked. I have even tried to open Firefox in safe mode but it still crashes on launch. I have also tried to go through the refresh process and it still crashes. Finally, I have even deleted the application and re-downloaded it. It seems to install fine, but still crashes when launched.

Crash ID: bp-68517d71-1ca6-4a37-a27d-701f10181028

I would appreciate any other suggestions. Thanks.

Asked by FormerBluffer 1 năm trước

Answered by philipp 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

how do override firefox on a site I want to bookmark that is listed as untrustworthy

I use a number of sites almost weekly for my business. I have been able to bookmark links on Chrome but when I try to do the sale for Foxfire, I get an error that these s… (xem thêm)

I use a number of sites almost weekly for my business. I have been able to bookmark links on Chrome but when I try to do the sale for Foxfire, I get an error that these sites are not trustworthy and cannot be saved. How do I override this problem so I can save these bookmarks or do I need to go back to Chrome?

Asked by biznetguy 1 năm trước

Answered by jscher2000 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Programming code is visible when viewing a page with Firefox, but not on other people's screens..

I've added some extra code to automatically show the correct language to visitors based on their location settings. This is working properly for the people who have chec… (xem thêm)

I've added some extra code to automatically show the correct language to visitors based on their location settings. This is working properly for the people who have checked it and they are only seeing the correct language, but the CODE is visible on the webpage when I check it on my own computer. I recognise it must be a Firefox setting on my computer, but can not determine which setting it is. Any help is appreciated.

Asked by lgould 1 năm trước

Answered by user633449 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Since an update my bookmarks can´t be found, replaced or restored, it claims the system is in use somewhere else.

I can't restore bookmarks or create new ones since a firefox update. It is like the whole bookmark tool stopped working. There is a red note saying the the system (or fil… (xem thêm)

I can't restore bookmarks or create new ones since a firefox update. It is like the whole bookmark tool stopped working. There is a red note saying the the system (or file) is in use somewhere else, which it is not.

Asked by KatarinaSjogren 1 năm trước

Answered by Scribe 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Firefox crashes

I used to run Firefox without problem but lately had been using Safari. Wanted to get back to Firefox last week and downloaded the newest version. Since then I can't star… (xem thêm)

I used to run Firefox without problem but lately had been using Safari. Wanted to get back to Firefox last week and downloaded the newest version. Since then I can't start Firefox; it crashes on start-up every time. I'm on a Mac, OS 10.12.6 (Sierra). I'm not especially techy but I have tried safe-start and a clean start with no success. Did submit crash reports, the last one about 10 minutes ago (Crash ID: bp-18a0ccaa-1f9e-4478-ada4-3ea8d0181109). If someone could help, that would be great. I am really fed up with Safari :(. Thanks in advance.

Asked by SabineC 1 năm trước

Answered by SabineC 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Movie Trailers or Clips will not play on Metacritic

Movie trailers will not auto-play after the 30 second intro ad. After the ad the video remains blank. This problem also exists when Firefox is restarted in safe mode. Wor… (xem thêm)

Movie trailers will not auto-play after the 30 second intro ad.

After the ad the video remains blank.

This problem also exists when Firefox is restarted in safe mode.

Works fine when using other browsers such as Chrome or Edge!

Please look into this!

Asked by DeanA320 1 năm trước

Answered by DeanA320 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Website error in WIndows 10 Home 64bit oem

Hey Guys and Gals, I have a website problem with Firefox in Windows 10 Home 64bit oem. I am trying to get to Cyberlink.com and I get error . I also get error if I try usi… (xem thêm)

Hey Guys and Gals,

I have a website problem with Firefox in Windows 10 Home 64bit oem.

I am trying to get to Cyberlink.com and I get error . I also get error if I try using Chrome. Attached at 2 screenshots, 1 FF and 1 Chrome.

I cant access the site using either browser in wiindows 10.

Microsoft Edge accesses it fine thou. Also I have a Linux virtual OS on my system and I can access Cyberlink.com using firefox in it.

I thought maybe it was my system but it also happened on 2 other computer running Windows 7. But to be on safeside I ran Windows 10 troubleshooter and no problems were found. I ran SFC /scannow from Elevated CMD prompt and it found no errors. I than ran a DISM /Online /Cleanup-Image /CheckHealth and it found no problems.

Anyone else have an issue accessing Cyberlink.com (cyberlink dot com) just in case links are blocked?

And how would I fix the issue if it is only my system?

Please let me know. Thanks in advance Gren

Asked by Grendor 1 năm trước

Answered by Grendor 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Embedded vimeo link incorrectly displays privacy notice

One of the sites I support now reports (incorrectly) that the video cannot be played due to privacy setting (see first uploaded image). This only happens in Firefox Chrom… (xem thêm)

One of the sites I support now reports (incorrectly) that the video cannot be played due to privacy setting (see first uploaded image). This only happens in Firefox

Chrome doesn't have this issue; see second uploaded image.

All this worked ok in Firefox until recently Thanks

Asked by lister171254 1 năm trước

Answered by jscher2000 1 năm trước

  • Đã giải quyết
  • Đã lưu trữ

Version 63.0.1, YouTube videos not showing on Mac

I'm using YouTube from a Mac with OS Mojave version 10.14, Firefox version 63.0.1. YouTube videos just aren't showing up for me, either on the YouTube site or embedded. … (xem thêm)

I'm using YouTube from a Mac with OS Mojave version 10.14, Firefox version 63.0.1. YouTube videos just aren't showing up for me, either on the YouTube site or embedded. This is true:

- for multiple videos;

- after deleting YouTube's cookies from my browser;

- whether I'm signed into YouTube or not;

- whether I disable AdBlock (and my other handful of extensions) or not;

- whether I started Firefox in Safe Mode or not.

I've attached a couple of screenshots of what YouTube looks like for me. Most of the time it loads correctly, but the video just doesn't appear. Sometimes (e.g. after disabling all add-ons and refreshing) it loads the other, whiter, even less interactive option. Oh! And it works fine in Safari on the same device.

Help would be much appreciated please!

Asked by Balladeer 1 năm trước

Answered by Balladeer 1 năm trước