Media Source API (MSE) and FireFox problem

Following approach to show video stream via Media Source Extensions (MSE) works well in Chrome, Edge, Opera but not in FireFox: Media Source API mediaSource = new Medi… (xem thêm)

Following approach to show video stream via Media Source Extensions (MSE) works well in Chrome, Edge, Opera but not in FireFox:

Media Source API


mediaSource = new MediaSource() sourceBuffer = mediaSource.addSourceBuffer(myCodec) sourceBuffer.mode = "sequence" sourceBuffer.addEventListener('updateend', function () { UpdateEndHandler(self); }, false) sourceBuffer.addEventListener('updatestart', function () { UpdateStartHandler(self); }, false)

and in the events UpdateStartHandler and UpdateEndHandler is processed the value of - sourceBuffer.buffered.end(0)

The problem is that FireFox often returns the same values for UpdateStartHandler and for UpdateEndHandler event which si not correct because into sourceBuffer.appendBuffer were appended real video data. Chrome, Edge, Opera returns two different values.

Please help.

Đã được hỏi bởi valent1 20 phút trước

okay to have many extensions but keep them disabled?

hi, i have a dozen extensions that i wouldn't mind keeping in case i want to use them sometime, though i know you're supposed to keep extensions to a minimum to avoid co… (xem thêm)

hi, i have a dozen extensions that i wouldn't mind keeping in case i want to use them sometime, though i know you're supposed to keep extensions to a minimum to avoid complications and slowness. Does disabling add-ons avoid the problems just like deleting them altogether would? thanks!

coatli

Đã được hỏi bởi coatli 2 giờ trước

Trả lời lần cuối bởi TyDraniu 1 giờ trước

IDM Integration Module

I installed IDM Integration Module 6.40.3.2 and every time I start Firefox I get a pop-up window asking permission to send information to IDM. Has anyone else have this … (xem thêm)

I installed IDM Integration Module 6.40.3.2 and every time I start Firefox I get a pop-up window asking permission to send information to IDM. Has anyone else have this problem and is there a way to fix this? I'm using Firefox 94.0.2 (64-bit) for Windows 10.

Thanks in advance.

Đã được hỏi bởi bjh 1 giờ trước

Trả lời lần cuối bởi bjh 1 giờ trước

false crash report

While running Firefox browser in Windows10, every once in a while a 'sorry your Firefox has crashed' box pops up. Yet the browser is still running just fine. Any ideas? … (xem thêm)

While running Firefox browser in Windows10, every once in a while a 'sorry your Firefox has crashed' box pops up. Yet the browser is still running just fine. Any ideas?

Đã được hỏi bởi cech3 1 ngày trước

Trả lời lần cuối bởi cech3 1 giờ trước

O’Reilly not loading page properly

Dear Firefox community I wonder if anybody else is experiencing problems with O’Reilly recently. I think the problem started more or less 2 weeks ago. The problem is tha… (xem thêm)

Dear Firefox community

I wonder if anybody else is experiencing problems with O’Reilly recently. I think the problem started more or less 2 weeks ago. The problem is that the page is not loaded at once, but more "on demand," that is, it loads once we scroll down (fig. oreilly_firefox_01). It takes like 1s or 2s to load to load the rest of the text (fig. oreilly_firefox_02). Maybe it's related with the last Firefox update. With Chrome it works as expected.

It's not a big issue, just annoying.

94.0.2 (64-bit) OS Name: Microsoft Windows 10 Education OS Version: 10.0.18363 N/A Build 18363

Đã được hỏi bởi marcelo.garcia 2 giờ trước

suddenly unable to login to my bank account

When I logon to my ANZ account - I get a msge " Access denied. Error 15. This request was blocked by the security rules." I can still logon through my iphone app, and als… (xem thêm)

When I logon to my ANZ account - I get a msge " Access denied. Error 15. This request was blocked by the security rules." I can still logon through my iphone app, and also through my other laptop (Macbook), and I tried successfully using another browser (Microsoft Edge), so it must be the settings or a security block on my Dell laptop & Firefox browser? How can I check the settings in Firefox? Thanks Graeme

Đã được hỏi bởi graeme.ching 9 giờ trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

Can't log in to Bank

I am trying to log in to my bank which up until yesterday was fine. I can log in on Chrome. So when i try to long in to the bank on either of our computers it just puts … (xem thêm)

I am trying to log in to my bank which up until yesterday was fine. I can log in on Chrome. So when i try to long in to the bank on either of our computers it just puts a red circle with a line through. I have done nothing different to Firefox at all and it was fine until Sunday (yesterday). No messages come up just the cursor will not click on it... Any help appreciated

Liz C

Đã được hỏi bởi Elspeth 11 giờ trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

Browser

When i enter a new address a message comes up that says "The page isn't redirecting properly, Firefox has detected that the server is redirecting the the request for this… (xem thêm)

When i enter a new address a message comes up that says "The page isn't redirecting properly, Firefox has detected that the server is redirecting the the request for this address in a way that will never complete" How do I remedy this?

Thanks Phillip

Đã được hỏi bởi phillipconnolly23 7 giờ trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

Visited Links color doesn't stick

I believe this started with 94.0.2 but could be 94.0.1. Looking at various things in Easysnews.com, for instance thumbnails, the title for that item used to change from b… (xem thêm)

I believe this started with 94.0.2 but could be 94.0.1. Looking at various things in Easysnews.com, for instance thumbnails, the title for that item used to change from blue (Unvisted Links) to brown (Visited Links) and keep the brown color until I exited Easynews. Now it does not. In another case, looking at my list of favorite groups, the group name will turn brown as long as my mouse is over it but it will not stick if I select that item.

I am not using system colors and Override the colors specified by the page with your selections above is set to Only With High Contrast themes. I tried the other two choices but they really created a mess.

I have also tried deleting any easynews cookies to no effect.

Đã được hỏi bởi rw330i 7 giờ trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

Not able to login into google account

Nothing happens when I enter my gmail id and click Next in google login page. Seeing the below error message in Developer Tools -> Console. Content Security Policy: T… (xem thêm)

Nothing happens when I enter my gmail id and click Next in google login page. Seeing the below error message in Developer Tools -> Console.

Content Security Policy: The page’s settings blocked the loading of a resource at https://ssl.gstatic.com/accounts/static/_/js/k=gaia.gaiafe_glif.en_GB.Qmzxml1wSug.O/am=AVSKJSkBIAAAAQMAAAAACAAAHgRgEJjrDQE/d=0/excm=glif_initial_css/ed=1/rs=ABkqax2exLx40csLSt8ILw0WSxSJK2QV2g/m=sy2x,sy2w,i5dxUd,m9oV,RAnnUd,sy2y,sy2z,sy30,uu7UOe,sy31,sy32,sy33,soHxf (“script-src”).

Đã được hỏi bởi reswaran 5 giờ trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

Keep extensions separate in same Firefox account on different machines

I use a Firefox account on two different machines- one is a Mac and the other is a Windows machine. I have some programs installed on the Windows machine that installed a… (xem thêm)

I use a Firefox account on two different machines- one is a Mac and the other is a Windows machine. I have some programs installed on the Windows machine that installed an extension for Firefox. Those programs are not Mac compatible but because of the same account, those extensions were copied to the Firefox installation on Mac. I was wondering if there is a way to isolate the extensions to just the windows installation? Thanks!

Đã được hỏi bởi Sunny 4 giờ trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

Youtube Videos Infinitely Loading (Attempting to Load but Never Do)

Hello, A few months ago, Firefox has not been loading Youtube videos properly. The video just never loads. Debugging steps I have done. 1) Disabled Hardware Acceleration … (xem thêm)

Hello, A few months ago, Firefox has not been loading Youtube videos properly. The video just never loads. Debugging steps I have done.

1) Disabled Hardware Acceleration 2) Deleted all cookies & cache 3) Ran Firefox in Troubleshoot Mode 4) Uninstalled Firefox & Reinstalled 5) Not a part of my debug but I recently did a fresh install of windows on my computer and installed Firefox with the same issue. I do get videos to work on both Edge and Chrome

I am at a loss at this point and any helping hints would be useful. I have an inkling that it might be put to my playback device but it wouldn't explain why it plays just fine on other browsers.

Any ideas?

Đã được hỏi bởi Aidoneus 1 ngày trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

  • Đã giải quyết

Netflix and Youtube Videos not playing

For some reason I can't watch any of the licensed content on youtube I purchased, and I cannot watch anything on netflix. Both problems appeared at the same time so I tho… (xem thêm)

For some reason I can't watch any of the licensed content on youtube I purchased, and I cannot watch anything on netflix. Both problems appeared at the same time so I thought they might be related. I have disabled hardware acceleration with no effect. I have cleared history and deleted cookies. I have also disabled my vpn, but none of it works.

Anyone else had this problem? Netflix says "browser not supported" and youtube says "problems showing licensed content."

Đã được hỏi bởi eric.lightner 20 giờ trước

Đã được trả lời bởi FredMcD 18 giờ trước

Log in to website

Trying to log into my investing website (Vanguard) So.............I log into the website periodically and several weeks or more ago they 'updated' their site with a new l… (xem thêm)

Trying to log into my investing website (Vanguard)

So.............I log into the website periodically and several weeks or more ago they 'updated' their site with a new look. So when I go to it, it has 'auto-filled' my username and password (just like it used to do) and after the site does the 'handshake' with the window I press the 'Log In' button and nothing happens. Nothing at all, it just sits there. I can launch my (outdated) Internet Explorer browser and do the same thing and it works fine and I go right in to the site. I've tried deleting cookies for the site on the Firefox browser but it doesn't change anything.

So..........ideas? Maybe a plug-in problem???

Thanks, Kent

Đã được hỏi bởi kentoc.58 2 ngày trước

Trả lời lần cuối bởi FredMcD 3 giờ trước

Regular Crashes Playing Wormax.io

Every time I play this online game at the site, Wormax.io, it will lag and/or crash the tab after a few minutes of playing. Occasionally, the site will take a very long t… (xem thêm)

Every time I play this online game at the site, Wormax.io, it will lag and/or crash the tab after a few minutes of playing. Occasionally, the site will take a very long time to load.

Here's my crash report: bp-4fd287ff-c2e1-4168-8e9d-ac1950211202

Đã được hỏi bởi Kevin Kehler 3 ngày trước

Trả lời lần cuối bởi Kevin Kehler 5 giờ trước

Update and ALL passwords, profile, info deleted - HELP!

Major issues after opening Firefox this morning - an update resulted in ALL my data being deleted. Hundreds of passwords, bookmarks, etc all gone. Infuriating is an unde… (xem thêm)

Major issues after opening Firefox this morning - an update resulted in ALL my data being deleted. Hundreds of passwords, bookmarks, etc all gone. Infuriating is an understatement. It is impossible to get in touch with a real person at Firefox to troubleshoot this - what on earth am I meant to do to resolve this!?!?!?!

Đã được hỏi bởi stringer.lc 9 giờ trước

Trả lời lần cuối bởi TNorth 7 giờ trước

Can't log on to my Vanguard account

My new computer is running Windows 11. I just tried to log on to my Vanguard account and the Logon button has no response. Using Microsoft Edge I had no problems logging … (xem thêm)

My new computer is running Windows 11. I just tried to log on to my Vanguard account and the Logon button has no response. Using Microsoft Edge I had no problems logging on so the issue must be with Firefox security controls. I have turned off Ad Blocker Ultimate as well as made an exception for cookies from this site. What can I do to fix this?

Đã được hỏi bởi Steve 12 giờ trước

Trả lời lần cuối bởi rw330i 7 giờ trước