Hiển thị các câu hỏi được đánh dấu: Xem tất cả các câu hỏi

Firefox browser history time spent on each website by user

I am creating a DotNet application to fetch time spent by user on websites visited by him using Firefox browser. The solution I am using does not give correct results for… (xem thêm)

I am creating a DotNet application to fetch time spent by user on websites visited by him using Firefox browser. The solution I am using does not give correct results for Firefox browser. Used approach from below link-

https://social.msdn.microsoft.com/Forums/vstudio/en-US/3e9f3588-ad0b-49af-b269-2abfda0b9abc/how-to-get-the-browser-history-in-program-using-c?forum=csharpgeneral

Output should be as below: 1. www.facebook.com , 20 minutes. 2. www.youtube.com , 15 seconds.

Which columns OR tables should I query to have accurate time spent by user ? I am using tables moz_places and moz_historyvisits. But the last_visit_date column only gives date time stamp when user last visited. As you can see I need total time spent.

Please guide me.

Đã được hỏi bởi contactkx2 23 phút trước

FF auto-updated to 89.0.1, now a site won't work, would like to RESTORE deleted/cleared cookies for that site to see if it will help cuz deleted the cookie for it MADE THINGS WORSE! Doesn't work under PRIVATE SESSION either!!

FF auto-updated to 89.0.1, now a site won't work, would like to RESTORE deleted/cleared COOKIES (?!?!) for that site to see if it will help cuz deleted the cookie for it … (xem thêm)

FF auto-updated to 89.0.1, now a site won't work, would like to RESTORE deleted/cleared COOKIES (?!?!) for that site to see if it will help cuz deleted the cookie for it made things worse! Doesn't work under Private FF session either!!

Specifics: I am the Webmaster of (we use WIX to create/manage it) 12cdrc.org and it is working fine using Edge, Chrome, Brave, but no longer works correctly (since 89.0.1, I think happened late last night early this morning on my system) update. Most of the page loads, but the Calendar and display tweets sub-windows will not load! It will be obvious to all where they should be displaying but are not!

So, I tried removing 12cdrc.org cookies. Things got worse! Now the Login won't work either, where I was logged in as my user for the site prior to that.

I tried a Private window/session, and the Login function does work, the Calendar does show, but the tweets sub-section/window still does not display/function.

Background: This is not the first website to malfunction using Firefox... Previous version updates broke the rescuemichigan.com website (none of the pull-down menu functions work, but work fine on/with Brave, Chrome, Edge)! Also mewe.com acts up using FF at times, but a clear of the mewe.com related cookies and relogin at mewe via FF clears up the issues of things not wanting to display correctly or fully on mewe using FF - which is why I thought clearing 12cdrc.org cookies would help in this case (but did not, again, made the malfunctioning worse)!

This makes little sense. I even tried doing D/L of full 89.0.1 install, didn't help.

I'd like to try and RESTORE COOKIES (last thing I want to do is clear all data/cookies for FF) for 12cdrc.org from manual offload of all my userid appdata folder/sub-folders to an external drive (or perhaps appdata backup to Norton cloud backup done a few weeks ago)! But I do not know where to look. Was about to go to my external drive and do complete file search of "12cdrc*.*" to see what would return when I thought I could search Mozilla/FF Help on "Restore Cookies" but only very old question for very old version of FF showed up and it said "IF STILL NEED HELP ASK NEW QUESTION" so here I am doing so!!!

Again, all sites (12CDRC.org, MeWe.com, and RescueMichigan.com) ALL WORK 100% error/issues free using Brave, Chrome, Edge, so this is FIREFOX SPECIFIC and all these issues have started under/after recent FF updates and/or gotten worse, not fixed/better, under updates/upgrades!!!!

Appreciate any Help... 1) like I said, where the Cookies are hidden that I might then recover them from previous save 2) other suggestions?!?!?!

Đã được hỏi bởi JLenardDetroit 2 giờ trước

server error when trying to log onto nike.com, only in firefox

I have cleared cookies, site preferences, disabled tracking protection, disabled adblockers, and since yesterday still cannot log into nike.com, all I get is a dialog box… (xem thêm)

I have cleared cookies, site preferences, disabled tracking protection, disabled adblockers, and since yesterday still cannot log into nike.com, all I get is a dialog box saying server error.

Nike disavows all knowledge of this problem even though there are tweets from 2017 referencing this exact same problem back then, but nike says no problems now, so it's just me!

Is it Firefox or Nike?? All other sites I have tried are fine, I used chrome to log into nike.com and no problem even though it seems same protections enabled there so there is something wrong with firefox and nike, and I am not about to do anything drastic to firefox for one website.. Anyone have any ideas, solutions, etc.? thanks

Đã được hỏi bởi jg 2 tuần trước

Trả lời lần cuối bởi FredMcD 8 giờ trước

Yahoo Default Search

Everytime I go into settings and change my default search to yahoo, no matter what I do, my search goes to Yahoo. Even if i go to google.com and then search, the yahoo pa… (xem thêm)

Everytime I go into settings and change my default search to yahoo, no matter what I do, my search goes to Yahoo. Even if i go to google.com and then search, the yahoo page comes up. Its come to the point im considering uninstalling firefox to use chrome exclusively which is something I certainly dont want to do after having been a loyal user for over a decade.

Thanks for any help.

Đã được hỏi bởi jem7991 11 giờ trước

Trả lời lần cuối bởi cor-el 8 giờ trước

Suddenly got this error: "Did Not Connect: Potential Security Issue"

I suddenly got this error a few days back and it only appears when I try to open facebook and youtube (or at least just those two websites for now). I can still google th… (xem thêm)

I suddenly got this error a few days back and it only appears when I try to open facebook and youtube (or at least just those two websites for now). I can still google things just fine. I also copied the following from firefox:

https://www.youtube.com/

Peer’s Certificate issuer is not recognized.

HTTP Strict Transport Security: true HTTP Public Key Pinning: true

Certificate chain:


BEGIN CERTIFICATE-----

MIIDSDCCAjCgAwIBAgIEYMoTvDANBgkqhkiG9w0BAQsFADBAMQ4wDAYDVQQKDAVD aXNjbzEuMCwGA1UEAwwlQ2lzY28gVW1icmVsbGEgU2Vjb25kYXJ5IFN1YkNBIGhr Zy1TRzAeFw0yMTA2MTQxNTAyMzBaFw0yMTA2MTkxNTAyMzBaMGwxCzAJBgNVBAYT AlVTMRMwEQYDVQQIDApDYWxpZm9ybmlhMRYwFAYDVQQHDA1TYW4gRnJhbmNpc2Nv MRYwFAYDVQQKDA1PcGVuRE5TLCBJbmMuMRgwFgYDVQQDDA93d3cueW91dHViZS5j b20wggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQDUOxWZs6S+HMCY03le TYlVZ9X3B0qd250c3qpnrxvPaUH4tyiXXv66eA1vOuFl2PipRu8+WeYVhl/b/nfO DuVUbeEZ20Dng5He/KaObcFRXhVrF6eUgsDC5np3yeQIgMon1rNXPp+M+JFmtE9A XOiqA70EStgj/r+v5Acs1BKwl1gnFQtEvAjkgQFpCXQOEWEjXkCxN8THh+U25Ifu 2SQj2KkrYW7cg7nG9MaNuioThOlqYrOqynw+Qls01Pc/mV46sEOg+jqtrw35VI4S fhP3GiiUSw0ktMVGpgTdE0AlYBVK053fxA8zU9oZn2kUpsmRTrMU5QC79HkKKYXm ks8jAgMBAAGjHjAcMBoGA1UdEQQTMBGCD3d3dy55b3V0dWJlLmNvbTANBgkqhkiG 9w0BAQsFAAOCAQEA0tQVuQLjGpTUK0VgMvgvV1eg/+nb9LoIiEZyutXPrQl3Pvoa 1WhGw4woMFcHiVGOyrD68AqJsRH779I6VPhsYKAHJoQcPZ0zs+27HgooaWXfSuGy xBrLJUV6yT+ZqmT1BA2QkYRT8JgWSoBMlXXvLQfwj2KMdlSlVGv1SXu0fq9Y5SyN deir0Nq1p+83p0wr7JQvZHq6CwvQBXDx7XSAVoYIkFVlUBtJlzlPcu75fQBu6bY/ 9zoDVBcQxxANMsT90z8z8a5bzwTP/e9z0mWdiWrpMgHYGWWaRVwZJrDj5vq6rUmw 9JDXWcaNkWmNuulSN0cdyBz8vR5aWgDl/kFYjA==


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIENjCCAx6gAwIBAgIRAOxWhi1BRktMpBCowvYwkjwwDQYJKoZIhvcNAQELBQAw cTELMAkGA1UEBhMCVVMxEzARBgNVBAgMCkNhbGlmb3JuaWExFjAUBgNVBAcMDVNh biBGcmFuY2lzY28xDjAMBgNVBAoMBUNpc2NvMSUwIwYDVQQDDBxDaXNjbyBVbWJy ZWxsYSBQcmltYXJ5IFN1YkNBMB4XDTIxMDYxNDE3NDIwMVoXDTIxMDYyNTE3NDIw MVowQDEOMAwGA1UECgwFQ2lzY28xLjAsBgNVBAMMJUNpc2NvIFVtYnJlbGxhIFNl Y29uZGFyeSBTdWJDQSBoa2ctU0cwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEK AoIBAQDUOxWZs6S+HMCY03leTYlVZ9X3B0qd250c3qpnrxvPaUH4tyiXXv66eA1v OuFl2PipRu8+WeYVhl/b/nfODuVUbeEZ20Dng5He/KaObcFRXhVrF6eUgsDC5np3 yeQIgMon1rNXPp+M+JFmtE9AXOiqA70EStgj/r+v5Acs1BKwl1gnFQtEvAjkgQFp CXQOEWEjXkCxN8THh+U25Ifu2SQj2KkrYW7cg7nG9MaNuioThOlqYrOqynw+Qls0 1Pc/mV46sEOg+jqtrw35VI4SfhP3GiiUSw0ktMVGpgTdE0AlYBVK053fxA8zU9oZ n2kUpsmRTrMU5QC79HkKKYXmks8jAgMBAAGjgfkwgfYwEgYDVR0TAQH/BAgwBgEB /wIBADAOBgNVHQ8BAf8EBAMCAYYwHQYDVR0OBBYEFAIpVEnS1669E34m/m9jW9ug 4JLsMB8GA1UdIwQYMBaAFEVf9ZtxMyWpwE48AkTPPOhGBhbEMEwGCCsGAQUFBwEB BEAwPjA8BggrBgEFBQcwAoYwaHR0cDovL2NybC5wcm9kLmNhZ2VuZXJhdG9yLnBr aS5zdHJsbi5uZXQvY2EucGVtMEIGA1UdHwQ7MDkwN6A1oDOGMWh0dHA6Ly9jcmwu cHJvZC5jYWdlbmVyYXRvci5wa2kuc3RybG4ubmV0L2NybC5wZW0wDQYJKoZIhvcN AQELBQADggEBAKdZP2XFQHAdcRGHN0GQRKge68eFJ58cH4ZSuYysK/SQ5hZfCZ8P qa8pT0xOk9E3ZRvlCSHw1VYLk6HDe5ksTYJi+PH2rJI6f2ILpa0pCJYt/xwsnjtd yqDMmwWqhhMtfwn2XRB8xdH6xYf8kNkO4w7Y5qzWKafSgXZr/LbAmJwugfJoHgfl XQOf996l9qoGBTye3ZTZ1+JPHuZiZ5GQGe5SzKfjPjhF8amPsOdvrqNR3UGNWdWb l74DWwvm5t5/qGCRVzEKJV4T0oYmAfAbSRJ5v/J+/boKYQPAVeu4FJWMiV0W5+zZ nBTpQSZX6UZocMv4NCn1LKswreGxWPe1n5E=


END CERTIFICATE-----
BEGIN CERTIFICATE-----

MIIEuzCCA6OgAwIBAgIJAcQ3zFeNvKYVMA0GCSqGSIb3DQEBCwUAMDExDjAMBgNV BAoTBUNpc2NvMR8wHQYDVQQDExZDaXNjbyBVbWJyZWxsYSBSb290IENBMB4XDTE5 MDUyMTE5NTMxOFoXDTI0MDUyMTE5NTMxOFowcTELMAkGA1UEBhMCVVMxEzARBgNV BAgMCkNhbGlmb3JuaWExFjAUBgNVBAcMDVNhbiBGcmFuY2lzY28xDjAMBgNVBAoM BUNpc2NvMSUwIwYDVQQDDBxDaXNjbyBVbWJyZWxsYSBQcmltYXJ5IFN1YkNBMIIB IjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAuFEhA5TkN8CiGmW7XjaUbuve U274v0kt6hRW8UUakmbyLnkI4d/BBQrGW71LYiT2QH4UaoYuihTXjuyAlzDxJ9OQ Vje2NB9RdE3FcUCISeW5GrQs7vF2xFrjs2TGgG4ZXjE/8WymgFZP50nsTJYf7VqL 1r6Brs59DAbbQ1rVvsz/DFxoE3ruFagSFcOF07/watUxFrAPV+S/kK6Nb5TqrI1j 32hK6i49ujavDcbbb12aozwdoyPSyhs4cB0sCXFHK/yEdaE4CNXEAH8EjKUuj6O2 QUvRtBGM480688BId0T0ws3q+hSzRiVJ+dYCr3iufmTrAMhVwc+EzGjlEfLyXwID AQABo4IBlDCCAZAwDgYDVR0PAQH/BAQDAgGGMBIGA1UdEwEB/wQIMAYBAf8CAQEw UgYDVR0gBEswSTBHBgorBgEEAQkVAR0AMDkwNwYIKwYBBQUHAgEWK2h0dHA6Ly93 d3cuY2lzY28uY29tL3NlY3VyaXR5L3BraS9wb2xpY2llcy8wHQYDVR0OBBYEFEVf 9ZtxMyWpwE48AkTPPOhGBhbEMEwGA1UdHwRFMEMwQaA/oD2GO2h0dHA6Ly93d3cu Y2lzY28uY29tL3NlY3VyaXR5L3BraS9jcmwvY2lzY291bWJyZWxsYXJvb3QuY3Js MIGHBggrBgEFBQcBAQR7MHkwSQYIKwYBBQUHMAKGPWh0dHA6Ly93d3cuY2lzY28u Y29tL3NlY3VyaXR5L3BraS9jZXJ0cy9jaXNjb3VtYnJlbGxhcm9vdC5jZXIwLAYI KwYBBQUHMAGGIGh0dHA6Ly9wa2ljdnMuY2lzY28uY29tL3BraS9vY3NwMB8GA1Ud IwQYMBaAFENzAN4kukAaQFQsfXzVAEiJDHCkMA0GCSqGSIb3DQEBCwUAA4IBAQC6 P7ugvpQSkNxrzY1ZM0Nd9Q3LaoTERS4ItcxMsswFPl7ID/3Vk3v3ZT6KgtCZ+Nh0 MUgZztLATHf42ZppdSkdMf1HfCmLSWORz/eK+fZxztE63M1EGiZJoe8qFKT9z6qx iDD989jyjY74sYfiSo5nbhcb5meUrUO6MQvOO5pUnlhWsDiBUg+yBzyfVoLnGRlY 2t7UZVTUz5kbBNFieTIt86yaYAumgOqriz/dCgQltFySbOkrgg/PN7cRv3IWm84C uKQ9prsXbXLLbl8U+bGRH119prl3zJyRnQ0D+ursCqUnIfziBdKv7yLsupGDGt+Q oqLzmkMPYE+WZmEi+3j5


END CERTIFICATE-----

Đã được hỏi bởi farisfadhir 1 ngày trước

Trả lời lần cuối bởi farisfadhir 13 giờ trước

Translat a page

When I right click in a page and choose "translate this page(auto/nl)" after a few pages I get the message below. I do not use scripts to translate a page. Is this a FF p… (xem thêm)

When I right click in a page and choose "translate this page(auto/nl)" after a few pages I get the message below. I do not use scripts to translate a page. Is this a FF problem or a Google Translate problem? How to solve it?

Đã được hỏi bởi jo.wynant 17 giờ trước

Trả lời lần cuối bởi jscher2000 15 giờ trước

  • Đã giải quyết

No text showing, only images from today on one news website.

I haven't installed any new Add-ons for over a year but suddenly today the Telegraph.co.uk website is only displaying images. I disabled all Add-ons, re started FF but th… (xem thêm)

I haven't installed any new Add-ons for over a year but suddenly today the Telegraph.co.uk website is only displaying images. I disabled all Add-ons, re started FF but that hasn't fixed it. Safari is okay though. Mac 10.11.6 and FF 78.10.1esr Thanks for any tips, can't do without a proper newspaper. Kryters.

Đã được hỏi bởi kryten 3 tuần trước

Đã được trả lời bởi kryten 16 giờ trước

iframe content dont show when <details> is set to close.

Hi everyone, When I use <article> <details close ><summary>This is a test</summary> <iframe width="100%" height="300px" frameborder="0" allowf… (xem thêm)

Hi everyone,

When I use <article> <details close ><summary>This is a test</summary>

<iframe width="100%" height="300px" frameborder="0" allowfullscreen src="https://framacarte.org/en/map/apparts_88475?scaleControl=false&miniMap=false&scrollWheelZoom=false&zoomControl=true&allowEdit=false&moreControl=true&searchControl=null&tilelayersControl=null&embedControl=null&datalayersControl=true&onLoadPanel=undefined&captionBar=false"></iframe>

<a href="https://framacarte.org/en/map/apparts_88475">See full screen</a>

</details>

The content of the iframe doesn't load when I expand the section.

With <details open> it's works...

Any work around ?

Thanks

Đã được hỏi bởi NS134171C 22 giờ trước

Trả lời lần cuối bởi TyDraniu 22 giờ trước

Entering a https://... website address is searched with Google

When I type a website address beginning with "https://" it is searched with Google. For instance, when I type "https://www.gotomeet.me/xxx", this returns a google search… (xem thêm)

When I type a website address beginning with "https://" it is searched with Google. For instance, when I type "https://www.gotomeet.me/xxx", this returns a google search. When I type "www.gotomeet.me/xxx", this correctly opens the webpage. When is beginning a term with the standard "https://" searching with Google? How do I stop this? It is annoying, as I am often copying and pasting these website addresses.

P.S. This began after a Firefox update.

Best regards,

D.S.

Đã được hỏi bởi d.sandbeck 23 giờ trước

[Firefox 89.0.1] Google Maps loads fine, then, AFTER load is complete, goes "dark".

I used to be able to use Google Maps without problem on Firefox. I'm not sure exactly when the problem arose, but I'm positive it is broken on my Firefox 89.0, and now on… (xem thêm)

I used to be able to use Google Maps without problem on Firefox.

I'm not sure exactly when the problem arose, but I'm positive it is broken on my Firefox 89.0, and now on Firefox 89.0.1 - The problem is as follows:

When I load the https://www.google.fr/maps/ site, I see the map load, I see the towns, the roads, the "pins" (shops, points of interest, etc.); I have the names displayed, it looks fine. Then, once it's done loading, the map background disappears, and I'm left with only the names and the pins. Enclosed is a picture of the area around Paris, France, after it "went dark".

If I drag and drop the map, or zoom in or out, the map reappears and is perfectly readable. But as soon as I stop moving it, the map tiles disappear again, and I'm stuck with only the names and pins again.


I've checked under other browsers (Edge, for instance), and the problem seems to occur only on Firefox. I've removed ALL my google-related cookies (because of old answers to problems with Google Maps, saying to try that), and it didn't help. I tried reloading the page, emptying the cache, didn't work either.

Am I the only one to experience this ? Any ideas as to why it happens, or how to correct it ?


OS is windows 10, up to date.

Đã được hỏi bởi Kzwix 1 ngày trước

  • Đã giải quyết

Random pages do not load correctly

Random pages do not load correctly. Sometimes pictures are obscured by a series of small green boxes or partially or wholly covered by a green box. The text appears in … (xem thêm)

Random pages do not load correctly. Sometimes pictures are obscured by a series of small green boxes or partially or wholly covered by a green box. The text appears in these instances as either pink/purple or garbled. I have checked and rechecked all available help in the support section and followed all the suggestions. I have completely removed and reinstalled Firefox three times.

I'd like to keep Firefox as my primary browser. Please help!

Đã được hỏi bởi bb.bubbab 1 ngày trước

Đã được trả lời bởi FredMcD 1 ngày trước

How to translate web pages like in Chrome or Edge?

Is there a possibilty to tanslate web pages in Firefox like the way it can be done in Google Chrome or Microsoft Edge? I have installed an Add-On but it doesn't work the … (xem thêm)

Is there a possibilty to tanslate web pages in Firefox like the way it can be done in Google Chrome or Microsoft Edge? I have installed an Add-On but it doesn't work the way I want(translating the web page right there and not translating it through Google Translate).

Đã được hỏi bởi A. Saxena 6 ngày trước

Trả lời lần cuối bởi jscher2000 1 ngày trước

unable to sign.into.americanairlines.com

I have used Firefox to sign into American Airlines website for years. Now when I try and sign in it says the site is unavailable but I am able to sign in on other devices… (xem thêm)

I have used Firefox to sign into American Airlines website for years. Now when I try and sign in it says the site is unavailable but I am able to sign in on other devices and other servers. I called American Airlines and there is no problem on their end. Why is this happening all of a sudden and only for this one website. Is there anyway I could get around there so I can keep using Firefox to get on American

Đã được hỏi bởi christvroijen 1 tháng trước

Trả lời lần cuối bởi pdurlacher 1 ngày trước

  • Đã giải quyết

"View Image Info" missing

I was recently automatically upgraded to a new version of Firefox (87.0). Now when I right-click on an image "View Image Info" is no longer available. How do I get it bac… (xem thêm)

I was recently automatically upgraded to a new version of Firefox (87.0). Now when I right-click on an image "View Image Info" is no longer available. How do I get it back? I'm a webmaster, and this feature is very important to me. Thanks.

Đã được hỏi bởi bhartford 2 tháng trước

Đã được trả lời bởi jscher2000 2 tháng trước

  • Đã giải quyết

Some Sites gets displayed on Black Ground making it useless.

Firefox recently had a update which was set to automatic and it notified that Firefox is updated. And later I found that some sites seems to be blacked making it useless … (xem thêm)

Firefox recently had a update which was set to automatic and it notified that Firefox is updated. And later I found that some sites seems to be blacked making it useless just like in the image below. I tried these sites in Chrome, Edge but it seems fine but Firefox seems to have this issue. I've tried all possible configs but nothing help. So, Kindly help me out.

Thanks, Sri.

Đã được hỏi bởi sriram_offcl 1 ngày trước

Đã được trả lời bởi FredMcD 1 ngày trước

Ebay wont display properly

Hi since the latest update today, ebat wont display properly, I have tried clearing cookies and cache and made no difference. It displays OK in a private browsing window.… (xem thêm)

Hi since the latest update today, ebat wont display properly, I have tried clearing cookies and cache and made no difference. It displays OK in a private browsing window. Any ideas, or is it just time to migrate to a browser that works?

Đã được hỏi bởi Rossco71 3 ngày trước

Trả lời lần cuối bởi ·´¯`·...¸>-)))º> ~dbben 1 ngày trước

  • Đã giải quyết

words disappear from Gmail drafts in German

When I use Gmail in my up-to-date Firefox under Windows 10 or Linux and type e.g. "Leser und Leserinnen", then exit the draft and reopen it, "und Leserinnen" is gone. Thi… (xem thêm)

When I use Gmail in my up-to-date Firefox under Windows 10 or Linux and type e.g. "Leser und Leserinnen", then exit the draft and reopen it, "und Leserinnen" is gone. This happens to all tested feminine forms ending with "-innen", even irregular or non-existing ones, if they follow the masculine form and " und " (both preceded and followed by exactly one space). The truncation is case insensitive, and when I type the feminine form first, "innen" will be cut, and " und [masculine]" as well. Turning off auto-correction didn't help. Also, when I send a mail containing such a double form, it arrives correctly, but in my sent mails " und [feminine]" is gone. However, when I then open "forward" or "reply" with repetition of the sent mail, the deleted words are back in place. None of this happens when I use another browser or an E-Mail client or the Gmail app on my phone, nor does it happen with other mail providers, not even when using Firefox. I know this sounds weird, as if there were an automatic "politically incorrect maker". But it is exactly what happens. I wonder if anyone can replicate the phenomenon or - even better, find out why it occurs.

Đã được hỏi bởi danigold3067 3 tháng trước

Đã được trả lời bởi dg7 1 ngày trước