Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Firefox crashes literally all the time. Why?

  • 7 trả lời
  • 108 gặp vấn đề này
  • 6819 lượt xem
  • Trả lời mới nhất được viết bởi HamlinRacing

more options

Firefox (Version 29.0) keeps crashing on me several times per day. I have done the following to try and fix it but it still crashes. I was better off on the Aurora it seems.

Add-Ons: I tried disabling them but Firefox still crashed. I only have 2 extensions installed.

Plugins: I have checked all my plugins and it says that Adobe Acrobat (Adobe PDF Plug-In For Firefox and Netscape 10.1.9) is vulnerable but when I go to update it, Adobe tells me that I already have the latest update installed. The same thing for Java Deployment Toolkit 7.0.550.14 & Java(TM) Platform SE 7 U55. I go to update them and Java tells me I am already up to date.

Reinstall & Safe Mode: I have completely uninstalled then re-installed Firefox along with trying Firefox in Safe Mode. It still crashes.

Crash Reports:

  • bp-aa93bed4-37c8-425e-a9ba-4b9242140507
  • bp-3a2d79c7-a613-419f-aa12-c6c9d2140507
  • bp-abe6f72c-eb62-4547-863b-3ab0d2140507
  • bp-6fc2234f-8bae-4848-857f-811442140505

Aaaaaaaaaaaaaaaaaaanyone have any idea why this keeps happening?

Được chỉnh sửa bởi NoahSUMO vào

All Replies (7)

more options

Well, the last one is due to Flash.

Try disabling Hardware Acceleration.

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

The rest have different signatures.
Disable Hardware Acceleration in Firefox and see if it crashes again
Firefox has hardware acceleration set to "on" by default, but it's still young, which means some video cards or drivers might have problems with it. You can try to disable hardware acceleration to see if that alleviates your problems.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps for Firefox version 29.0 and above:

  • Click the menu button New Fx Menu and select {menu Options} for Windows or {menu Preferences} on Mac or Linux. For Firefox 28.0 and previous versions, click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window, click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

more options

I tried that and my computer crashed. I got the following:

Problem signature:

 Problem Event Name:	BlueScreen
 OS Version:	6.0.6002.
 Locale ID:	1033

Additional information about the problem:

 BCCode:	4e
 BCP1:	00000099
 BCP2:	0003C8E4
 BCP3:	00000002
 BCP4:	0003C887
 OS Version:	6_0_6002
 Service Pack:	2_0
 Product:	768_1

Files that help describe the problem:

more options

We may be on the path away from Firefox support and onto Microsoft's territory.

I'll escalate this thread to the professional full-time SUMO HelpDesk to see if they can't help us out here.

Can you send me your troubleshooting information from the Firefox installation that's having issues? This is a good part in troubleshooting.

  • Navigate to about:support via Address Bar
  • Click the button that says Copy text to clipboard
  • Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.
more options

I also get this scripting error often:

"A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.


more options

Here's the troubleshooting info you requested:

Application Basics

Name: Firefox Version: 29.0 User Agent: Mozilla/5.0 (Windows NT 6.0; rv:29.0) Gecko/20100101 Firefox/29.0

Crash Reports for the Last 3 Days

Report ID: bp-aa93bed4-37c8-425e-a9ba-4b9242140507 Submitted: 2 days ago

Report ID: bp-3a2d79c7-a613-419f-aa12-c6c9d2140507 Submitted: 2 days ago

Report ID: bp-abe6f72c-eb62-4547-863b-3ab0d2140507 Submitted: 2 days ago

All Crash Reports


Name: Ebates Cash Back Version: Enabled: true ID: {35d6291e-1d4b-f9b4-c52f-77e6410d1326}

Name: Pocket Version: 3.0.4 Enabled: true ID:

Name: HP Smart Web Printing Version: 4.60 Enabled: false ID:

Name: Microsoft .NET Framework Assistant Version: 0.0.0 Enabled: false ID: {20a82645-c095-46ed-80e3-08825760534b}

Name: Move Media Player Version: 7 Enabled: false ID:

Important Modified Preferences

browser.cache.disk.capacity: 358400 browser.cache.disk.smart_size_cached_value: 358400 browser.cache.disk.smart_size.first_run: false browser.cache.disk.smart_size.use_old_max: false browser.places.smartBookmarksVersion: 6 browser.sessionstore.upgradeBackup.latestBuildID: 20140421221237 browser.startup.homepage_override.buildID: 20140421221237 browser.startup.homepage_override.mstone: 29.0 dom.mozApps.used: true extensions.lastAppVersion: 29.0 Cambria network.cookie.prefsMigrated: true places.database.lastMaintenance: 1399658226 places.history.expiration.transient_current_max_pages: 53419 plugin.disable_full_page_plugin_for_types: application/pdf plugin.importedState: true privacy.donottrackheader.enabled: true privacy.sanitize.migrateFx3Prefs: true storage.vacuum.last.index: 1 storage.vacuum.last.places.sqlite: 1399240299


Adapter Description: Intel(R) 82945G Express Chipset Family Adapter Drivers: igdumd32 Adapter RAM: Unknown Device ID: 0x2772 Direct2D Enabled: Blocked for your graphics driver version. DirectWrite Enabled: false (7.0.6002.23200) Driver Date: 6-18-2008 Driver Version: GPU #2 Active: false GPU Accelerated Windows: 0/1 Basic Vendor ID: 0x8086 WebGL Renderer: Google Inc. -- ANGLE (Intel(R) 82945G Express Chipset Family Direct3D9Ex vs_0_0 ps_2_0) windowLayerManagerRemote: false AzureCanvasBackend: skia AzureContentBackend: cairo AzureFallbackCanvasBackend: cairo AzureSkiaAccelerated: 0


Incremental GC: true


Activated: false Prevent Accessibility: 0

Library Versions

NSPR Expected minimum version: 4.10.3 Version in use: 4.10.3

NSS Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSMIME Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSSSL Expected minimum version: 3.16 Basic ECC Version in use: 3.16 Basic ECC

NSSUTIL Expected minimum version: 3.16 Version in use: 3.16

more options

I was reading a comment in one of the related crash reports that someone thought the Ebates Cash Back addon was to blame. Do you really use that addon? Could you try uninstalling it and browse for a few days and see if you don't crash? I would like to rule that out as a cause of the crash.

Also do make sure to uninstall the Ebates Cash Back addon instead of just disabling it. I would like to make sure 100% that this addon is not causing the crash. I'm a bit paranoid that disabling addons doesn't really completely disable them in all cases.

But there's some good news though! :) The 2nd crash you have has been fixed very recently and will be in Firefox 30. If don't want to wait (who would?! :P), download and install the Aurora build. It has the fix since April 28th. See: Bug 942121 - application crashed [@ js::gc::MarkUnbarriered<JSObject>(JSTracer*, JSObject**, char const*)]

Aurora download link:

Được chỉnh sửa bởi NoahSUMO vào

more options

I have uninstalled the eBates add on. I'll see in the coming days if this helps or not. I'll also check out the Aurora build. I had that before but websites seemed to "hang" a lot. So we will see! Thanks so much for the advice!