X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Can't get flash working on firefox even though plugin is installed.

Được đăng

I am trying to get flash to work with Firefox on my mac OSX 10.6.8 VM. I had an old version of flash and I just updated it. According to adobe's help page (http://helpx.adobe.com/flash-player.html), the most recent version *is* installed but the animation on that page doesn't appear, nor does any other flash-based site seem to work. In the add-ons page, shockwave flash is present, and the setting is "always activate." In every way it seems to be successfully installed, but firefox has no idea it is there. Flash works just fine for Safari. I've uninstalled and reinstalled flash completely, several times. I've restarted my VM at different points during this process. Elsewhere on this site I found advice suggesting that I try to delete pluginreg.dat. No dice. If I check the about:plugins page it states that flash is present and enabled. But it simply doesn't work.

The only possible thing I can think of is that while flash is installed in the default directory, firefox is in a custom directory. (I use this VM for automated browser testing so I have several versions of firefox installed. Flash isn't working on any of them.) Any advice?

I am trying to get flash to work with Firefox on my mac OSX 10.6.8 VM. I had an old version of flash and I just updated it. According to adobe's help page (http://helpx.adobe.com/flash-player.html), the most recent version *is* installed but the animation on that page doesn't appear, nor does any other flash-based site seem to work. In the add-ons page, shockwave flash is present, and the setting is "always activate." In every way it seems to be successfully installed, but firefox has no idea it is there. Flash works just fine for Safari. I've uninstalled and reinstalled flash completely, several times. I've restarted my VM at different points during this process. Elsewhere on this site I found advice suggesting that I try to delete pluginreg.dat. No dice. If I check the about:plugins page it states that flash is present and enabled. But it simply doesn't work. The only possible thing I can think of is that while flash is installed in the default directory, firefox is in a custom directory. (I use this VM for automated browser testing so I have several versions of firefox installed. Flash isn't working on any of them.) Any advice?

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/34.0.1847.116 Safari/537.36

Thông tin chi tiết

cor-el
  • Top 10 Contributor
  • Moderator
17531 giải pháp 158524 câu trả lời
Được đăng

Do you see the Flash plugin on the about:plugins page?

Do you see the Flash plugin on the about:plugins page?

Người tạo câu hỏi

Yeah, it's there. It says it's enabled.

Yeah, it's there. It says it's enabled.
cor-el
  • Top 10 Contributor
  • Moderator
17531 giải pháp 158524 câu trả lời
Được đăng

Did you look on the location bar for a Lego block icon that the Flash plugin is blocked?

You can inspect and manage the permissions for the domain in the currently selected tab via these steps:

  • Click the "Site Identity Button" (globe/padlock) on the location bar
  • Click "More Information" to open "Tools > Page Info" with the Security tab selected
  • Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab
Did you look on the location bar for a Lego block icon that the Flash plugin is blocked? You can inspect and manage the permissions for the domain in the currently selected tab via these steps: *Click the "[[Site Identity Button|Site Identity Button]]" (globe/padlock) on the location bar *Click "More Information" to open "Tools > Page Info" with the Security tab selected *Go to the Permissions tab (Tools > Page Info > Permissions) to check the permissions for the domain in the currently selected tab

Người tạo câu hỏi

In that permissions page, I see Adobe Flash is set to "Allow" and everything else in the tab is set to "Use Default." On the location bar there is a gray lego icon but when I click it, I am told "Adobe Flash is enabled on helpx.adobe.com" and given the option to Block Plugin or to Continue Allowing. I've tried blocking and unblocking the plugin but this doesn't fix it.

In that permissions page, I see Adobe Flash is set to "Allow" and everything else in the tab is set to "Use Default." On the location bar there is a gray lego icon but when I click it, I am told "Adobe Flash is enabled on helpx.adobe.com" and given the option to Block Plugin or to Continue Allowing. I've tried blocking and unblocking the plugin but this doesn't fix it.
user669794 59 giải pháp 672 câu trả lời
Được đăng

Hello,

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Hello, Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

Được chỉnh sửa bởi user669794 vào

Câu trả lời hữu ích

Sadly, that icon doesn't even appear for me. I can click the empty space where the icon should be and select "settings" but the settings box won't appear. I tried in the safari I have installed on the same vm, the settings box would appear but I couldn't actually click anything or make the box respond. This appears to have been a known issue with flash v10.whatever but I'm on v13. Is there another way to access this hardware acceleration option for flash? I already have it disabled for firefox.

Sadly, that icon doesn't even appear for me. I can click the empty space where the icon should be and select "settings" but the settings box won't appear. I tried in the safari I have installed on the same vm, the settings box would appear but I couldn't actually click anything or make the box respond. This appears to have been a known issue with flash v10.whatever but I'm on v13. Is there another way to access this hardware acceleration option for flash? I already have it disabled for firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17531 giải pháp 158524 câu trả lời
Được đăng
See also http://helpx.adobe.com/flash-player/kb/video-playback-issues.html

Người tạo câu hỏi

I guess you're saying it's time to file a bug report? The previous poster linked the same page, and I'd already read it for solutions I can enact myself. Again, nothing flash-related actually renders and I can't get that settings box to display in firefox. If this is related to a hardware acceleration issue, I can't change it via that settings manager GUI in firefox. I can change it in Safari, though. It either isn't a global variable or hardware acceleration isn't the problem, because disabling it through Safari changes nothing for me. I tried to search for files that change when I check or uncheck that box and nothing jumps out at me as easy to change manually in my own filesystem / from the command line.

I guess you're saying it's time to file a bug report? The previous poster linked the same page, and I'd already read it for solutions I can enact myself. Again, nothing flash-related actually renders and I can't get that settings box to display in firefox. If this is related to a hardware acceleration issue, I can't change it via that settings manager GUI in firefox. I can change it in Safari, though. It either isn't a global variable or hardware acceleration isn't the problem, because disabling it through Safari changes nothing for me. I tried to search for files that change when I check or uncheck that box and nothing jumps out at me as easy to change manually in my own filesystem / from the command line.
ceasar 0 giải pháp 1 câu trả lời
Được đăng

Just reset your fire fox to its default state i tried it and it worked.

Just reset your fire fox to its default state i tried it and it worked.
James
  • Top 25 Contributor
  • Moderator
1598 giải pháp 11287 câu trả lời
Được đăng

Reset is overkill and this was a old thread from April.

Reset is overkill and this was a old thread from April.

Người tạo câu hỏi

Actually I tried a reset and it didn't help; I think it's some vmware configuration or another not playing nice with flash but since posting I have not spent much time on it and still haven't figured it out. Thanks for the recommendation though.

Actually I tried a reset and it didn't help; I think it's some vmware configuration or another not playing nice with flash but since posting I have not spent much time on it and still haven't figured it out. Thanks for the recommendation though.
Steenie 0 giải pháp 3 câu trả lời
Được đăng

I got the box but it wouldn't let me uncheck it, yet to find a solution for this.  :(

I got the box but it wouldn't let me uncheck it, yet to find a solution for this. :(