Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Middle mouse button does not open links in a new tab.

  • 6 trả lời
  • 48 gặp vấn đề này
  • 39067 lượt xem
  • Trả lời mới nhất được viết bởi ShadowBomber

more options

If your only solution is to tell me to: 1.Restart my computer 2.Start Firefox in safemode 3.Use another hotkey to open a new tab that's not middle mouse button.

Then don't even bother replying. As I've done the first two and it made no difference and 3rd option is a solution at all.

This is frustrating and I'm slightly upset that after reading 20+ Pages of the same problem dating back from 2011 that there are no answers.

I am on a fresh install Windows XP (Yes I know old school) with firefox version 27.0.1.

Giải pháp được chọn

Cor-El I have done all of those as everyone else suggested on all of the other forums.

I plugged my mouse into another computer and it worked fine. So that lets me know its either something fishy with firefox or my computer.

As I was writing this I found out what my problem was. However I'm unsure of why. I'll explain here in case anyone else has a similar problem.

If I Middle click + Hold click for a solid second on the link it will open a new tab.

It just seems like there is a massive delay in my middle mouse click speed on this system.

Either way I'll investigate this further on my own. I appreciate all of your time.

Đọc câu trả lời này trong ngữ cảnh 👍 0

Tất cả các câu trả lời (6)

more options

hello, do you use a mouse driver that is replacing a middle-click with its own custom options?

more options

Have you checked these settings in about:config?

  • middlemouse.openNewWindow - should be true
  • middlemouse.contentLoadURL - should be false
  • middlemouse.paste - should be false
  • middlemouse.scrollbarPosition - should be false
more options

Have you tried another mouse to help rule out.

more options

finitarry I appreciate your reply as that was what I was looking for however it did not fix my problem. As it is exactly how you have it pasted.

To the other two: The mouse is the same mouse I've always used and it always worked up until this new update. It is the generic windows driver that to my knowledge hasn't been updated nor do i have any other software that has any control over the mouse. I do not have another mouse.

more options

Can you open a new tab if you hold down the Ctrl key and left-click the link?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Also make sure that all mouse buttons have the default action.

  • Windows Control Panel > Mouse
more options

Giải pháp được chọn

Cor-El I have done all of those as everyone else suggested on all of the other forums.

I plugged my mouse into another computer and it worked fine. So that lets me know its either something fishy with firefox or my computer.

As I was writing this I found out what my problem was. However I'm unsure of why. I'll explain here in case anyone else has a similar problem.

If I Middle click + Hold click for a solid second on the link it will open a new tab.

It just seems like there is a massive delay in my middle mouse click speed on this system.

Either way I'll investigate this further on my own. I appreciate all of your time.