Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

I want firefox to always open in a new session.

  • 6 trả lời
  • 1 gặp vấn đề này
  • 904 lượt xem
  • Trả lời mới nhất được viết bởi benschwab

more options

I have the setting on the general options screen for Firefox to open my home page when it starts. I would like it to do this. If I wanted it to open my previous session I would use that setting. When Firefox crashes it does this anyways. Apparently my web browser thinks that it is smarter then me. This is a problem. I've tried to have words with it but it is apparently not smart enough to make this possible. This makes the problem worse.

Even when Firefox crashes I do NOT want it to open my previous session automatically. How do I turn this feature off? If I want my previous session restored even after I crash, I am still capable of doing so through the history menu. I have Firefox 27.0.1.

Giải pháp được chọn

There is a hidden setting to stop Firefox from recovering the previous session automatically after a crash. I haven't tried it myself, but based on the documentation, this is the one you want:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionstore.resume_from_crash to switch it from true to false.

Đọc câu trả lời này trong ngữ cảnh 👍 1

Tất cả các câu trả lời (6)

more options

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash IDs to help us learn more about your crash.

  1. Enter about:crashes in the Firefox address bar and press Enter. A Submitted Crash Reports list will appear, similar to the one shown below.
  2. Copy the 5 most recent Report IDs that start with bp- and paste them into your response here.

SubmittedCrashReports-Win7

Thank you for your help!

More information and further troubleshooting steps can be found in the Troubleshoot Firefox crashes (closing or quitting unexpectedly) article.

more options

My problem isn't with the crashes. I'm sure problems that would lead to a crash are being worked on. When I open Firefox after a crash, I DO NOT want it to restore my previous session. I seam to have lost where the option to make this happen is and I can't find it again. I remember a previous version enabling me to do this. How do I get Firefox to ALWAYS open to my home page when starting?

more options

Try this go to Tools >> Options >> General and set Firefox to open the default home page(restore default) or type a link that you want.

Or try go to about:config search for browser.startup.homepage and change its value to:

about:home - the default home page
about:blank - a blank page
url - a page that you want

Được chỉnh sửa bởi Diego Victor vào

more options

Giải pháp được chọn

There is a hidden setting to stop Firefox from recovering the previous session automatically after a crash. I haven't tried it myself, but based on the documentation, this is the one you want:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste sess and pause while the list is filtered

(3) Double-click the browser.sessionstore.resume_from_crash to switch it from true to false.

more options

Thank you Mr. Victor and Mr. Edmeister. My options are already set to open to my homepage but these options only apply to when Firefox starts normally. I want options for how Firefox starts after a crash.

It seams that maybe in the about:config I want to change

browser.sessionstore.resume_from_crash

from "true" to "false"

I would rather have some reassurance before trying this myself.

more options

Thank you Mr. 2000