Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

"Don't load tabs until selected" ... Where is the setting so that it affects the tabs when I click "Open all in tabs" from History?

  • 17 trả lời
  • 19 gặp vấn đề này
  • 2019 lượt xem
  • Trả lời mới nhất được viết bởi ed1

more options

I am trying to reload all the tabs from history, it's a couple thousand. I am not concerned about system RAM I have 16GB. I know it will be slow, I'm not looking for any warnings or questions about why I have to reload that many tabs or how to work with the restore.bak sessionstore files.

The question I need an answer to is, "What setting do I need to change so that when I reload multiple tabs, it doesn't say "connecting" on all of them even though I have already selected "Don't load tabs until selected"

Được chỉnh sửa bởi stoptabsloading vào

Tất cả các câu trả lời (17)

more options

You are opening tabs from the Library dialog or History sidebar? I don't know whether there is a way to defer loading in that case.

The preference "Don't load tabs until selected" was designed for users who were starting up and reloading their previous session windows and tabs. Only the active tab in each window would be loaded immediately. This checkbox used to be on that General panel right below that setting and later was moved to the Tabs panel where that context is missing.

Perhaps someone else will have an idea for your scenario.

more options

In a window titled "library" with all the months to choose from. I right click on the month and choose "Open all in tabs".

I need the setting to apply here, to stop all those opening tabs from "connecting" or loading. I need the setting to disable automatically trying to connect to the internet when they load.

I have tried putting firefox in offline mode, disabling my ethernet/wan adapters, that does not work. I have tried numerous addons that supsend/stop tabs that are "in the background" from loading and from using memory but they do not address the issue of trying to launch them from the "library" aka history window.


Được chỉnh sửa bởi stoptabsloading vào

more options

Do you sort the history by location in the Library or by visited date?

If you use the History side bar (View > Sidebar) then you can also have the history sorted by Date and Site.
You can select multiple items if you hold down the Ctrl key and click to the left of the icon in the sidebar.

Note that Firefox includes more recent visits if you have visited a page more than once (you only see the last time you visited the URL).

more options

That did not even remotely address what I am asking for help with. I DO NOT need help opening or sorting tabs by date/location, that IS NOT what I asked.

I need to know the setting to change, so that when I restore multiple tabs from history, they do not automatically try to "connect" to the internet or load.

For example, if I restored 20 tabs from history, I would like that none of them try to load, I would like them to be "suspended" "delayed" "inactive" whatever you want to call it, until I click on it. Just like the setting for "Don't load tabs until selected" I would like to know where to add/change that setting when restoring multiple tabs from history.


Được chỉnh sửa bởi stoptabsloading vào

more options

If you already have opened tabs with those web pages then you can't prevent Firefox from opening the tabs, so the only way to proceed is to only open the pages in tabs that you want to keep and really want to open by only selecting those pages in the history. Once you have opened them then they will open, so you will have to select all tabs in the history and un-select the pages that you do not want to open and only open selected pages in tabs.

more options


Thank you for your answer even though it is a long way of saying "it can't be done". At least you understand what I am trying to do and I was already anticipating a "it can't be done, do it the long way" response. I understand I can do it the way you said, but as Will Sm-th said in the movie "The Pursuit of Happ-ness" "I found out I could save 8 seconds after every call if I didn't hangup the phone".

If I was to do it the long way you mentioned, I would have to constantly click from the tabs I am closing/opening to then select more history entries by moving the mouse while holding ctrl+shift, (of course correcting when I've selected too many or the wrong one....... it would be so tedious just to even get the tabs open it would be rediculous, not to mention sorting through them once they are all open, hence why I haven't even given it a second though to try it this way.

When firefox crashes, or when you close firefox with multiple tabs open, I'm sure you know that you can click "restore last session" upon launching firefox the next time, the tabs will load exactly the way I'M ASKING FOR. They all load WITHOUT connecting to the internet, without "loading" "connecting" "refreshing".

That's what i'm looking for, the setting that will allow me to open all the tabs the same way firefox already does by default after a crash or close with multiple tabs open.

If firefox can do it that way, when restoring a session, the fast way, thats the behavior i'm searching for; where after opening all the tabs without them trying to "connect" "refresh" one can easily 'left-click' on each tab "x" and easily go through hundreds or thousands of tabs without having to move a wrist or use another hand to hold shift+ctrl which would take exponentially longer than pushing down with your index finger on the tab "x". (hence the 8-seconds reference, but it's not 8-seconds, it's exponentially 8-seconds)


more options

does anyone know how to help me? Or is explaining to the moderator [how you would like to have firefox do something with history that it already does by default when you click on "restore last session"] like sending a plate of food back; you don't get any more service after that and are told you should just be happy with what you got even if it's not what you asked for.

Được chỉnh sửa bởi stoptabsloading vào

more options

I think we both understand what you want. And we're both saying we are not aware of any built-in way to do this.

more options

Thank you jscher,

I appreciate your response. Ok, so after taking a couple days for it to sink in, that santa isn't real and no one knows of any solution, now my next question is, could you recommend a resource, or maybe someone I could ask who might be able to help me further with this. Could I "feature request" this and where would I go and to whom would I address it?

I do not know how to code, I have never taken any classes on it, but i have been repairing computers at residences and businesses for 10 years and nothing I do for a customer came from any college course. I'm willing to research this if I knew where to look.

I know IF firefox knows how to handle tabs that way with a "restore last session", THEN there must be some way for it to open those tabs the same way when opening from history.

Maybe it's an add-on I haven't found, or a code I'd have to add myself, or something the dev's at firefox could easily implement in the next release or so, please any suggestions.

more options

The code for reading the sessionstore.js file and re-opening closed tabs is distinct from the logic for right-click > Open in a New Tab. Someone could go through that and figure out how to create tabs associated with a URL but not yet loaded. I'm not sure what would happen when you click such a tab, but if it looks just like a restored tab, Firefox might be able to handle it automatically.

This level of programming is well beyond me, however.

You could propose the idea on the Add-on forums and see whether anyone there wants to take it on.


more options

Thank you I will do that right now.

Guess my last question is: Does Mozilla offer a site where I can request this "feature" be directly implemented in firefox?

more options

Hi stoptabsloading, you could submit feature suggestions, such as deferred launching of any background tab, using one of these:

  • Input site: Help > Submit Feedback (receives thousands of comments)

That said, I don't know how to find the person who will champion a particular idea so it doesn't languish.

more options

I don't know if anyone ever answered, if not here it is: click on the menu button click on options click on tabs check the box for "Don't load tabs until selected."

more options

I was having that problem earlier, which is how I found your question.

It was checked in my options as well, but they were all trying to load at the same time (website's logo showing on the loaded ones, but the swirley with the progress bar at the top until it loaded), but it's working correctly now.


Được chỉnh sửa bởi ed1 vào

more options

Dear reader, I find it not good to post this on a other topic, But i can not find "how" to post a new topic, So I do it here in the hope someone wil rederict this post to the right topic and give me a link to it so I can folow up my problem. Sorry fore this, Frans.

Dear reader.

Firefox crasht in normal&safe mode. Already de-instal with Reno Uninstaller and re-instal, not work. Mozila Maintenance Service don't work. Crash continue. Drivers are up-date, Software is up-date. Internet Security is working and up-date. Virusscan with AVG free, Malwarebite, Super Antispyware and MCAffee On-line Scanner shows computer is clean. Memtest shows no problems. Firefox crashed first time on 13/06/2014

Crash-ID: bp-bd59f781-482f-4d77-bc0b-cda6c2140615

Crash-ID: bp-d4596c3e-a0c8-432e-b4a0-421112140615

Acer Aspire 7720G Windows Vista Home Premium, Service Pack2

I would be verry happy and gratefull to receive some help from Mozila-Firefox team.

Your truly,

Frans Wouters.

more options

Frans12 has created a new thread, so lets continue there:

more options

As to your recent modification to your original question:

"The question I need an answer to is, "What setting do I need to change so that when I reload multiple tabs, it doesn't say "connecting" on all of them even though I have already selected "Don't load tabs until selected"

Modified June 15, 2014 12:04:25 AM PDT by stoptabsloading "

The reload all command seems to work independently from the "Don't reload tab until selected" setting.