X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

Firefox hangs on the default Start Page

Được đăng

Hey. I'm having a rather odd problem where Firefox hangs for about ten seconds while loading the default home page. It has worked just fine for years, and then suddenly yesterday every time I open a new tab or start Firefox (basically anything that would take me to the start page,) I get a 10-15 second hang. I've confirmed this by changing the homepage to the old "http://www.google.com/firefox" which completely fixes the issue. No other pages do it, only the start page.

I've tried safe mode, but I knew it wouldn't yield any results as I've not changed configuration in any way for years. I've tried updating to the most recent version of Firefox, this also had no effect. I tried backing up my profile and resetting Firefox, of course still no effect. Finally I tried completely uninstalling all Mozilla products, then sweeping the registry for any of their keys, then reinstalling it all. Still hangs on the start page. So that this point I just restored my backed up profiles, scratched my head and came here.

The obvious solution would be to change homepage, but I can't let it beat me. =P

Anyone have any ideas? I'm pretty stumped at this point.

Hey. I'm having a rather odd problem where Firefox hangs for about ten seconds while loading the default home page. It has worked just fine for years, and then suddenly yesterday every time I open a new tab or start Firefox (basically anything that would take me to the start page,) I get a 10-15 second hang. I've confirmed this by changing the homepage to the old "http://www.google.com/firefox" which completely fixes the issue. No other pages do it, only the start page. I've tried safe mode, but I knew it wouldn't yield any results as I've not changed configuration in any way for years. I've tried updating to the most recent version of Firefox, this also had no effect. I tried backing up my profile and resetting Firefox, of course still no effect. Finally I tried completely uninstalling all Mozilla products, then sweeping the registry for any of their keys, then reinstalling it all. Still hangs on the start page. So that this point I just restored my backed up profiles, scratched my head and came here. The obvious solution would be to change homepage, but I can't let it beat me. =P Anyone have any ideas? I'm pretty stumped at this point.

Được chỉnh sửa bởi Diriel vào

Giải pháp được chọn

Like philipp mentioned, there was an issue with a snippet uploaded yesterday. The snippet (which appears below the search bar on about:home) had an icon that causes the browser to freeze for a bit while it attempts to display it.

We've disabled the snippet, but if you're already seeing the slowdowns, it will take up to 24 hours for your browser to fetch new snippets and remove the slow one. However, you can force an update and get rid of it immediately like so:

  1. Visit about:home.
  2. Open up the web console (Cmd+Option+K on Mac, Ctrl+Shift+K on Windows I believe. You can also use the menu item Tools -> Web Developer -> Web Console).
  3. Enter the following in the console, and then hit Enter/Return:
    gSnippetsMap.clear()
    • Note: On older versions of Firefox (anything prior to Firefox 25), this line may not work and display an error in the console. If it doesn't work for you, try entering this line instead:
      localStorage['snippets-last-update'] = 0
  4. Clear your cache by going to History -> Clear recent history, selecting only the Cache checkbox, and setting the time to "Everything".
  5. Refresh about:home and it should fetch new snippets and no longer freeze up.

To keep this from happening again, we're working on a feature that will warn admins if they make snippets that are too large (https://bugzilla.mozilla.org/show_bug.cgi?id=963248).https://bugzilla.mozilla.org/show_bug.cgi?id=963248 {also note etiquette] edit & fixed link ~J99 Sorry that we made your Firefox slow! :(

Đọc câu trả lời này trong ngữ cảnh 6

Chi tiết hệ thống bổ sung

Phần bổ trợ đã cài đặt

  • Shockwave Flash 12.0 r0
  • Next Generation Java Plug-in 10.51.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • VLC media player Web Plugin 2.0.6
  • Foxit Reader Plug-In For Firefox and Netscape
  • Plugin for Wacom tablets.
  • Wacom Dynamic Link Library

Ứng dụng

  • Firefox 26.0
  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
  • URL hỗ trợ: https://support.mozilla.org/1/firefox/26.0/WINNT/en-US/

Tiện ích mở rộng

  • Adblock Plus 2.4.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Advertising Cookie Opt-out 1.5 (optout@google.com)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • FoxyProxy Standard 4.2.3 (foxyproxy@eric.h.jung)
  • Tab Mix Plus 0.4.1.2.02 ({dc572301-7619-498c-a57d-39143191b318})
  • Transparent standalone images initial.rev29 (jid0-ezUl0hF1SPM9hLO5BMBkNoblB8s@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Đồ họa

  • adapterDescription: AMD Radeon HD 7700 Series
  • adapterDescription2:
  • adapterDeviceID: 0x683d
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-20-2013
  • driverDate2:
  • driverVersion: 12.100.17.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7700 Series Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Thay đổi cài đặt

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.newtab.url: about:blank
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131205075310
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20131205075310
  • browser.startup.homepage_override.mstone: 26.0
  • browser.tabs.drawInTitlebar: False
  • browser.tabs.insertRelatedAfterCurrent: False
  • browser.tabs.onTop: False
  • browser.tabs.warnOnClose: False
  • browser.urlbar.formatting.enabled: False
  • browser.urlbar.trimURLs: False
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 26.0
  • font.internaluseonly.changed: True
  • gfx.direct2d.disabled: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • gfx.font_rendering.cleartype.use_for_downloadable_fonts: False
  • gfx.font_rendering.cleartype_params.cleartype_level: 0
  • gfx.font_rendering.cleartype_params.enhanced_contrast: 0
  • gfx.font_rendering.cleartype_params.force_gdi_classic_for_families:
  • gfx.font_rendering.cleartype_params.force_gdi_classic_max_size: 0
  • gfx.font_rendering.cleartype_params.gamma: 0
  • gfx.font_rendering.cleartype_params.pixel_structure: 0
  • gfx.font_rendering.cleartype_params.rendering_mode: 0
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • network.dns.disablePrefetch: True
  • places.database.lastMaintenance: 1390410056
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1302607916
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npdeployjava: 0
  • plugin.state.npintelwebapiipt: 0
  • plugin.state.npintelwebapiupdater: 0
  • plugin.state.npunity3d: 0
  • plugin.state.npuplaypc: 0
  • plugin.state.npuplaypchub: 0
  • plugin.state.npwatweb: 0
  • privacy.cpd.cookies: False
  • privacy.cpd.extensions-tabmix: True
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.cpd.siteSettings: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1390044413

Linh tinh

  • Người dùng JS: Có
  • Có thể tiếp cận: Có
cor-el
  • Top 10 Contributor
  • Moderator
17583 giải pháp 159079 câu trả lời
Được đăng

Is that a web based page (what URL?) or the built-in about:home page that shows as your home page setting?

I can hardly understand that you would have a problem with the about:home page unless there would be a problem with the snippets that Firefox displays on the page.

You can delete the storage\moz-safe-about+home folder in the Firefox profile folder to reset snippets stored in IndexedDB.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder)
Is that a web based page (what URL?) or the built-in about:home page that shows as your home page setting? I can hardly understand that you would have a problem with the about:home page unless there would be a problem with the snippets that Firefox displays on the page. You can delete the storage\moz-safe-about+home folder in the Firefox profile folder to reset snippets stored in IndexedDB.<br /> You can use this button to go to the Firefox profile folder: *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox
Christopher4636 0 giải pháp 3 câu trả lời
Được đăng

I have the 'exact' same problem. The default Firefox startpage/homepage causes a 5-10 second hang on opening and the only solution I've found so far is to change my homepage. However I find the shortcut icons for things like 'restore last session' rather handy on the default home page so I'd really like to fix this.

I'm gonna take a stab in the dark and suggest it's quite a widespread issue with the homepage but the only thing I can think of is it has something to do with the Google search bar it features. I've tried deleting the 'storage\moz-safe-about+home' folder but that does not make a difference.

My Firefox load time is usually instantaneous so I find even a 5 second hang unacceptable.

I have the 'exact' same problem. The default Firefox startpage/homepage causes a 5-10 second hang on opening and the only solution I've found so far is to change my homepage. However I find the shortcut icons for things like 'restore last session' rather handy on the default home page so I'd really like to fix this. I'm gonna take a stab in the dark and suggest it's quite a widespread issue with the homepage but the only thing I can think of is it has something to do with the Google search bar it features. I've tried deleting the 'storage\moz-safe-about+home' folder but that does not make a difference. My Firefox load time is usually instantaneous so I find even a 5 second hang unacceptable.
cor-el
  • Top 10 Contributor
  • Moderator
17583 giải pháp 159079 câu trả lời
Được đăng

Just to confirm: is this an issue with the about:home page or with another page

I usually set the browser.aboutHomeSnippets.updateUrl pref to an empty string on the about:config page. You need to delete storage\moz-safe-about+home to remove already stored snippets.

Just to confirm: is this an issue with the about:home page or with another page I usually set the browser.aboutHomeSnippets.updateUrl pref to an empty string on the <b>about:config</b> page. You need to delete storage\moz-safe-about+home to remove already stored snippets.

Được chỉnh sửa bởi cor-el vào

GreenOracle 1 giải pháp 6 câu trả lời
Được đăng

Chalk me up as another person with the EXACT same problem.

Has nothing to do with addons and extensions. This I can confirm by a vanilla clean install of Firefox 26.0 on a Windows XP SP3 virtual machine which does NOT have Flash, Acrobat, Java, Silverlight installed... nor any Extensions installed... nor Sync set up....

Chalk me up as another person with the EXACT same problem. Has nothing to do with addons and extensions. This I can confirm by a vanilla clean install of Firefox 26.0 on a Windows XP SP3 ''virtual machine'' which does NOT have Flash, Acrobat, Java, Silverlight installed... nor any Extensions installed... nor Sync set up....
philipp
  • Top 25 Contributor
  • Moderator
5324 giải pháp 23509 câu trả lời
Được đăng

apparently there are server-side issues with the snippet service: https://bugzilla.mozilla.org/show_bug.cgi?id=962885

apparently there are server-side issues with the snippet service: https://bugzilla.mozilla.org/show_bug.cgi?id=962885
philipp
  • Top 25 Contributor
  • Moderator
5324 giải pháp 23509 câu trả lời
Được đăng

the problem should go away by itself within 24 hours (that's when firefox automatically fetches a new snippets).

in order to resolve the issue manually please perform the steps described by mkelly in comment #9 of 962885.

the problem should go away by itself within 24 hours (that's when firefox automatically fetches a new snippets). in order to resolve the issue manually please perform the steps described by mkelly in [https://bugzilla.mozilla.org/show_bug.cgi?id=962885#c9 comment #9 of 962885].
Michael Kelly 1 giải pháp 4 câu trả lời
Được đăng

Giải pháp được chọn

Like philipp mentioned, there was an issue with a snippet uploaded yesterday. The snippet (which appears below the search bar on about:home) had an icon that causes the browser to freeze for a bit while it attempts to display it.

We've disabled the snippet, but if you're already seeing the slowdowns, it will take up to 24 hours for your browser to fetch new snippets and remove the slow one. However, you can force an update and get rid of it immediately like so:

  1. Visit about:home.
  2. Open up the web console (Cmd+Option+K on Mac, Ctrl+Shift+K on Windows I believe. You can also use the menu item Tools -> Web Developer -> Web Console).
  3. Enter the following in the console, and then hit Enter/Return:
    gSnippetsMap.clear()
    • Note: On older versions of Firefox (anything prior to Firefox 25), this line may not work and display an error in the console. If it doesn't work for you, try entering this line instead:
      localStorage['snippets-last-update'] = 0
  4. Clear your cache by going to History -> Clear recent history, selecting only the Cache checkbox, and setting the time to "Everything".
  5. Refresh about:home and it should fetch new snippets and no longer freeze up.

To keep this from happening again, we're working on a feature that will warn admins if they make snippets that are too large (https://bugzilla.mozilla.org/show_bug.cgi?id=963248).https://bugzilla.mozilla.org/show_bug.cgi?id=963248 {also note etiquette] edit & fixed link ~J99 Sorry that we made your Firefox slow! :(

Like philipp mentioned, there was an issue with a snippet uploaded yesterday. The snippet (which appears below the search bar on about:home) had an icon that causes the browser to freeze for a bit while it attempts to display it. We've disabled the snippet, but if you're already seeing the slowdowns, it will take up to 24 hours for your browser to fetch new snippets and remove the slow one. However, you can force an update and get rid of it immediately like so: # Visit about:home. # Open up the web console (Cmd+Option+K on Mac, Ctrl+Shift+K on Windows I believe. You can also use the menu item Tools -> Web Developer -> Web Console). # Enter the following in the console, and then hit Enter/Return:<br> <code>gSnippetsMap.clear()</code><ul><li>'''Note:''' On older versions of Firefox (anything prior to Firefox 25), this line may not work and display an error in the console. If it doesn't work for you, try entering this line instead: <br><code>localStorage['snippets-last-update'] = 0</code> </li></ul> # Clear your cache by going to History -> Clear recent history, selecting only the Cache checkbox, and setting the time to "Everything". # Refresh about:home and it should fetch new snippets and no longer freeze up. To keep this from happening again, we're working on a feature that will warn admins if they make snippets that are too large <s>(https://bugzilla.mozilla.org/show_bug.cgi?id=963248).</s>''https://bugzilla.mozilla.org/show_bug.cgi?id=963248 {<sub>also note [https://bugzilla.mozilla.org/page.cgi?id=etiquette.html etiquette]] edit & fixed link ~J99<sub>'' Sorry that we made your Firefox slow! :(

Được chỉnh sửa bởi John99 vào

Người tạo câu hỏi

I had figured that this was a server-side issue due to the sudden and unprovoked nature of the issue.

For anyone else having this problem; Michael Kelly's solution works perfectly.

Thanks man, I guess we'll not be seeing any more SVG icons. =P

I had figured that this was a server-side issue due to the sudden and unprovoked nature of the issue. For anyone else having this problem; Michael Kelly's solution works perfectly. Thanks man, I guess we'll not be seeing any more SVG icons. =P
Christopher4636 0 giải pháp 3 câu trả lời
Được đăng

That works a treat, thanks for the solution.

That works a treat, thanks for the solution.
Smiles 0 giải pháp 3 câu trả lời
Được đăng

Not helpful. When entering the code I get ReferenceError: gSnippetsMap is not defined. The other code replies with 0 then doesn't help. I would adore it if someone has another solution? I love Firefox but if it keeps doing this and on my phone I will have to delete it.

Not helpful. When entering the code I get ReferenceError: gSnippetsMap is not defined. The other code replies with 0 then doesn't help. I would adore it if someone has another solution? I love Firefox but if it keeps doing this and on my phone I will have to delete it.

Được chỉnh sửa bởi Smiles vào

Michael Kelly 1 giải pháp 4 câu trả lời
Được đăng

Mei-Silja: Did you try using

localStorage['snippets-last-update'] = 0

instead? I mentioned it in a note because older versions of Firefox will get exactly the error you mentioned.

(It should disappear in about 6 hours anyway, so this may not be relevant).

Mei-Silja: Did you try using <code>localStorage['snippets-last-update'] = 0</code> instead? I mentioned it in a note because older versions of Firefox will get exactly the error you mentioned. (It should disappear in about 6 hours anyway, so this may not be relevant).
eknirb 0 giải pháp 1 câu trả lời
Được đăng

yep, this worked. PS, how do I change my user name, I entered it incorrectlywhen I signed up.

yep, this worked. PS, how do I change my user name, I entered it incorrectlywhen I signed up.
Smiles 0 giải pháp 3 câu trả lời
Được đăng

Câu trả lời hữu ích

-Pokes up- I did, and its reply is simply 0 then does nothing. My firefox version is also not old, I just downloaded a new instillation trying to fix this.

-Pokes up- I did, and its reply is simply 0 then does nothing. My firefox version is also not old, I just downloaded a new instillation trying to fix this.
Michael Kelly 1 giải pháp 4 câu trả lời
Được đăng

That's really odd, then, because on newer versions of Firefox you should get an error message when trying to run that line (localStorage is disabled in about:home starting in Firefox 25).

Either way, after it shows 0, it doesn't do anything on its own; you have to clear the cache (step 4 from my instructions) and then refresh about:home, and the freezing should disappear.

One thing to note is that you must run the localStorage line in the Web Console, and then clear the cache without reloading about:home in the meantime, so if you go back to clear your cache, make sure you re-run the line in the Web Console as well so that they're both reset when you refresh about:home.

If you're still seeing freezing even after that, then there may be something up with your Firefox profile or something, which is something normal support posters have way more experience giving advice on than I do.

Let me know how it goes!

That's really odd, then, because on newer versions of Firefox you should get an error message when trying to run that line (localStorage is disabled in about:home starting in Firefox 25). Either way, after it shows 0, it doesn't do anything on its own; you have to clear the cache (step 4 from my instructions) and then refresh about:home, and the freezing should disappear. One thing to note is that you must run the localStorage line in the Web Console, and then clear the cache without reloading about:home in the meantime, so if you go back to clear your cache, make sure you re-run the line in the Web Console as well so that they're both reset when you refresh about:home. If you're still seeing freezing even after that, then there may be something up with your Firefox profile or something, which is something normal support posters have way more experience giving advice on than I do. Let me know how it goes!
cor-el
  • Top 10 Contributor
  • Moderator
17583 giải pháp 159079 câu trả lời
Được đăng

Deleting the storage\moz-safe-about+home folder in the Firefox profile folder with Firefox closed should also remove all snippets stored in IndexedDB.

Deleting the storage\moz-safe-about+home folder in the Firefox profile folder with Firefox closed should also remove all snippets stored in IndexedDB.
Smiles 0 giải pháp 3 câu trả lời
Được đăng

Thank you so much cor-el!~ That worked in two seconds for both my devices. -Hugs- Thank you so much!

Thank you so much cor-el!~ That worked in two seconds for both my devices. -Hugs- Thank you so much!
renoir-3 0 giải pháp 1 câu trả lời
Được đăng

Hello to all. I noticed the same problem with Firefox yesterday. The default start page was hanging for about 3-4 seconds when i was pressing the home button. I tried the chosen solution but the problem was still there. In my case the issue was the Adblock Plus add-on. When i disable ABP the page load instantly. I changed my home page to "about:newtab" as a temporary solution.

Hello to all. I noticed the same problem with Firefox yesterday. The default start page was hanging for about 3-4 seconds when i was pressing the home button. I tried the chosen solution but the problem was still there. In my case the issue was the Adblock Plus add-on. When i disable ABP the page load instantly. I changed my home page to "about:newtab" as a temporary solution.