X
Nhấn vào đây để đến phiên bản di động của trang web.

Diễn đàn trợ giúp

"Firefox prevented this page from automatically redirecting to another page"

Được đăng

I read the solution to this from various posts but there's a problem with that solution.

Tools>Options>Advanced>"Warn me when websites try to redirect or reload a page"

Un-checking the redirect block is a Global setting. I want to know how to allow redirect/reload pages for sites I use every day as friendly sites. I do not want to turned off for the entire world wide web. Otherwise, why even have this security setting at all? I've already added my usual sites to my Privacy exception list hoping that will work but that list is ignored by the redirect security warning. The "Allow" popup is a real pain so the entire feature has to be disabled. Like I said, what's the point of having this feature.

Firefox - Please provide an exception list for Redirect warnings.

.

[Profanity removed by moderator. Please read Forum rules and guidelines, thanks.]

I read the solution to this from various posts but there's a problem with that solution. Tools>Options>Advanced>"Warn me when websites try to redirect or reload a page" Un-checking the redirect block is a Global setting. I want to know how to allow redirect/reload pages for sites I use every day as friendly sites. I do not want to turned off for the entire world wide web. Otherwise, why even have this security setting at all? I've already added my usual sites to my Privacy exception list hoping that will work but that list is ignored by the redirect security warning. The "Allow" popup is a real pain so the entire feature has to be disabled. Like I said, what's the point of having this feature. Firefox - Please provide an exception list for Redirect warnings. . ''[Profanity removed by moderator. Please read [[Forum rules and guidelines]], thanks.]''

Được chỉnh sửa bởi Chris Ilias vào

Chi tiết hệ thống bổ sung

Ứng dụng

  • Chuỗi đại diện người dùng: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36

Thông tin chi tiết

philipp
  • Top 25 Contributor
  • Moderator
5320 giải pháp 23501 câu trả lời
Được đăng

hello Guaps, the setting isn't meant as a security feature per se but to help users with accessibility challenges to avoid confusion when pages change suddenly.

you might want to use an extension for that purpose instead - there's https://addons.mozilla.org/firefox/addon/refreshblocker/ and i think noscript and requestpolicy would have such a functionality too...

hello Guaps, the setting isn't meant as a security feature per se but to help users with accessibility challenges to avoid confusion when pages change suddenly. you might want to use an extension for that purpose instead - there's https://addons.mozilla.org/firefox/addon/refreshblocker/ and i think noscript and requestpolicy would have such a functionality too...
cldjr 0 giải pháp 17 câu trả lời
Được đăng

I don't have any extention to prevent this but since few days I have constantly a pop up telling me that “Firefox prevented this page from automatically redirecting to an other page” (Firefox 26.0 on Mac OS X 10.9.1) As soon as I click Allow, the pop up reappear asking the same question. Anyway the page loaded doesn’t redirecting me to any other page at all. I use the web site for years without any trouble and now I got constantly this boring pop up... How to disable this ?

I don't have any extention to prevent this but since few days I have constantly a pop up telling me that “'''Firefox prevented this page from automatically redirecting to an other page'''” (Firefox 26.0 on Mac OS X 10.9.1) As soon as I click '''Allow''', the pop up reappear asking the same question. Anyway the page loaded doesn’t redirecting me to any other page at all. I use the web site for years without any trouble and now I got constantly this boring pop up... How to disable this ?
jscher2000
  • Top 10 Contributor
8785 giải pháp 71847 câu trả lời
Được đăng

Hi cldjr, on Mac, try here:

Firefox menu > Preferences > Advanced > General mini-tab > Accessibility section

Uncheck the box for "Warn me when websites try to redirect or reload a page"

Hi cldjr, on Mac, try here: Firefox menu > Preferences > Advanced > General mini-tab > Accessibility section Uncheck the box for "Warn me when websites try to redirect or reload a page"
jscher2000
  • Top 10 Contributor
8785 giải pháp 71847 câu trả lời
Được đăng

Hi cldjr, one other thought.

Now that Firefox will be redirecting normally, you may see a message saying that a page is trying to redirect in a way that will never complete, or something along those lines. In that case, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Command+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

Firefox menu > Preferences > Advanced > Network mini-tab

In the Cached Web Content section click "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

Hi cldjr, one other thought. Now that Firefox will be redirecting normally, you may see a message saying that a page is trying to redirect in a way that will never complete, or something along those lines. In that case, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Use Command+Shift+r to reload the page fresh from the server. Alternately, you also can clear Firefox's cache completely using: Firefox menu > Preferences > Advanced > Network mini-tab In the Cached Web Content section click "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Tools menu > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page. Does that help?
cldjr 0 giải pháp 17 câu trả lời
Được đăng

Firefox menu > Preferences > Advanced > General mini-tab > Accessibility section Uncheck the box for "Warn me when websites try to redirect or reload a page"

Unfortunately this doesn't exist on Firefox 26.0 under OS X Maverics...

''Firefox menu > Preferences > Advanced > General mini-tab > Accessibility section Uncheck the box for "Warn me when websites try to redirect or reload a page" '' Unfortunately this doesn't exist on Firefox 26.0 under OS X Maverics...
cor-el
  • Top 10 Contributor
  • Moderator
17567 giải pháp 158894 câu trả lời
Được đăng
See https://support.mozilla.org/kb/advanced-settings-browsing-network-updates-encryption
cldjr 0 giải pháp 17 câu trả lời
Được đăng

Thank you. It's confirm what I said before: no such option on Firefox 26.0 under Mavericks.

Thank you. It's confirm what I said before: no such option on Firefox 26.0 under Mavericks.
jscher2000
  • Top 10 Contributor
8785 giải pháp 71847 câu trả lời
Được đăng

You don't have the top section, or that options is missing from the top section?

I see from this screen shot that on Mac "General" looks more like a button than a tab...

You don't have the top section, or that options is missing from the top section? <img src="https://support.cdn.mozilla.net/media/uploads/gallery/images/2013-07-11-16-33-04-27252e.png"> I see from this screen shot that on Mac "General" looks more like a button than a tab...
cbreeez 0 giải pháp 1 câu trả lời
Được đăng

I had this problem when trying to use the Tangerine banking site. The solution was so simple I couldn't believe it. Just ignore it. That's right. Don't do anything to it. Treat it as if the information box from Firefox isn't there. Go on about your banking as usual. Let me know if it works for you. It did for me.

I had this problem when trying to use the Tangerine banking site. The solution was so simple I couldn't believe it. Just ignore it. That's right. Don't do anything to it. Treat it as if the information box from Firefox isn't there. Go on about your banking as usual. Let me know if it works for you. It did for me.
ronalds173 0 giải pháp 7 câu trả lời
Được đăng

I also have this problem. Additionally, when I click on "Allow" I am automatically disconnected from the (secure) website I have logged into. It's very frustrating.

I also have this problem. Additionally, when I click on "Allow" I am automatically disconnected from the (secure) website I have logged into. It's very frustrating.
jscher2000
  • Top 10 Contributor
8785 giải pháp 71847 câu trả lời
Được đăng

Câu trả lời hữu ích

Hi ronalds173, did you try switching the setting in Options? Note that in Firefox 29, the way to access the dialog has changed. These should work:

  • "3-bar" menu button > Options > Advanced panel > General mini-tab
  • If you display the classic menu bar:
    • Windows: Tools > Options > Advanced panel > General mini-tab
    • Mac: Firefox > Preferences > Advanced panel > General mini-tab
Hi ronalds173, did you try switching the setting in Options? Note that in Firefox 29, the way to access the dialog has changed. These should work: * "3-bar" menu button > Options > Advanced panel > General mini-tab * If you display the classic menu bar: ** Windows: Tools > Options > Advanced panel > General mini-tab ** Mac: Firefox > Preferences > Advanced panel > General mini-tab