Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

On a Mac I want to use Preview as default to read PDF's, and Firefox won't let me use anything but Adobe Reader. How to change?

  • 8 trả lời
  • 2 gặp vấn đề này
  • 396 lượt xem
  • Trả lời mới nhất được viết bởi rat_snake

more options

It had been working properly until recently. I have tried the usual setting in firefox>preferences>applications. It accepts Preview as default, but uses Adobe anyway. If I set it to Ask, it does ask me, and when I tell it to use Preview it uses Adobe.

Desired default operation is download PDF's and open with Preview.

Tất cả các câu trả lời (8)

more options

Sometimes plugins seem to preempt external viewers despite your preference. This could indicate a corrupted preferences file, but as a shortcut to troubleshooting that, if you never want to use the Adobe Plugin, you can set it to "Never Activate" on the Add-ons page. Either:

  • Command+Shift+a
  • Tools menu > Add-ons

In the left column, click Plugins. It should be near the top of the list. Does that work?

more options

No.

My apologies, as I had failed to mention that I had already set it to never activate, and checked that.

I should mention that the OS correctly uses Preview when I open a PDF. Also, I have tried restarting Firefox, too.

So, how do I un-corrupt the preferences file?

more options

The file that stores your preferences for how to open downloads is named mimeTypes.rdf. Since it has a somewhat inscrutable format, the usual remedy is to rename it and have Firefox generate a new one.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show in Finder" button

Leaving Finder open, switch back to Firefox and Quit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox and reselect your preference. Any improvement?

more options

I cannot locate any file named mimeTypes.rdf.

Perhaps it has a different name?

more options

Did Firefox open the correct folder? You would find very up-to-date files such as:

  • places.sqlite (database that stores bookmarks and history)
  • prefs.js (file that stores most of your Firefox preferences)

I only have experience with Windows, but I'm not aware of any difference in file naming conventions on Mac.

more options

I simply tried to use the OS to find a file with that name anywhere under my home directory and all its sub-directories. When that failed, I tried the search on the whole computer, with same null result.

I do find file names containing the following strings: mim place prefs. So, the search utility seems to be working. However, if I get more specific, then it returns a null search result.

more options

The reason you can't find the file in a general search is that your application folders are hidden by the OS. Please use the "Show in Finder" button on the Troubleshooting Information page as I described.

more options

Ah yes. I was following your instructions too literally and not recognizing that I was looking for a hidden file. It works fine now. Thanks.

By the way, the button that says "mark it as solved" takes me to a Mozilla "page not found" page.