Tìm kiếm hỗ trợ

Tránh các lừa đảo về hỗ trợ. Chúng tôi sẽ không bao giờ yêu cầu bạn gọi hoặc nhắn tin đến số điện thoại hoặc chia sẻ thông tin cá nhân. Vui lòng báo cáo hoạt động đáng ngờ bằng cách sử dụng tùy chọn "Báo cáo lạm dụng".

Learn More

Firefox keeps automatically deleting my cookies

  • 5 trả lời
  • 12 gặp vấn đề này
  • 6279 lượt xem
  • Trả lời mới nhất được viết bởi cor-el

more options

Firefox keeps automatically deleting my cookies (same thread I found from 2010; followed all instructions there (not that there were many.... or helpful... or clear...) and still have same issue.

Tất cả các câu trả lời (5)

more options

Make sure you not running Firefox in (permanent) Private Browsing mode.


Tools > Options > Privacy > Firefox will: "Use custom settings for history"

  • Deselect: [ ] "Always use private browsing mode"

If you not using Private Browsing Mode

  • Tools > Options > Privacy > History>
  • Firefox will: "Use custom settings for history":
  • Select: [x] Accept Cookies from sites
    • Accpet third party cookies: "From Visites"
  • Keep until "They Expire"
  • Deselect: [ ] "Clear history when Firefox closes"
  • https://support.mozilla.org/kb/Clear+Recent+History

If you use cleanup software like CCleaner then check the settings for the Firefox application.

more options

In case you are using "Clear history when Firefox closes":

  • do not clear the Cookies
  • do not clear the Site Preferences

Note that clearing "Site Preferences" clears all exceptions for cookies, images, pop-up windows, software installation, and passwords.

Clearing cookies will remove all specified (selected) cookies including cookies with an allow exception that you want to keep.

If you use cleanup software like CCleaner then check the settings for the Firefox application.


If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

more options

This information already appeared in the last thread (I mentioned), and there was no need to repeat it, as obviously I have already tried this, and made sure my setting does not indicate erasing cookies upon logout. Also: 1. I did not clear site preference or cleared cookies. 2. I did use CCleaner, but after that I visited sites and re-established my cookies (or so I thought). 3. Apparently this cleared cookies phenomena does not happen on all sites, but at some of the sites (where I need to re-establish logins each time). In short... Still puzzled...

more options

This information already appeared in the last thread (I mentioned), and there was no need to repeat it, as obviously I have already tried this, and made sure: 1. my setting does not indicate erasing cookies upon logout; 2. my setting is on the “remember History”; 3. I also checked the custom setting, just in case, which is set to all of the above (what you instructed). Also: I did use CCleaner (once), but after that I visited sites and re-established my cookies (or so I thought); still with no success; apparently this cleared cookies phenomena does not happen on all sites, but at some of the sites (where I need to re-establish logins each time). In short... Still puzzled...

more options

It can always be possible that CCleaner corrupted the cookies.sqlite file when clearing the cookies, so best is always to use built-in Firefox means instead of external applications.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.